Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » OSEE » Connect to the OSEE Application-Server
Connect to the OSEE Application-Server [message #493492] Mon, 26 October 2009 14:18 Go to next message
HtwTeam  is currently offline HtwTeam Friend
Messages: 2
Registered: October 2009
Junior Member
I tried to connect to the OSEE Application-Server with an own client.
Unforunately the documentation does not cover this topic.

The following topics are interessting for me:
- How to connect to the applications Server (we use the local server)?
- How to add/edit/delete artifacts?
Re: Connect to the OSEE Application-Server [message #493807 is a reply to message #493492] Wed, 28 October 2009 06:45 Go to previous messageGo to next message
Nirmal SasidharanFriend
Messages: 120
Registered: July 2009
Location: Germany
Senior Member
Hi,

Did you download OSEE 0.7.0 from http://osee.microdoc.com/node/2 and follow the instructions "Installation & Initialization" in the Wiki?

What is the exact error you are getting?

To delete artifacts simply right click on the artifact and click "Delete Artifact" or use the "Delete". If you meant how to delete artifact types from database, follow the step here http://wiki.eclipse.org/OSEE/Users_Guide/Tips#How_do_I_delet e_artifact_types.3F

Hope this helps,

Regards,
Nirmal
Re: Connect to the OSEE Application-Server [message #493874 is a reply to message #493492] Wed, 28 October 2009 10:48 Go to previous messageGo to next message
HTWTeam  is currently offline HTWTeam Friend
Messages: 6
Registered: October 2009
Junior Member
Hi Nirmal,

thank you for your reply.

I'm sorry for my inaccurate question. We downloaded and installed the all-in-one package for 0.7 and could successfully install and use OSEE with it, but that's not where our problem lies.

We want to program our very own OSEE client which uses the OSEE API to communicate and interact with the OSEE Application Server running in the background, offering a web service which allows OSEE to be integrated into some other automated software engineering tool framework. This framework interacts with the SE tools via web service events, so we want to write an adapter that translates those events into OSEE application server API calls.
Alas, there seems to be no documentation on the API and the documentation covering the architecture seems to be bit dated, as we were not able to find some of the methods in the sequence diagrams.

We tried to write a small test program which connects to a local running OSEE application server, but we couldn't get it to work and are a bit helpless right now.

So if anyone knows something about the API or how to program a client for OSEE, please let us know.

[Updated on: Wed, 28 October 2009 12:44]

Report message to a moderator

Re: Connect to the OSEE Application-Server [message #495223 is a reply to message #493874] Wed, 04 November 2009 09:25 Go to previous message
Nirmal SasidharanFriend
Messages: 120
Registered: July 2009
Location: Germany
Senior Member
I doubt if you would find any documentation regarding this. The current OSEE client implementation would be the best example you could look into. Needless to say, try debugging it (I am sure you would had done this already)

All the best,

Nirmal
Re: Connect to the OSEE Application-Server [message #575970 is a reply to message #493492] Wed, 28 October 2009 06:45 Go to previous message
Nirmal SasidharanFriend
Messages: 120
Registered: July 2009
Location: Germany
Senior Member
Hi,

Did you download OSEE 0.7.0 from http://osee.microdoc.com/node/2 and follow the instructions "Installation & Initialization" in the Wiki?

What is the exact error you are getting?

To delete artifacts simply right click on the artifact and click "Delete Artifact" or use the "Delete". If you meant how to delete artifact types from database, follow the step here http://wiki.eclipse.org/OSEE/Users_Guide/Tips#How_do_I_delet e_artifact_types.3F

Hope this helps,

Regards,
Nirmal
Re: Connect to the OSEE Application-Server [message #575986 is a reply to message #493492] Wed, 28 October 2009 10:48 Go to previous message
HTWTeam  is currently offline HTWTeam Friend
Messages: 6
Registered: October 2009
Junior Member
Hi Nirmal,

thank you for your reply.

Yes, we downloaded the OSEE 0.7.0 All-In-One package and followed the "Installation & Initialization" instructions in the Wiki.
We are getting no errors. With the OSEE Eclipse Client we can connect to the Application Server and edit the artifacts.

Our problem is that we are want to develop an own client (service based without a GUI) that communicates with the application server and edit for example the artifacts.
But we are don't know how we can connect to the application server from a simple java application.
Re: Connect to the OSEE Application-Server [message #576041 is a reply to message #575986] Wed, 04 November 2009 09:25 Go to previous message
Nirmal SasidharanFriend
Messages: 120
Registered: July 2009
Location: Germany
Senior Member
I doubt if you would find any documentation regarding this. The current OSEE client implementation would be the best example you could look into. Needless to say, try debugging it (I am sure you would had done this already)

All the best,

Nirmal
Previous Topic:Connect to the OSEE Application-Server
Next Topic:OSEE 0.8.3 application server & PostgreSQL
Goto Forum:
  


Current Time: Thu Nov 27 07:07:26 GMT 2014

Powered by FUDForum. Page generated in 0.03374 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software