Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DSDP - Mobile Tools for Java (MTJ) » MJT and Java ME SDK 3.0(MJT does not find any devices in Java ME SDK 3)
MJT and Java ME SDK 3.0 [message #493333] Sat, 24 October 2009 18:51 Go to next message
Markus M is currently offline Markus M
Messages: 6
Registered: July 2009
Junior Member
Hi,

I am trying to configure MJT with Java ME SDK 3.0. Unfortunately, I do not succeed in configuring/adding any devices.
As explained in the different tutorials, I try to add an SDK to MJT using the Java ME tab in Eclipse's preferences (Windows->Preferences->Java ME). There, I enter the path to my Java ME SDK 3.0 installation folder and MJT starts to search this directory for devices. To my surprise, this always ends with no found devices. In the past, I managed to get this to work with one of the previous WTKs but now, with the new Java ME SDK 3.0, this does not work any longer. Is there any solution to this problem? How can I add devices to MTJ?

Thanks in advance,

Markus

System used:
- Eclipse Galileo (Java edition)
- MJT 1.0.1
- Java ME SDK 3.0
- Windows 7 x64

[Updated on: Mon, 26 October 2009 05:54]

Report message to a moderator

Re: MJT and Java ME SDK 3.0 [message #496038 is a reply to message #493333] Sat, 07 November 2009 08:29 Go to previous messageGo to next message
Diego Madruga Sandin is currently offline Diego Madruga Sandin
Messages: 59
Registered: July 2009
Member
Hi,

Could you do some testing so we can determine whats wrong in your workspace?

First:
Opening a console and going to the installation directory of wtk 3.0, there should be a "bin" folder. Inside that folder, there must be an emulator.exe.

If you run emulator.exe -Xquery whats the output?

Second:
Are you using java 1.6 in your computer? I believe WTK 3 requires jre 1.6 to run properly.

Regards,
Diego

Re: MJT and Java ME SDK 3.0 [message #496064 is a reply to message #496038] Sat, 07 November 2009 14:22 Go to previous messageGo to next message
Markus M is currently offline Markus M
Messages: 6
Registered: July 2009
Junior Member
Hi,

thanks for your help. Unfortunately, running emulator.exe -Xquery does not produce any output. My system delays a second or two and simply produces an empty command promt without any further messages Crying or Very Sad
I have installed the most recent version of Java SDK.
Do you have any further suggestions?

Thanks in advance,

Markus

Re: MJT and Java ME SDK 3.0 [message #496210 is a reply to message #496064] Mon, 09 November 2009 06:30 Go to previous messageGo to next message
Diego Madruga Sandin is currently offline Diego Madruga Sandin
Messages: 59
Registered: July 2009
Member
Hi,

According to the wtk 3.0 Required Software section, it runs on Microsoft Windows XP or Vista 32-bit with recent service packs.

Windows 7 x64 is not supported yet, so I would suggest you to try to find out on sun's wtk3 forums if there is a way to run it in your system.

You could also take a look at the Pulsar, maybe one of the SDK's provided works on win7 x64.

Regards,
Diego

Re: MJT and Java ME SDK 3.0 [message #501423 is a reply to message #493333] Wed, 02 December 2009 04:50 Go to previous messageGo to next message
Marcel RUff is currently offline Marcel RUff
Messages: 12
Registered: December 2009
Junior Member
I had the same problem with WTK2.5.2 on Vista 32bit:

C:\WTK2.5.2\bin>emulator.exe -Xquery
Create process failed


All DLLs are there so it seems that WTK2.5.2 is not running on my Vista anymore.

Upgrading to WTK3.0 helped:

C:\Java_ME_platform_SDK_3.0\bin>emulator.exe -Xquery | more
# List of supported devices
device.list: ClamshellCldcPhone1,DefaultCdcPbpPhone1,DefaultCldcJtwiPhone 1,DefaultCldcJtwiPhone2,DefaultCldcMsaPhone1,DefaultCldcMsaP hone2,DefaultCldcPhon
,DefaultCldcPhone2,DefaultFxPhone1,DefaultFxTouchPhone1,SunV gaAGUIPhone1,SunVgaCdcPhone1
uei.version: 1.0.1
uei.arguments: Xdevice,Xquery,Xdebug,Xrunjdwp
...


regards
Marcel
Re: MJT and Java ME SDK 3.0 [message #521752 is a reply to message #493333] Thu, 18 March 2010 12:39 Go to previous messageGo to next message
lurgen is currently offline lurgen
Messages: 13
Registered: March 2010
Junior Member
I have problems with Windows 7 32 bit. I have configured all based on instructions http://eclipseme.org/docs/installation.html but I can't compile and even create new midlet. Does anyone have the same problem? (and know how to figure it out?)
Re: MJT and Java ME SDK 3.0 [message #529850 is a reply to message #521752] Tue, 27 April 2010 09:11 Go to previous message
Gustavo de Paula is currently offline Gustavo de Paula
Messages: 42
Registered: January 2010
Member
those issues don't seems to be associated directly to mtj, but to running wtk on vista and windows 77. there are a couple of reports about issues with that. probably it is better to check sun web site for some guidelines about how to do it.
Previous Topic:Build state machine has not been initialized
Next Topic:MJT and Java ME SDK 3.0
Goto Forum:
  


Current Time: Fri Aug 01 07:54:52 EDT 2014

Powered by FUDForum. Page generated in 0.02422 seconds