Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DSDP - Mobile Tools for Java (MTJ) » Preprocessor not working after Eclipse software update
Preprocessor not working after Eclipse software update [message #491951] Fri, 16 October 2009 17:21 Go to next message
Adam L is currently offline Adam L
Messages: 2
Registered: October 2009
Junior Member
Hi all,

This may have been answered before, but i couldn't find the answer anywhere. When I do an Eclipse software update, it appears that the config.ini file is overwritten. This means that every time Eclipse or one of my plugins is updated, the preprocessor stops working until I re-add the org.eclipse.mtj.core.hooks stuff to the config file. This only started happening to me after upgrading to Eclipse 3.5.

Are other people experiencing this issue? Is there some way I can prevent this from happening?
Thanks!

Here's my config.ini file:
#This configuration file was written by: org.eclipse.equinox.internal.frameworkadmin.equinox.EquinoxFwConfigFileParser
#Tue Oct 06 11:22:17 CDT 2009
org.eclipse.update.reconcile=false
eclipse.p2.profile=epp.package.jee
osgi.instance.area.default=@user.home/workspace
osgi.framework=file\:plugins/org.eclipse.osgi_3.5.1.R35x_v20090827.jar
eclipse.buildId=M20090917-0800
osgi.bundles=reference\:file\:org.eclipse.equinox.simpleconfigurator_1.0.101.R35x_v20090807-1100.jar@1\:start
org.eclipse.equinox.simpleconfigurator.configUrl=file\:org.eclipse.equinox.simpleconfigurator/bundles.info
eclipse.product=org.eclipse.platform.ide
osgi.splashPath=platform\:/base/plugins/org.eclipse.platform
osgi.framework.extensions=reference\:file\:org.eclipse.persistence.jpa.equinox.weaving_1.1.2.v20090612-r4475.jar,reference\:file\:javax.transaction_1.1.1.v200909161740.jar,org.eclipse.mtj.core.hooks
eclipse.application=org.eclipse.ui.ide.workbench
eclipse.p2.data.area=@config.dir/../p2/
mtj.build.logging=all
osgi.bundles.defaultStartLevel=4
Re: Preprocessor not working after Eclipse software update [message #492930 is a reply to message #491951] Thu, 22 October 2009 12:10 Go to previous message
Diego Madruga Sandin is currently offline Diego Madruga Sandin
Messages: 59
Registered: July 2009
Member
Hi,

I guess this is a common behavior on upgrades for the normal eclipse distribution, but try to use the pulsar distribution, and this problem probably wont happen on the next upgrade.

Thanks,
Diego





Previous Topic:Device management Cannot import Nokia 6131 NFC SDK v.1.1
Next Topic:Preprocessor not working after Eclipse software update
Goto Forum:
  


Current Time: Tue Oct 21 18:36:40 GMT 2014

Powered by FUDForum. Page generated in 0.02339 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software