Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » cannot use dropins to change jet/M2T version !
cannot use dropins to change jet/M2T version ! [message #49883] Wed, 17 September 2008 06:03 Go to next message
Edoardo Comar is currently offline Edoardo Comar
Messages: 102
Registered: July 2009
Senior Member
I installed 0.9.1RC2 in the dropins folder of an SDK 3.4.1RC3
As it fails to work for me (with an NPE) I tried to go back to 0.9.0

SO I shut down the platform, moved the m2t..091rc2... directory I had
under dropins and unzipped a 090

On restart the JET plugins can't be seen (wizards/editors/run
configurations ... all gone). From the software updates menu the
features are all listed and there are no messages on the consoles.

Funnily enough I cannot even revert to 091RC2.

I can only restart unzipping a new SDk and addeing m2t/emf etc again!!!
very annoying (also the svn connectors needs to be pulled from a web
update site etc.).

So how is one supposed to use the dropins to try different releases ???
Re: cannot use dropins to change jet/M2T version ! [message #49946 is a reply to message #49883] Wed, 17 September 2008 09:36 Go to previous messageGo to next message
Paul Elder is currently offline Paul Elder
Messages: 849
Registered: July 2009
Senior Member
Edoardo:

I suspect there is a p2 problem with the dropins folder. But, what you are
trying to do can be accomplished directly with Software Updates/P2 UI. I
have just done the following:

1) installed Eclipse 3.4.1RC3
2) Started Software Updates, and add the following updates sites:

EMF Release builds:
http://download.eclipse.org/modeling/emf/updates/releases/
JET Milestone builds:
http://download.eclipse.org/modeling/m2t/updates/milestones/
JET Release builds:
http://download.eclipse.org/modeling/m2t/updates/releases/

3) Install all of EMF 2.4.1 and JET 0.9.1RC2 and restart when prompted.
4) Return to Software Updates, select the JET plugins, and click Uninstall.
Restart when prompted.
5) Return to Software Updates, and install JET 0.9.0. and restart when
prompted.

On restart, I have verified that JET 0.9.0 and not 0.9.1 is installed.

Paul
Re: cannot use dropins to change jet/M2T version ! [message #49976 is a reply to message #49946] Wed, 17 September 2008 11:29 Go to previous message
Edoardo Comar is currently offline Edoardo Comar
Messages: 102
Registered: July 2009
Senior Member
thanks but what a pain having to go through UI and point and click
selections when a couple of file operations used to suffice.

IMO technology should keep simple things simple and be complex only for
complex goals

Paul Elder wrote:
> Edoardo:
>
> I suspect there is a p2 problem with the dropins folder. But, what you are
> trying to do can be accomplished directly with Software Updates/P2 UI. I
> have just done the following:
>
> 1) installed Eclipse 3.4.1RC3
> 2) Started Software Updates, and add the following updates sites:
>
> EMF Release builds:
> http://download.eclipse.org/modeling/emf/updates/releases/
> JET Milestone builds:
> http://download.eclipse.org/modeling/m2t/updates/milestones/
> JET Release builds:
> http://download.eclipse.org/modeling/m2t/updates/releases/
>
> 3) Install all of EMF 2.4.1 and JET 0.9.1RC2 and restart when prompted.
> 4) Return to Software Updates, select the JET plugins, and click Uninstall.
> Restart when prompted.
> 5) Return to Software Updates, and install JET 0.9.0. and restart when
> prompted.
>
> On restart, I have verified that JET 0.9.0 and not 0.9.1 is installed.
>
> Paul
>
>
Previous Topic:JET comments (redux)
Next Topic:[MTL : OMG Model-to-text standard] first stable version is out
Goto Forum:
  


Current Time: Sun Apr 20 09:30:21 EDT 2014

Powered by FUDForum. Page generated in 0.03444 seconds