Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » no launcher executable in generated RCP app(no launcher executable in generated RCP app)
no launcher executable in generated RCP app [message #489335] Fri, 02 October 2009 13:34
John Bradley is currently offline John Bradley
Messages: 14
Registered: July 2009
Junior Member
I have recently switched to Eclipse 3.5 and am having problems exporting my RCP application. I am running Eclipse under Vista, but trying to use the delta pack to create a Mac version of the application as well.

The deployment files contain some of the necessary files (all the plugins in the plugin folder, and a set of folders in the p2 folder), and a file called "artifacts.xml", but no launcher is provided in either the windows or mac folders.

I know that how one sets up the delta pack in 3.5 is different from 3.4, and I followed the instructions I found in Andrew Niefer's blog, I used the Window/Preferences/Plug-in Development/Target Platform to edit the active target and add a pointer to the downloaded delta folder.

I then noticed that I had a series of errors appear like this one:

The installable unit org.eclipse.equinox.executable_root.cocoa.macosx.x86_64 is missing the filename property.

What should I be doing to allow this to work?

Previous Topic:Removing menu items from the default context menu
Next Topic:How to get an IContributionItem from the main menu
Goto Forum:
  


Current Time: Wed Oct 01 14:18:08 GMT 2014

Powered by FUDForum. Page generated in 0.09512 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software