Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Upgrading platform (or SDK) from Eclipse updates
Upgrading platform (or SDK) from Eclipse updates [message #488906] Wed, 30 September 2009 16:36 Go to next message
Dmitry Smirnov is currently offline Dmitry SmirnovFriend
Messages: 90
Registered: July 2009
Member
Hi, I have installed Eclipse 6.0.0.
When I try to upgrade to 6.0.1 I see the message that some dependencies cannot be satisfied. Since I believed, these problematic components are part of the platform (or SDK) I was very surprized.
I do not know how to proceed further except to create new Eclipse installation from scratch.

Can you advice another way or figure out what is the problem.

Here is the message:

Cannot complete the install because of a conflicting dependency.
Software being installed: Eclipse SDK 3.5.1.M20090917-0800 (org.eclipse.sdk.ide 3.5.1.M20090917-0800)
Software currently installed: Eclipse Platform 3.5.0.I20090611-1540 (org.eclipse.platform.ide 3.5.0.I20090611-1540)
Only one of the following can be installed at once:
Equinox p2 repository tools. 1.0.0.v20090527-1812 (org.eclipse.equinox.p2.repository.tools 1.0.0.v20090527-1812)
Equinox p2 repository tools. 1.0.1.R35x_v20090806 (org.eclipse.equinox.p2.repository.tools 1.0.1.R35x_v20090806)
Cannot satisfy dependency:
From: Equinox p2 Provisioning 1.1.0.v20090605-1440-7u6Fb3FbPbJP5MjJjZgifk (org.eclipse.equinox.p2.user.ui.feature.group 1.1.0.v20090605-1440-7u6Fb3FbPbJP5MjJjZgifk)
To: org.eclipse.equinox.p2.repository.tools [1.0.0.v20090527-1812]
Cannot satisfy dependency:
From: Equinox p2 Provisioning 1.1.1.R35x_v20090811-7u6FbEFYXk1qWdbS0gnpRg2932 (org.eclipse.equinox.p2.user.ui.feature.group 1.1.1.R35x_v20090811-7u6FbEFYXk1qWdbS0gnpRg2932)
To: org.eclipse.equinox.p2.repository.tools [1.0.1.R35x_v20090806]
Cannot satisfy dependency:
From: Eclipse Platform 3.5.0.I20090611-1540 (org.eclipse.platform.ide 3.5.0.I20090611-1540)
To: org.eclipse.equinox.p2.user.ui.feature.group [1.1.0.v20090605-1440-7u6Fb3FbPbJP5MjJjZgifk]
Cannot satisfy dependency:
From: Eclipse SDK 3.5.1.M20090917-0800 (org.eclipse.sdk.ide 3.5.1.M20090917-0800)
To: org.eclipse.equinox.p2.user.ui.feature.group [1.1.1.R35x_v20090811-7u6FbEFYXk1qWdbS0gnpRg2932]
Re: Upgrading platform (or SDK) from Eclipse updates [message #489761 is a reply to message #488906] Mon, 05 October 2009 19:25 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 2371
Registered: July 2009
Senior Member
On 9/30/09 12:36 PM, Dmitry Smirnov wrote:
> Hi, I have installed Eclipse 6.0.0.
> When I try to upgrade to 6.0.1 I see the message that some dependencies
> cannot be satisfied. Since I believed, these problematic components are
> part of the platform (or SDK) I was very surprized.

I'm very surprised, too, since the latest Eclipse release is version
3.5. What do you have that is 6.0? Whatever it is it sure shouldn't be
labeled or branded as "Eclipse."

Eric

> I do not know how to proceed further except to create new Eclipse
> installation from scratch.
> Can you advice another way or figure out what is the problem.
>
> Here is the message:
>
> Cannot complete the install because of a conflicting dependency.
> Software being installed: Eclipse SDK 3.5.1.M20090917-0800
> (org.eclipse.sdk.ide 3.5.1.M20090917-0800)
> Software currently installed: Eclipse Platform 3.5.0.I20090611-1540
> (org.eclipse.platform.ide 3.5.0.I20090611-1540)
> Only one of the following can be installed at once: Equinox p2
> repository tools. 1.0.0.v20090527-1812
> (org.eclipse.equinox.p2.repository.tools 1.0.0.v20090527-1812)
> Equinox p2 repository tools. 1.0.1.R35x_v20090806
> (org.eclipse.equinox.p2.repository.tools 1.0.1.R35x_v20090806)
> Cannot satisfy dependency:
> From: Equinox p2 Provisioning
> 1.1.0.v20090605-1440-7u6Fb3FbPbJP5MjJjZgifk
> (org.eclipse.equinox.p2.user.ui.feature.group
> 1.1.0.v20090605-1440-7u6Fb3FbPbJP5MjJjZgifk)
> To: org.eclipse.equinox.p2.repository.tools [1.0.0.v20090527-1812]
> Cannot satisfy dependency:
> From: Equinox p2 Provisioning
> 1.1.1.R35x_v20090811-7u6FbEFYXk1qWdbS0gnpRg2932
> (org.eclipse.equinox.p2.user.ui.feature.group
> 1.1.1.R35x_v20090811-7u6FbEFYXk1qWdbS0gnpRg2932)
> To: org.eclipse.equinox.p2.repository.tools [1.0.1.R35x_v20090806]
> Cannot satisfy dependency:
> From: Eclipse Platform 3.5.0.I20090611-1540 (org.eclipse.platform.ide
> 3.5.0.I20090611-1540)
> To: org.eclipse.equinox.p2.user.ui.feature.group
> [1.1.0.v20090605-1440-7u6Fb3FbPbJP5MjJjZgifk]
> Cannot satisfy dependency:
> From: Eclipse SDK 3.5.1.M20090917-0800 (org.eclipse.sdk.ide
> 3.5.1.M20090917-0800)
> To: org.eclipse.equinox.p2.user.ui.feature.group
> [1.1.1.R35x_v20090811-7u6FbEFYXk1qWdbS0gnpRg2932]
Re: Upgrading platform (or SDK) from Eclipse updates [message #489903 is a reply to message #489761] Tue, 06 October 2009 13:08 Go to previous message
Paul Webster is currently offline Paul WebsterFriend
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

I think he means CDT 6 on eclipse 3.5

Dmitry, did you make sure you can update from the Eclipse 3.5 update site at the same time, in case the CDT 6.0.1 pulls in something with a dependency on 3.5.1?

PW


Previous Topic:Export deployable feature for Java Web start
Next Topic:Update Site
Goto Forum:
  


Current Time: Sat Nov 29 10:23:41 GMT 2014

Powered by FUDForum. Page generated in 0.01722 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software