Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Error message when trying to synchronize with subversive
Error message when trying to synchronize with subversive [message #488557] Tue, 29 September 2009 05:07 Go to next message
Andy Coleman is currently offline Andy Coleman
Messages: 33
Registered: September 2009
Member
Hi,

I am using subversive with connectors from polarion.org and JavaHL 1.5.4

When I try and perform a synchronization with subversion I am getting the following error

Synchronize operation failed.
RA layer request failed
svn: Server sent unexpected return value (400 Bad Request) in response to REPORT request for 'http://subversion.myorg.com/svn/repos/myproject/blah'

(I have modified the url for security reasons).

Googling for the error seems to indicate that it is down to a problem with proxy settings but as I am able to download updates etc I am asuming my proxy settings are correct. I have also compared my proxy settings to coleagues and they match.

Note that I also get a similar error when using subclipse so I do not think this is an error specificaly related to subversive.

I am able to perform checkin and checkout operations through subversive it just seems that when it tries to do a synchronization I get an error.

I am running on Windows XP. I also have TortoiseSVN and the subversion command line tools installed all of which work fine.

Thanks in advance for any help

Andy

Re: Error message when trying to synchronize with subversive [message #491674 is a reply to message #488557] Thu, 15 October 2009 09:04 Go to previous message
Igor Burilo is currently offline Igor Burilo
Messages: 435
Registered: July 2009
Senior Member
Hello Andy,

If it's possible, could you please see Apache's log when you perform
synchronization?
You can also try to make synhronization with another connector(SVNKit,
JavaHL) or another version of connector(e.g. 1.4, 1.5, 1.6).

> Hi,
>
> I am using subversive with connectors from polarion.org and JavaHL 1.5.4
>
> When I try and perform a synchronization with subversion I am getting the
> following error
>
> Synchronize operation failed.
> RA layer request failed
> svn: Server sent unexpected return value (400 Bad Request) in response to
> REPORT request for 'http://subversion.myorg.com/svn/repos/myproject/blah'
>
> (I have modified the url for security reasons).
>
> Googling for the error seems to indicate that it is down to a problem with
> proxy settings but as I am able to download updates etc I am asuming my
> proxy settings are correct. I have also compared my proxy settings to
> coleagues and they match.
> Note that I also get a similar error when using subclipse so I do not
> think this is an error specificaly related to subversive.
>
> I am able to perform checkin and checkout operations through subversive it
> just seems that when it tries to do a synchronization I get an error.
>
> I am running on Windows XP. I also have TortoiseSVN and the subversion
> command line tools installed all of which work fine.
>
> Thanks in advance for any help
>
> Andy
>
>
Previous Topic:Subversive - Integration with m2eclipse.
Next Topic:Integrate ImportFromSVNWizard into RCP?
Goto Forum:
  


Current Time: Sat Aug 23 07:38:25 EDT 2014

Powered by FUDForum. Page generated in 0.08286 seconds