Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 Tools » Installation seems onerous
Installation seems onerous [message #488455] Mon, 28 September 2009 18:04 Go to next message
Vinay  is currently offline Vinay
Messages: 4
Registered: September 2009
Junior Member
Hi,

I've spent most of my working hours trying to install UML2Tools on Galileo. Here is what I've tried:

1)Updating via software updater


  • Entire MDT/modeling option
  • Just the couple of UML2 tools option


2) Downloaded UML2Tools 0.9 along with all the build dependencies separately. I downloaded all their all-in-one update sites, with good attention to versions.


  • Tried by putting them in the plugins and features folders
  • Put them in the dropins folder with a couple of legal layouts


I tried every option with a fresh copy of eclipse. Also used the -clean option. Easy to guess, none worked.

Are there any other installation routes? The plugins directory and the dropins directory installation did not pop up any error. However, the software update failed with different erros, the most common one being:

An error occurred while collecting items to be installed session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.provisional.p2.engine.pha ses.Collect, operand=, action=).

It also said some artifacts were missing.


Any help?

Thanks a lot,
Vinay.
P.S: Google results indicated this error could be coz of the eclipse site updating itself, however, I've been trying all day.
Re: Installation seems onerous [message #488474 is a reply to message #488455] Mon, 28 September 2009 20:25 Go to previous message
Vinay  is currently offline Vinay
Messages: 4
Registered: September 2009
Junior Member
phew!

Was able to get it working finally. Hope this could be of help if anyone's facing the same issue.

Problem seems to be with the eclipse update website, what I did to solve should probably be the last resort, however, it works.




  1. Download UML2Tools and all its build dependencies(except the first one, Eclipse gtk 200906111540) from here: http://www.eclipse.org/modeling/mdt/downloads/?project=uml2t ools




  2. Disable the internet connection. This is what helped me. With every update eclipse looks up the update website. It was problematic.




  3. Install the components locally using the zip file

    For Eclipse Galileo: Help > Install new software> add button > archive

    browse to the respective zip file which you want to install. You will have to figure out the order by trial and error. I think this is the order that worked for me:


    1. emf-query-Update-1.3.0.zip
    2. emf-validation-Update-1.3.1.zip
    3. emf-xsd-Update-2.5.0.zip
    4. gmf-gmf-Update-2.2.1.zip
    5. m2m-qvtoml-Update-2.0.1.zip
    6. GEF-Update-3.5.1.zip
    7. mdt-uml2-Update-3.0.1.zip
    8. mdt-ocl-Update-1.3.0.zip
    9. mdt-uml2tools-Update-incubation-0.9.0.zip
    10. emf-transaction-Update-1.3.1.zip: This proved problematic to me. I installed it by deselecting the first two options for EMF Data Integrity Layer.





I did not restart eclipse after each installation, just used the 'apply changes' option and restarted eclipse after the last installation i.e UML2TOOLS.


m2c,
Vinay Binny.

P.S: Eclipse's severs are acting a bit strange, not sure if it is an anomaly.


Previous Topic:Re: Problem while trying to export graphic from diagram
Next Topic:Installation seems onerous
Goto Forum:
  


Current Time: Sat Oct 25 21:30:12 GMT 2014

Powered by FUDForum. Page generated in 0.01696 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software