Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Feature Export in 3.5 not creating feature jnlp file(Feature Export in 3.5 not creating feature jnlp file)
Feature Export in 3.5 not creating feature jnlp file [message #488224] Sat, 26 September 2009 06:34 Go to next message
PM  is currently offline PM
Messages: 14
Registered: July 2009
Junior Member
We export feature for webstarting our RCP application. Till 3.4.2 everything worked as expected. We also did multi-platform export. However we have started running into problems after migrating to 3.5 First of all the export doesnt create the feature jnlp. This jnlp is used by the root jnlp. I have the Create JNLP checkbox checked. But the jnlp is still not getting created. I dont want to hand code that file since we have close to 70 plugins.
Has anyone run intho issue? I really appreciate your answers/solutions.

Regards
Priyanka
Re: Feature Export in 3.5 not creating feature jnlp file [message #489409 is a reply to message #488224] Fri, 02 October 2009 20:56 Go to previous messageGo to next message
Andrew Niefer is currently offline Andrew Niefer
Messages: 990
Registered: July 2009
Senior Member
Make sure the "Generate metadata repository" option is not checked in the export wizard.. The details of p2 metadata and jnlp webstart together have not been fully worked out in build, and it seems they don't work at the same time.

PM wrote on Sat, 26 September 2009 02:34
We export feature for webstarting our RCP application. Till 3.4.2 everything worked as expected. We also did multi-platform export. However we have started running into problems after migrating to 3.5 First of all the export doesnt create the feature jnlp. This jnlp is used by the root jnlp. I have the Create JNLP checkbox checked. But the jnlp is still not getting created. I dont want to hand code that file since we have close to 70 plugins.
Has anyone run intho issue? I really appreciate your answers/solutions.

Regards
Priyanka

Re: Feature Export in 3.5 not creating feature jnlp file [message #489413 is a reply to message #489409] Fri, 02 October 2009 21:09 Go to previous messageGo to next message
PM  is currently offline PM
Messages: 14
Registered: July 2009
Junior Member
Thanx for the answer. That worked.
Re: Feature Export in 3.5 not creating feature jnlp file [message #536279 is a reply to message #488224] Thu, 27 May 2010 14:32 Go to previous message
No real name is currently offline No real name
Messages: 5
Registered: March 2010
Junior Member
I'm new to RCP and came across this article. I'm having trouble creating a proper jnlp file by hand. This article seems to say that I can get the feature export functionality to do this for me automatically.

When I pull up my feature.xml file it brings up an editor called "RCP Application Feature". Then I invoke "Export Wizard" under the "Exporting" tab. In none of the tabs do I see any option to generate a jnlp file. And, no matter want combination of options I choose on the various tabs, a jnlp file is never generated.

Can someone help me understand what I might be missing? Thanks

Chuck
Previous Topic:TreeViewer Memory Mgt.
Next Topic:How to dispose a view programmatically?
Goto Forum:
  


Current Time: Mon Sep 22 12:24:11 GMT 2014

Powered by FUDForum. Page generated in 0.03043 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software