Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Platform - User Assistance (UA) » Remote Help and spaces in the path
Remote Help and spaces in the path [message #486985] Mon, 21 September 2009 12:18 Go to next message
Enrico Schenk is currently offline Enrico SchenkFriend
Messages: 23
Registered: July 2009
Junior Member
Hello,

I'm currently setting up an Infocenter on Tomcat. This works fine except
that I cannot use the Infocenter remotely. Although I'm able to retrieve
the generated TOCs, the retrieval of content fails. It turned out that
spaces in the URL of the remote documents were not escaped to '%20',
hence the local help is not able to get the content of the requested
documents. I tried to replace the spaces in the corresponding TOC
documents, but that did not work. At some point the '%20' got translated
back to ' '. Is there a workaround that issue, other than removing the
spaces in all paths?

Thanks,

Enrico
Re: Remote Help and spaces in the path [message #487107 is a reply to message #486985] Mon, 21 September 2009 22:06 Go to previous messageGo to next message
Chris Goldthorpe is currently offline Chris GoldthorpeFriend
Messages: 815
Registered: July 2009
Senior Member
This sounds like a bug, can you file a bug report?

Enrico Schenk wrote:
> Hello,
>
> I'm currently setting up an Infocenter on Tomcat. This works fine except
> that I cannot use the Infocenter remotely. Although I'm able to retrieve
> the generated TOCs, the retrieval of content fails. It turned out that
> spaces in the URL of the remote documents were not escaped to '%20',
> hence the local help is not able to get the content of the requested
> documents. I tried to replace the spaces in the corresponding TOC
> documents, but that did not work. At some point the '%20' got translated
> back to ' '. Is there a workaround that issue, other than removing the
> spaces in all paths?
>
> Thanks,
>
> Enrico
Re: Remote Help and spaces in the path [message #487258 is a reply to message #487107] Tue, 22 September 2009 15:32 Go to previous message
Enrico Schenk is currently offline Enrico SchenkFriend
Messages: 23
Registered: July 2009
Junior Member
I have filed a bug report, the bug id is 290147.

Chris Goldthorpe wrote:
> This sounds like a bug, can you file a bug report?
>
> Enrico Schenk wrote:
>> Hello,
>>
>> I'm currently setting up an Infocenter on Tomcat. This works fine
>> except that I cannot use the Infocenter remotely. Although I'm able to
>> retrieve the generated TOCs, the retrieval of content fails. It turned
>> out that spaces in the URL of the remote documents were not escaped to
>> '%20', hence the local help is not able to get the content of the
>> requested documents. I tried to replace the spaces in the
>> corresponding TOC documents, but that did not work. At some point the
>> '%20' got translated back to ' '. Is there a workaround that issue,
>> other than removing the spaces in all paths?
>>
>> Thanks,
>>
>> Enrico
Re: Remote Help and spaces in the path [message #623562 is a reply to message #486985] Mon, 21 September 2009 22:06 Go to previous message
Chris Goldthorpe is currently offline Chris GoldthorpeFriend
Messages: 815
Registered: July 2009
Senior Member
This sounds like a bug, can you file a bug report?

Enrico Schenk wrote:
> Hello,
>
> I'm currently setting up an Infocenter on Tomcat. This works fine except
> that I cannot use the Infocenter remotely. Although I'm able to retrieve
> the generated TOCs, the retrieval of content fails. It turned out that
> spaces in the URL of the remote documents were not escaped to '%20',
> hence the local help is not able to get the content of the requested
> documents. I tried to replace the spaces in the corresponding TOC
> documents, but that did not work. At some point the '%20' got translated
> back to ' '. Is there a workaround that issue, other than removing the
> spaces in all paths?
>
> Thanks,
>
> Enrico
Re: Remote Help and spaces in the path [message #623564 is a reply to message #487107] Tue, 22 September 2009 15:32 Go to previous message
Enrico Schenk is currently offline Enrico SchenkFriend
Messages: 23
Registered: July 2009
Junior Member
I have filed a bug report, the bug id is 290147.

Chris Goldthorpe wrote:
> This sounds like a bug, can you file a bug report?
>
> Enrico Schenk wrote:
>> Hello,
>>
>> I'm currently setting up an Infocenter on Tomcat. This works fine
>> except that I cannot use the Infocenter remotely. Although I'm able to
>> retrieve the generated TOCs, the retrieval of content fails. It turned
>> out that spaces in the URL of the remote documents were not escaped to
>> '%20', hence the local help is not able to get the content of the
>> requested documents. I tried to replace the spaces in the
>> corresponding TOC documents, but that did not work. At some point the
>> '%20' got translated back to ' '. Is there a workaround that issue,
>> other than removing the spaces in all paths?
>>
>> Thanks,
>>
>> Enrico
Previous Topic:preindexing extradir documentation
Next Topic:preindexing extradir documentation
Goto Forum:
  


Current Time: Fri Dec 19 20:17:45 GMT 2014

Powered by FUDForum. Page generated in 0.02310 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software