Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Riena » riena security start
riena security start [message #486967] Mon, 21 September 2009 10:49 Go to next message
Waldi  is currently offline Waldi
Messages: 60
Registered: July 2009
Member
Dear all,

i try to start with riena security. Now I try out the security sample in
the SWT ExampleApplication.product. The vm arguments I set to
-Djava.security.auth.login.config==${workspace_loc}\org.ecli pse.riena.security.simpleservices\config\sample_jaas.config

I start the Riena Sample App Server und try to login with john and john.
The following exception appears:

!ENTRY org.eclipse.equinox.security 4 0 2009-09-21 12:46:41.132
!MESSAGE Could not locate JAAS Configuration with name "Remote", verify
that the configuration exists and is non-empty.
Mon Sep 21 12:46:41 CEST 2009 ERROR [main] Bundle
org.eclipse.core.runtime Message: Could not locate JAAS Configuration
with name "Remote", verify that the configuration exists and is
non-empty., Code: 0, Plugin: org.eclipse.equinox.security

!ENTRY
org.eclipse.equinox.security 4 0 2009-09-21 12:46:41.167
!MESSAGE Could not locate JAAS Configuration with name "other", verify
that the configuration exists and is non-empty.
Mon Sep 21 12:46:41 CEST 2009 ERROR [main] Bundle
org.eclipse.core.runtime Message: Could not locate JAAS Configuration
with name "other", verify that the configuration exists and is
non-empty., Code: 0, Plugin: org.eclipse.equinox.security

I run it unter Linux.

I check sample_jaas.config. It looks like:
/** Login Configuration for the JAAS Sample Application **/
Remote {
org.eclipse.equinox.security.auth.module.ExtensionLoginModul e
required debug="true"
extensionId="org.eclipse.riena.example.client.remoteSecurity ";
};

Can you helb me?

CU Waldi
Re: riena security start [message #486968 is a reply to message #486967] Mon, 21 September 2009 10:50 Go to previous message
Waldi  is currently offline Waldi
Messages: 60
Registered: July 2009
Member
BTW: I use Riena 1.1.0.0

Waldi Waldemar schrieb:
> Dear all,
>
> i try to start with riena security. Now I try out the security sample in
> the SWT ExampleApplication.product. The vm arguments I set to
> -Djava.security.auth.login.config==${workspace_loc}\org.ecli pse.riena.security.simpleservices\config\sample_jaas.config
>
>
> I start the Riena Sample App Server und try to login with john and john.
> The following exception appears:
>
> !ENTRY org.eclipse.equinox.security 4 0 2009-09-21 12:46:41.132
> !MESSAGE Could not locate JAAS Configuration with name "Remote", verify
> that the configuration exists and is non-empty.
> Mon Sep 21 12:46:41 CEST 2009 ERROR [main] Bundle
> org.eclipse.core.runtime Message: Could not locate JAAS Configuration
> with name "Remote", verify that the configuration exists and is
> non-empty., Code: 0, Plugin: org.eclipse.equinox.security
>
> !ENTRY
> org.eclipse.equinox.security 4 0 2009-09-21 12:46:41.167
> !MESSAGE Could not locate JAAS Configuration with name "other", verify
> that the configuration exists and is non-empty.
> Mon Sep 21 12:46:41 CEST 2009 ERROR [main] Bundle
> org.eclipse.core.runtime Message: Could not locate JAAS Configuration
> with name "other", verify that the configuration exists and is
> non-empty., Code: 0, Plugin: org.eclipse.equinox.security
>
> I run it unter Linux.
>
> I check sample_jaas.config. It looks like:
> /** Login Configuration for the JAAS Sample Application **/
> Remote {
> org.eclipse.equinox.security.auth.module.ExtensionLoginModul e
> required debug="true"
> extensionId="org.eclipse.riena.example.client.remoteSecurity ";
> };
>
> Can you helb me?
>
> CU Waldi
Re: riena security start [message #583468 is a reply to message #486967] Mon, 21 September 2009 10:50 Go to previous message
Waldi  is currently offline Waldi
Messages: 60
Registered: July 2009
Member
BTW: I use Riena 1.1.0.0

Waldi Waldemar schrieb:
> Dear all,
>
> i try to start with riena security. Now I try out the security sample in
> the SWT ExampleApplication.product. The vm arguments I set to
> -Djava.security.auth.login.config==${workspace_loc}\org.ecli pse.riena.security.simpleservices\config\sample_jaas.config
>
>
> I start the Riena Sample App Server und try to login with john and john.
> The following exception appears:
>
> !ENTRY org.eclipse.equinox.security 4 0 2009-09-21 12:46:41.132
> !MESSAGE Could not locate JAAS Configuration with name "Remote", verify
> that the configuration exists and is non-empty.
> Mon Sep 21 12:46:41 CEST 2009 ERROR [main] Bundle
> org.eclipse.core.runtime Message: Could not locate JAAS Configuration
> with name "Remote", verify that the configuration exists and is
> non-empty., Code: 0, Plugin: org.eclipse.equinox.security
>
> !ENTRY
> org.eclipse.equinox.security 4 0 2009-09-21 12:46:41.167
> !MESSAGE Could not locate JAAS Configuration with name "other", verify
> that the configuration exists and is non-empty.
> Mon Sep 21 12:46:41 CEST 2009 ERROR [main] Bundle
> org.eclipse.core.runtime Message: Could not locate JAAS Configuration
> with name "other", verify that the configuration exists and is
> non-empty., Code: 0, Plugin: org.eclipse.equinox.security
>
> I run it unter Linux.
>
> I check sample_jaas.config. It looks like:
> /** Login Configuration for the JAAS Sample Application **/
> Remote {
> org.eclipse.equinox.security.auth.module.ExtensionLoginModul e
> required debug="true"
> extensionId="org.eclipse.riena.example.client.remoteSecurity ";
> };
>
> Can you helb me?
>
> CU Waldi
Previous Topic:riena security start
Next Topic:Icons in an ITreeRidget
Goto Forum:
  


Current Time: Thu Oct 02 06:23:47 GMT 2014

Powered by FUDForum. Page generated in 0.03460 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software