Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Orbit » Version of iText
Version of iText [message #486861] Sun, 20 September 2009 09:03 Go to next message
Lars Vogel is currently offline Lars Vogel
Messages: 1049
Registered: July 2009
Senior Member

Hello,

I just downloaded iText from Orbit and it appear to me like a very old
version (1_5_4). Current is 2.1.7.

Do you have any plans to upgrade iText in Orbit? Or do I like
incorrectly at the version number?

Best regards, Lars

--
http://www.vogella.de/ - Eclipse plugin and Eclipse RCP Tutorials
http://www.twitter.com/vogella - vogella on Twitter
Re: Version of iText [message #486879 is a reply to message #486861] Sun, 20 September 2009 17:17 Go to previous messageGo to next message
David Williams is currently offline David Williams
Messages: 176
Registered: July 2009
Senior Member
Lars Vogel wrote:
> ...
> I just downloaded iText from Orbit and it appear to me like a very old
> version (1_5_4). Current is 2.1.7.
>
> Do you have any plans to upgrade iText in Orbit?
> ...

We in Orbit do not have those plans. Our "plans" are driven
entirely by what other Eclipse Projects plan and their needs.
(That is, we are not a general purpose repo for bundles).
It appears this particular Orbit contribution was made by BIRT and/or
OSEE Projects. I suspect they simply have no need to move up to
latest version, for what ever they are using it for. But you
could ask them, on their newsgroups, I suppose.
Better, you could ask the iText project to provide an OSGI bundle
as part of their distribution!
Re: Version of iText [message #486883 is a reply to message #486879] Sun, 20 September 2009 17:46 Go to previous messageGo to next message
Lars Vogel is currently offline Lars Vogel
Messages: 1049
Registered: July 2009
Senior Member

Hi David,

Thank you for your answer.

I did already asked iText for an OSGi version in http://bit.ly/QIa2k

Best regards, Lars


--
http://www.vogella.de/ - Eclipse plugin and Eclipse RCP Tutorials
http://www.twitter.com/vogella - vogella on Twitter


David Williams wrote:
> Lars Vogel wrote:
>> ...
>> I just downloaded iText from Orbit and it appear to me like a very old
>> version (1_5_4). Current is 2.1.7.
>>
>> Do you have any plans to upgrade iText in Orbit?
> > ...
>
> We in Orbit do not have those plans. Our "plans" are driven
> entirely by what other Eclipse Projects plan and their needs.
> (That is, we are not a general purpose repo for bundles).
> It appears this particular Orbit contribution was made by BIRT and/or
> OSEE Projects. I suspect they simply have no need to move up to
> latest version, for what ever they are using it for. But you
> could ask them, on their newsgroups, I suppose.
> Better, you could ask the iText project to provide an OSGI bundle
> as part of their distribution!
>
>
>
Re: Version of iText [message #548207 is a reply to message #486861] Wed, 21 July 2010 05:55 Go to previous message
Gunnar Wagenknecht is currently offline Gunnar Wagenknecht
Messages: 452
Registered: July 2009
Location: Germany ✈ Vancouver
Senior Member

Am 20.09.2009 11:03, schrieb Lars Vogel:
> I just downloaded iText from Orbit and it appear to me like a very old
> version (1_5_4). Current is 2.1.7.

BTW, they changed their licens to AGPL which makes them incompatible to
Orbit.

-Gunnar

--
Gunnar Wagenknecht
gunnar@wagenknecht.org
http://wagenknecht.org/
Re: Version of iText [message #565438 is a reply to message #486861] Sun, 20 September 2009 17:17 Go to previous message
David Williams is currently offline David Williams
Messages: 176
Registered: July 2009
Senior Member
Lars Vogel wrote:
> ...
> I just downloaded iText from Orbit and it appear to me like a very old
> version (1_5_4). Current is 2.1.7.
>
> Do you have any plans to upgrade iText in Orbit?
> ...

We in Orbit do not have those plans. Our "plans" are driven
entirely by what other Eclipse Projects plan and their needs.
(That is, we are not a general purpose repo for bundles).
It appears this particular Orbit contribution was made by BIRT and/or
OSEE Projects. I suspect they simply have no need to move up to
latest version, for what ever they are using it for. But you
could ask them, on their newsgroups, I suppose.
Better, you could ask the iText project to provide an OSGI bundle
as part of their distribution!
Re: Version of iText [message #565465 is a reply to message #486879] Sun, 20 September 2009 17:46 Go to previous message
Lars Vogel is currently offline Lars Vogel
Messages: 1049
Registered: July 2009
Senior Member

Hi David,

Thank you for your answer.

I did already asked iText for an OSGi version in http://bit.ly/QIa2k

Best regards, Lars


--
http://www.vogella.de/ - Eclipse plugin and Eclipse RCP Tutorials
http://www.twitter.com/vogella - vogella on Twitter


David Williams wrote:
> Lars Vogel wrote:
>> ...
>> I just downloaded iText from Orbit and it appear to me like a very old
>> version (1_5_4). Current is 2.1.7.
>>
>> Do you have any plans to upgrade iText in Orbit?
> > ...
>
> We in Orbit do not have those plans. Our "plans" are driven
> entirely by what other Eclipse Projects plan and their needs.
> (That is, we are not a general purpose repo for bundles).
> It appears this particular Orbit contribution was made by BIRT and/or
> OSEE Projects. I suspect they simply have no need to move up to
> latest version, for what ever they are using it for. But you
> could ask them, on their newsgroups, I suppose.
> Better, you could ask the iText project to provide an OSGI bundle
> as part of their distribution!
>
>
>
Re: Version of iText [message #566029 is a reply to message #486861] Wed, 21 July 2010 05:55 Go to previous message
Gunnar Wagenknecht is currently offline Gunnar Wagenknecht
Messages: 452
Registered: July 2009
Location: Germany ✈ Vancouver
Senior Member

Am 20.09.2009 11:03, schrieb Lars Vogel:
> I just downloaded iText from Orbit and it appear to me like a very old
> version (1_5_4). Current is 2.1.7.

BTW, they changed their licens to AGPL which makes them incompatible to
Orbit.

-Gunnar

--
Gunnar Wagenknecht
gunnar@wagenknecht.org
http://wagenknecht.org/
Previous Topic:GWT-User not installable with p2
Next Topic:SLF4j Version 1.6.0
Goto Forum:
  


Current Time: Thu Oct 23 04:38:37 GMT 2014

Powered by FUDForum. Page generated in 0.01722 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software