Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Plugin Development Environment (PDE) » specifying runtime bundle-dependencies
specifying runtime bundle-dependencies [message #484661] Tue, 08 September 2009 12:37
Thomas Paradies is currently offline Thomas Paradies
Messages: 4
Registered: July 2009
Junior Member
Hi,

in a RCP/EclipseLink(OSGi bundles) project I'm using static bytecode
weaving. The bytecode enhancements leeding to additional dependencies
(e.g.
org.eclipse.persistence.core/org.eclipse.persistence.interna l.weaving.PersistenceWeaved).
As good OSGi citizen I specifiy all my bundle dependencies as imported
packages. Now I'm in doubt if it wouldn't be better to specify such
dependencies as required plugins particulary as the process to detect
any package dependency at runtime and specify it is very painful. Are
there best practises how to get on with such dependencies in Eclipse?

Thomas
Previous Topic:Target Definition for Eclipse 3.2.2
Next Topic:specifying runtime bundle-dependencies
Goto Forum:
  


Current Time: Thu Aug 28 09:29:35 EDT 2014

Powered by FUDForum. Page generated in 0.01535 seconds