Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » [XPAND] 50 % slowdown compared to OAW XPAND
[XPAND] 50 % slowdown compared to OAW XPAND [message #484489] Mon, 07 September 2009 17:45 Go to next message
Marcel Wagner is currently offline Marcel WagnerFriend
Messages: 6
Registered: July 2009
Junior Member
I observed a 50 % (feeled not measured) slowdown of my XPAND files after migrating from OAW to TMF.

Anybody else have observed this?
Have I done something wrong?

Thanks for some ideas.

Marcel
Re: [XPAND] 50 % slowdown compared to OAW XPAND [message #484498 is a reply to message #484489] Mon, 07 September 2009 18:32 Go to previous messageGo to next message
Sebastian Zarnekow is currently offline Sebastian ZarnekowFriend
Messages: 2942
Registered: July 2009
Senior Member
Hi Marcel,

do you use your templates in an OSGi environment?

Regards,
Sebastian
--
Need professional support for Eclipse Modeling?
Go visit: http://xtext.itemis.com

Marcel Wagner schrieb:
> I observed a 50 % (feeled not measured) slowdown of my XPAND files after
> migrating from OAW to TMF.
>
> Anybody else have observed this?
> Have I done something wrong?
>
> Thanks for some ideas.
>
> Marcel
Re: [XPAND] 50 % slowdown compared to OAW XPAND [message #484677 is a reply to message #484498] Tue, 08 September 2009 17:38 Go to previous messageGo to next message
Marcel Wagner is currently offline Marcel WagnerFriend
Messages: 6
Registered: July 2009
Junior Member
Yes, the templates are integrated in an OSGI plugin. Is there a trick to
know about to speed things up? Any ideas would be fantastic, in this state
I can't migrate to the new xtext ;-(.

Thanks for your help.

Marcel
Re: [XPAND] 50 % slowdown compared to OAW XPAND [message #484700 is a reply to message #484677] Tue, 08 September 2009 19:05 Go to previous messageGo to next message
Sebastian Zarnekow is currently offline Sebastian ZarnekowFriend
Messages: 2942
Registered: July 2009
Senior Member
Hi Marcel,

please have a look at the thread "Galileo twice as slow". There you'll
find the trick ;-)

Regards,
Sebastian

--
Need professional support for Eclipse Modeling?
Go visit: http://xtext.itemis.com

Marcel Wagner schrieb:
> Yes, the templates are integrated in an OSGI plugin. Is there a trick to
> know about to speed things up? Any ideas would be fantastic, in this
> state I can't migrate to the new xtext ;-(.
>
> Thanks for your help.
>
> Marcel
>
Re: [XPAND] 50 % slowdown compared to OAW XPAND [message #484947 is a reply to message #484700] Wed, 09 September 2009 20:14 Go to previous message
Marcel Wagner is currently offline Marcel WagnerFriend
Messages: 6
Registered: July 2009
Junior Member
ahhh, better read the newsgroups ;-)

Sorry for the useless question, the trick functions!

Now I am twice as fast ;-) Great job!

Thanks a lot for your help,

Marcel
Previous Topic:Check: How to activate the EMF Validation Adapter?
Next Topic:Invoking Expand generator from Java
Goto Forum:
  


Current Time: Thu Nov 27 09:38:11 GMT 2014

Powered by FUDForum. Page generated in 0.02078 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software