Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Need help with trivial HTML-template PLZ(I can't get this quite trivial template working)
Need help with trivial HTML-template PLZ [message #482874] Fri, 28 August 2009 08:28 Go to next message
jzaruba  is currently offline jzaruba
Messages: 8
Registered: July 2009
Junior Member
I'm trying to create a template that would wrap selected text with new tag. (The template should obviously let me fill the tag name, a cursor should end where the attributes go...)

<${tagName}${cursor}>${word_selection}</${tagName}>

Yet when I apply the template on let's say "word" I end up with following error message:
Template Evaluation Error:
First position 'ord<tag' at 1452, this position 'rd</tag' at 1466


... and the result looks like this:
|word|<tagName>word</tagName>
(pipes indicating selection)

...instead of:
<writeTagName|>word</writeTagName>
(pipe indicating cursor)

What am I doiing wrong PLZ?
Re: Need help with trivial HTML-template PLZ [message #483240 is a reply to message #482874] Mon, 31 August 2009 13:31 Go to previous messageGo to next message
David Williams is currently offline David Williams
Messages: 176
Registered: July 2009
Senior Member
jzaruba wrote:
> What am I doiing wrong PLZ?

Its probably a bug. Before you open one, it'd help if you narrowed it
down ... is it only HTML? XML too? Java? Plain text? That will help
determine who should look at it (or, if there is already an existing one).
Re: Need help with trivial HTML-template PLZ [message #483243 is a reply to message #483240] Mon, 31 August 2009 13:44 Go to previous messageGo to next message
jzaruba  is currently offline jzaruba
Messages: 8
Registered: July 2009
Junior Member
I will try to narrow it.

As for whether this is already filed or not:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=241358
...I am not sure though whether this is exactly the same thing.
Re: Need help with trivial HTML-template PLZ [message #483314 is a reply to message #483243] Mon, 31 August 2009 23:23 Go to previous messageGo to next message
David Williams is currently offline David Williams
Messages: 176
Registered: July 2009
Senior Member
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=UTF-8" http-equiv="Content-Type">
<title></title>
</head>
<body bgcolor="#ffffff" text="#000000">
jzaruba wrote:
<blockquote cite="mid:h7h25n$kgu$1@build.eclipse.org" type="cite">I
will try to narrow it.
<br>
<br>
As for whether this is already filed or not:
<br>
<a class="moz-txt-link-freetext" href="https://bugs.eclipse.org/bugs/show_bug.cgi?id=241358">https://bugs.eclipse.org/bugs/show_bug.cgi?id=241358</a>
<br>
....I am not sure though whether this is exactly the same thing.
<br>
</blockquote>
<font face="Consolas">I suspect that's close enough that you could file
your use-case there, since it says "</font>The cursor variable's not
one we can support without some changes to the wizard". I think in your
use case, it is the cursor variable that is the issue (that is, if the
cursor variable is left out, then works as expected). <br>
<br>
HTH<br>
<br>
</body>
</html>
Re: Need help with trivial HTML-template PLZ [message #483365 is a reply to message #483314] Tue, 01 September 2009 07:31 Go to previous message
jzaruba  is currently offline jzaruba
Messages: 8
Registered: July 2009
Junior Member
The result is always messed. (I should have probably used "line_selection" instead of "word_selection" though.)
In HTML with certain type of selection I don't get the error when I ommit the cursor-variable. In XML I always get the error, even without the cursor-variable.
Previous Topic:Saving a JSF file into a HTML
Next Topic:Top Down Web Service -Final Step
Goto Forum:
  


Current Time: Thu Aug 21 06:30:54 EDT 2014

Powered by FUDForum. Page generated in 0.03407 seconds