Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IAM (Eclipse Integration for Apache Maven) » Cannot install IAM(Cannot install IAM - EMF errors)
Cannot install IAM [message #482240] Tue, 25 August 2009 19:50 Go to next message
Abbie Tittizer is currently offline Abbie TittizerFriend
Messages: 6
Registered: August 2009
Junior Member
Attempting to install IAM via Software Updates in Eclipse 3.4.2. I get the following errors:

Cannot complete the request. See the details.
Cannot find a solution where both "org.eclipse.emf.compare.match [1.0.0,2.0.0)" and "org.eclipse.emf.compare.match [0.8.1.v200902100450]" are satisfied.
Cannot find a solution where both "org.eclipse.emf.compare [1.0.0,2.0.0)" and "org.eclipse.emf.compare [0.8.1.v200902100450]" are satisfied.
Cannot find a solution where both "org.eclipse.emf.compare.diff [1.0.0,2.0.0)" and "org.eclipse.emf.compare.diff [0.8.1.v200902100450]" are satisfied.
Cannot find a solution where both "org.eclipse.emf.compare.match [1.0.0,2.0.0)" and "org.eclipse.emf.compare.match [0.8.1.v200902100450]" are satisfied.
Cannot find a solution where both "org.eclipse.emf.compare [1.0.0,2.0.0)" and "org.eclipse.emf.compare [0.8.1.v200902100450]" are satisfied.
Cannot find a solution where both "org.eclipse.emf.compare.diff [1.0.0,2.0.0)" and "org.eclipse.emf.compare.diff [0.8.1.v200902100450]" are satisfied.
Cannot find a solution where both "org.eclipse.emf.compare [1.0.0,2.0.0)" and "org.eclipse.emf.compare [0.8.1.v200902100450]" are satisfied.
Cannot find a solution where both "org.eclipse.emf.compare.diff [1.0.0,2.0.0)" and "org.eclipse.emf.compare.diff [0.8.1.v200902100450]" are satisfied.
Unsatisfied dependency: [org.eclipse.emf.mint 0.8.0.v200906161513] requiredCapability: osgi.bundle/org.eclipse.emf.codegen.ecore/[2.5.0,3.0.0)
Cannot find a solution where both "bundle org.eclipse.emf.codegen.ecore [2.4.2,2.5.0)" and "bundle org.eclipse.emf.codegen.ecore [2.5.0,3.0.0)" are satisfied.
Cannot find a solution where both "org.eclipse.emf.compare.match [1.0.0,2.0.0)" and "org.eclipse.emf.compare.match [0.8.1.v200902100450]" are satisfied.
Unsatisfied dependency: [org.eclipse.emf.mint 0.8.0.v200906161513] requiredCapability: osgi.bundle/org.eclipse.core.resources/[3.5.0,4.0.0)
Cannot find a solution where both "bundle org.eclipse.core.resources [3.4.1,3.5.0)" and "bundle org.eclipse.core.resources [3.5.0,4.0.0)" are satisfied.
Cannot find a solution where both "org.eclipse.emf.compare [1.0.0,2.0.0)" and "org.eclipse.emf.compare [0.8.1.v200902100450]" are satisfied.
Cannot find a solution where both "org.eclipse.emf.compare.diff [1.0.0,2.0.0)" and "org.eclipse.emf.compare.diff [0.8.1.v200902100450]" are satisfied.
Cannot find a solution where both "bundle org.eclipse.emf.codegen.ecore [2.4.2,2.5.0)" and "bundle org.eclipse.emf.codegen.ecore [2.5.0,3.0.0)" are satisfied.
Cannot find a solution where both "org.eclipse.emf.compare.match [1.0.0,2.0.0)" and "org.eclipse.emf.compare.match [0.8.1.v200902100450]" are satisfied.
Cannot find a solution where both "bundle org.eclipse.core.resources [3.4.1,3.5.0)" and "bundle org.eclipse.core.resources [3.5.0,4.0.0)" are satisfied.
Cannot find a solution where both "org.eclipse.emf.compare [1.0.0,2.0.0)" and "org.eclipse.emf.compare [0.8.1.v200902100450]" are satisfied.
Cannot find a solution where both "org.eclipse.emf.compare.diff [1.0.0,2.0.0)" and "org.eclipse.emf.compare.diff [0.8.1.v200902100450]" are satisfied.
Cannot find a solution where both "bundle org.eclipse.emf.codegen.ecore [2.4.2,2.5.0)" and "bundle org.eclipse.emf.codegen.ecore [2.5.0,3.0.0)" are satisfied.
Cannot find a solution where both "org.eclipse.emf.compare.match [1.0.0,2.0.0)" and "org.eclipse.emf.compare.match [0.8.1.v200902100450]" are satisfied.
Cannot find a solution where both "bundle org.eclipse.core.resources [3.4.1,3.5.0)" and "bundle org.eclipse.core.resources [3.5.0,4.0.0)" are satisfied.
Unsatisfied dependency: [org.eclipse.emf.compare.sdk.feature.group 0.8.1.v200902100450] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.emf.compare.feature.gr oup/[0.8.1.v200902100450,0.8.1.v200902100450]
Unsatisfied dependency: [org.eclipse.emf.mint 0.8.0.v200906161513] requiredCapability: osgi.bundle/org.eclipse.core.resources/[3.5.0,4.0.0)
Unsatisfied dependency: [org.eclipse.emf.mint 0.8.0.v200906161513] requiredCapability: osgi.bundle/org.eclipse.emf.codegen.ecore/[2.5.0,3.0.0)
Unsatisfied dependency: [org.eclipse.emf.compare.feature.group 0.8.1.v200902100450] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.emf.compare.match/[0.8 .1.v200902100450,0.8.1.v200902100450]
Unsatisfied dependency: [org.eclipse.emf.compare.feature.group 0.8.1.v200902100450] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.emf.compare.diff/[0.8. 1.v200902100450,0.8.1.v200902100450]
Unsatisfied dependency: [org.eclipse.emf.compare.feature.group 0.8.1.v200902100450] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.emf.compare/[0.8.1.v20 0902100450,0.8.1.v200902100450]

Any ideas what I'm doing wrong here?
Re: Cannot install IAM [message #482288 is a reply to message #482240] Wed, 26 August 2009 05:40 Go to previous messageGo to next message
Abel Mui is currently offline Abel MuiFriend
Messages: 247
Registered: July 2009
Senior Member
Hello Abble,

Looks like you didn't add the EMFT update site:
http://download.eclipse.org/modeling/emft/updates/releases/

If you still can not install, check the installation instructions:
http://code.google.com/p/q4e/wiki/Installation

I have just installed on a clean Eclipse 3.4.2 SDK (without buckminster
and subversive integrations).

Let us know if you need more help.

Abbie Tittizer wrote:
> Attempting to install IAM via Software Updates in Eclipse 3.4.2. I get
> the following errors:
>
> Cannot complete the request. See the details.
> Cannot find a solution where both "org.eclipse.emf.compare.match
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare.match [0.8.1.v200902100450]"
> are satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare [0.8.1.v200902100450]" are
> satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare.diff
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare.diff [0.8.1.v200902100450]"
> are satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare.match
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare.match [0.8.1.v200902100450]"
> are satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare [0.8.1.v200902100450]" are
> satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare.diff
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare.diff [0.8.1.v200902100450]"
> are satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare [0.8.1.v200902100450]" are
> satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare.diff
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare.diff [0.8.1.v200902100450]"
> are satisfied.
> Unsatisfied dependency: [org.eclipse.emf.mint 0.8.0.v200906161513]
> requiredCapability: osgi.bundle/org.eclipse.emf.codegen.ecore/[2.5.0,3.0.0)
> Cannot find a solution where both "bundle org.eclipse.emf.codegen.ecore
> [2.4.2,2.5.0)" and "bundle org.eclipse.emf.codegen.ecore [2.5.0,3.0.0)"
> are satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare.match
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare.match [0.8.1.v200902100450]"
> are satisfied.
> Unsatisfied dependency: [org.eclipse.emf.mint 0.8.0.v200906161513]
> requiredCapability: osgi.bundle/org.eclipse.core.resources/[3.5.0,4.0.0)
> Cannot find a solution where both "bundle org.eclipse.core.resources
> [3.4.1,3.5.0)" and "bundle org.eclipse.core.resources [3.5.0,4.0.0)" are
> satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare [0.8.1.v200902100450]" are
> satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare.diff
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare.diff [0.8.1.v200902100450]"
> are satisfied.
> Cannot find a solution where both "bundle org.eclipse.emf.codegen.ecore
> [2.4.2,2.5.0)" and "bundle org.eclipse.emf.codegen.ecore [2.5.0,3.0.0)"
> are satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare.match
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare.match [0.8.1.v200902100450]"
> are satisfied.
> Cannot find a solution where both "bundle org.eclipse.core.resources
> [3.4.1,3.5.0)" and "bundle org.eclipse.core.resources [3.5.0,4.0.0)" are
> satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare [0.8.1.v200902100450]" are
> satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare.diff
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare.diff [0.8.1.v200902100450]"
> are satisfied.
> Cannot find a solution where both "bundle org.eclipse.emf.codegen.ecore
> [2.4.2,2.5.0)" and "bundle org.eclipse.emf.codegen.ecore [2.5.0,3.0.0)"
> are satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare.match
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare.match [0.8.1.v200902100450]"
> are satisfied.
> Cannot find a solution where both "bundle org.eclipse.core.resources
> [3.4.1,3.5.0)" and "bundle org.eclipse.core.resources [3.5.0,4.0.0)" are
> satisfied.
> Unsatisfied dependency: [org.eclipse.emf.compare.sdk.feature.group
> 0.8.1.v200902100450] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.emf.compare.feature.gr
> oup/[0.8.1.v200902100450,0.8.1.v200902100450]
> Unsatisfied dependency: [org.eclipse.emf.mint 0.8.0.v200906161513]
> requiredCapability: osgi.bundle/org.eclipse.core.resources/[3.5.0,4.0.0)
> Unsatisfied dependency: [org.eclipse.emf.mint 0.8.0.v200906161513]
> requiredCapability: osgi.bundle/org.eclipse.emf.codegen.ecore/[2.5.0,3.0.0)
> Unsatisfied dependency: [org.eclipse.emf.compare.feature.group
> 0.8.1.v200902100450] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.emf.compare.match/[0.8
> .1.v200902100450,0.8.1.v200902100450]
> Unsatisfied dependency: [org.eclipse.emf.compare.feature.group
> 0.8.1.v200902100450] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.emf.compare.diff/[0.8.
> 1.v200902100450,0.8.1.v200902100450]
> Unsatisfied dependency: [org.eclipse.emf.compare.feature.group
> 0.8.1.v200902100450] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.emf.compare/[0.8.1.v20
> 0902100450,0.8.1.v200902100450]
>
> Any ideas what I'm doing wrong here?
Re: Cannot install IAM [message #482450 is a reply to message #482288] Wed, 26 August 2009 15:15 Go to previous messageGo to next message
Abbie Tittizer is currently offline Abbie TittizerFriend
Messages: 6
Registered: August 2009
Junior Member
Abel,
That helped, except now I'm getting:

Cannot find a solution satisfying the following requirements bundle javax.wsdl [1.5.1,1.6.0).

Any idea what this is?

Thanks,
Abbie
Re: Cannot install IAM [message #482475 is a reply to message #482450] Wed, 26 August 2009 17:10 Go to previous messageGo to next message
Abel Mui is currently offline Abel MuiFriend
Messages: 247
Registered: July 2009
Senior Member
Hello Abbie,

javax.wsdl is not used by IAM, so there must be something else confusing
your Eclipse.

Try using the "Refresh" button and/or updating installed plug-ins before
trying to install IAM.

For a quick test, you can download a fresh Eclipse 3.4 from
http://www.eclipse.org/downloads/packages/release/ganymede/s r2
(Eclipse IDE for Java EE Developer is recomended, but IAM will run on
Eclipse Classic too)


Abbie Tittizer wrote:
> Abel,
> That helped, except now I'm getting:
>
> Cannot find a solution satisfying the following requirements bundle
> javax.wsdl [1.5.1,1.6.0).
>
> Any idea what this is?
>
> Thanks,
> Abbie
Re: Cannot install IAM [message #484688 is a reply to message #482475] Tue, 08 September 2009 18:19 Go to previous messageGo to next message
Abbie Tittizer is currently offline Abbie TittizerFriend
Messages: 6
Registered: August 2009
Junior Member
I'm not sure what the solution to this actually was, but one day it just worked (when I was showing a colleague to get another perspective on it). Thanks for the help.
Re: Cannot install IAM [message #570838 is a reply to message #482240] Wed, 26 August 2009 05:40 Go to previous messageGo to next message
Abel Mui is currently offline Abel MuiFriend
Messages: 247
Registered: July 2009
Senior Member
Hello Abble,

Looks like you didn't add the EMFT update site:
http://download.eclipse.org/modeling/emft/updates/releases/

If you still can not install, check the installation instructions:
http://code.google.com/p/q4e/wiki/Installation

I have just installed on a clean Eclipse 3.4.2 SDK (without buckminster
and subversive integrations).

Let us know if you need more help.

Abbie Tittizer wrote:
> Attempting to install IAM via Software Updates in Eclipse 3.4.2. I get
> the following errors:
>
> Cannot complete the request. See the details.
> Cannot find a solution where both "org.eclipse.emf.compare.match
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare.match [0.8.1.v200902100450]"
> are satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare [0.8.1.v200902100450]" are
> satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare.diff
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare.diff [0.8.1.v200902100450]"
> are satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare.match
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare.match [0.8.1.v200902100450]"
> are satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare [0.8.1.v200902100450]" are
> satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare.diff
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare.diff [0.8.1.v200902100450]"
> are satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare [0.8.1.v200902100450]" are
> satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare.diff
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare.diff [0.8.1.v200902100450]"
> are satisfied.
> Unsatisfied dependency: [org.eclipse.emf.mint 0.8.0.v200906161513]
> requiredCapability: osgi.bundle/org.eclipse.emf.codegen.ecore/[2.5.0,3.0.0)
> Cannot find a solution where both "bundle org.eclipse.emf.codegen.ecore
> [2.4.2,2.5.0)" and "bundle org.eclipse.emf.codegen.ecore [2.5.0,3.0.0)"
> are satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare.match
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare.match [0.8.1.v200902100450]"
> are satisfied.
> Unsatisfied dependency: [org.eclipse.emf.mint 0.8.0.v200906161513]
> requiredCapability: osgi.bundle/org.eclipse.core.resources/[3.5.0,4.0.0)
> Cannot find a solution where both "bundle org.eclipse.core.resources
> [3.4.1,3.5.0)" and "bundle org.eclipse.core.resources [3.5.0,4.0.0)" are
> satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare [0.8.1.v200902100450]" are
> satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare.diff
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare.diff [0.8.1.v200902100450]"
> are satisfied.
> Cannot find a solution where both "bundle org.eclipse.emf.codegen.ecore
> [2.4.2,2.5.0)" and "bundle org.eclipse.emf.codegen.ecore [2.5.0,3.0.0)"
> are satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare.match
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare.match [0.8.1.v200902100450]"
> are satisfied.
> Cannot find a solution where both "bundle org.eclipse.core.resources
> [3.4.1,3.5.0)" and "bundle org.eclipse.core.resources [3.5.0,4.0.0)" are
> satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare [0.8.1.v200902100450]" are
> satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare.diff
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare.diff [0.8.1.v200902100450]"
> are satisfied.
> Cannot find a solution where both "bundle org.eclipse.emf.codegen.ecore
> [2.4.2,2.5.0)" and "bundle org.eclipse.emf.codegen.ecore [2.5.0,3.0.0)"
> are satisfied.
> Cannot find a solution where both "org.eclipse.emf.compare.match
> [1.0.0,2.0.0)" and "org.eclipse.emf.compare.match [0.8.1.v200902100450]"
> are satisfied.
> Cannot find a solution where both "bundle org.eclipse.core.resources
> [3.4.1,3.5.0)" and "bundle org.eclipse.core.resources [3.5.0,4.0.0)" are
> satisfied.
> Unsatisfied dependency: [org.eclipse.emf.compare.sdk.feature.group
> 0.8.1.v200902100450] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.emf.compare.feature.gr
> oup/[0.8.1.v200902100450,0.8.1.v200902100450]
> Unsatisfied dependency: [org.eclipse.emf.mint 0.8.0.v200906161513]
> requiredCapability: osgi.bundle/org.eclipse.core.resources/[3.5.0,4.0.0)
> Unsatisfied dependency: [org.eclipse.emf.mint 0.8.0.v200906161513]
> requiredCapability: osgi.bundle/org.eclipse.emf.codegen.ecore/[2.5.0,3.0.0)
> Unsatisfied dependency: [org.eclipse.emf.compare.feature.group
> 0.8.1.v200902100450] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.emf.compare.match/[0.8
> .1.v200902100450,0.8.1.v200902100450]
> Unsatisfied dependency: [org.eclipse.emf.compare.feature.group
> 0.8.1.v200902100450] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.emf.compare.diff/[0.8.
> 1.v200902100450,0.8.1.v200902100450]
> Unsatisfied dependency: [org.eclipse.emf.compare.feature.group
> 0.8.1.v200902100450] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.emf.compare/[0.8.1.v20
> 0902100450,0.8.1.v200902100450]
>
> Any ideas what I'm doing wrong here?
Re: Cannot install IAM [message #570922 is a reply to message #482288] Wed, 26 August 2009 15:15 Go to previous messageGo to next message
Abbie Tittizer is currently offline Abbie TittizerFriend
Messages: 6
Registered: August 2009
Junior Member
Abel,
That helped, except now I'm getting:

Cannot find a solution satisfying the following requirements bundle javax.wsdl [1.5.1,1.6.0).

Any idea what this is?

Thanks,
Abbie
Re: Cannot install IAM [message #570941 is a reply to message #570922] Wed, 26 August 2009 17:10 Go to previous messageGo to next message
Abel Mui is currently offline Abel MuiFriend
Messages: 247
Registered: July 2009
Senior Member
Hello Abbie,

javax.wsdl is not used by IAM, so there must be something else confusing
your Eclipse.

Try using the "Refresh" button and/or updating installed plug-ins before
trying to install IAM.

For a quick test, you can download a fresh Eclipse 3.4 from
http://www.eclipse.org/downloads/packages/release/ganymede/s r2
(Eclipse IDE for Java EE Developer is recomended, but IAM will run on
Eclipse Classic too)


Abbie Tittizer wrote:
> Abel,
> That helped, except now I'm getting:
>
> Cannot find a solution satisfying the following requirements bundle
> javax.wsdl [1.5.1,1.6.0).
>
> Any idea what this is?
>
> Thanks,
> Abbie
Re: Cannot install IAM [message #571003 is a reply to message #482475] Tue, 08 September 2009 18:19 Go to previous message
Abbie Tittizer is currently offline Abbie TittizerFriend
Messages: 6
Registered: August 2009
Junior Member
I'm not sure what the solution to this actually was, but one day it just worked (when I was showing a colleague to get another perspective on it). Thanks for the help.
Previous Topic:Endless rebuilding in IAM Maven Builder
Next Topic:Editor does not pick up dependencies
Goto Forum:
  


Current Time: Fri Nov 21 17:55:16 GMT 2014

Powered by FUDForum. Page generated in 0.19073 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software