Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » re-publishing EAR on JBoss with Eclipse 3.5 won't work
re-publishing EAR on JBoss with Eclipse 3.5 won't work [message #482141] Tue, 25 August 2009 13:45 Go to next message
Giampaolo Tomassoni is currently offline Giampaolo TomassoniFriend
Messages: 8
Registered: August 2009
Junior Member
After adding a moderate to big new EAR project to a local JBoss server in the "Servers" tab, eclipse deployes it just fine and jboss detects and installs it as well.

If you then make some change to some file in the EAR project, attempting to use the "publish" button in the "Servers" tab, results in JBoss to issue an error. It seems that Eclipse attempts re-building the .ear file directly into the JBoss' deploy folder. If the project is big enough, it happens that JBoss detect a new version of the .ear file before Eclipse has done building it.

However, if one "remove"s the project from the JBoss server in the "Servers" tab and then add it back, it seems that Eclipse rebuilds the .ear off-line and *then* moves it to the JBoss deploy folder, which should be the expected behaviour also for the "publish" case.

WST Server Core 3.1.0.v200901260254-30Et8s733L3E4H

Is anybody experiencing the same? Eclipse 3.4 (can't remember the WST ver) worked just fine.
Re: re-publishing EAR on JBoss with Eclipse 3.5 won't work [message #482199 is a reply to message #482141] Tue, 25 August 2009 16:42 Go to previous messageGo to next message
Marcos is currently offline MarcosFriend
Messages: 68
Registered: July 2009
Member
Giampaolo, I'm having this same problem in Eclipse 3.5 with JBoss. In
Eclipse 3.4 everything works ok. Now I know I'm not alone on this.

Marcos

Giampaolo Tomassoni wrote:

> After adding a moderate to big new EAR project to a local JBoss server in
the "Servers" tab, eclipse deployes it just fine and jboss detects and
installs it as well.

> If you then make some change to some file in the EAR project, attempting to
use the "publish" button in the "Servers" tab, results in JBoss to issue an
error. It seems that Eclipse attempts re-building the .ear file directly into
the JBoss' deploy folder. If the project is big enough, it happens that JBoss
detect a new version of the .ear file before Eclipse has done building it.

> However, if one "remove"s the project from the JBoss server in the "Servers"
tab and then add it back, it seems that Eclipse rebuilds the .ear off-line and
*then* moves it to the JBoss deploy folder, which should be the expected
behaviour also for the "publish" case.

> WST Server Core 3.1.0.v200901260254-30Et8s733L3E4H

> Is anybody experiencing the same? Eclipse 3.4 (can't remember the WST ver)
worked just fine.
Re: re-publishing EAR on JBoss with Eclipse 3.5 won't work [message #482203 is a reply to message #482199] Tue, 25 August 2009 16:58 Go to previous messageGo to next message
Giampaolo Tomassoni is currently offline Giampaolo TomassoniFriend
Messages: 8
Registered: August 2009
Junior Member
Here in Italy we say "Mal comune, mezzo gaudio" (shared trouble, half a joy).

Your reply confirms the problem has nothing to do with my specific config. So I'm going to place a bug on this.
Re: re-publishing EAR on JBoss with Eclipse 3.5 won't work [message #482211 is a reply to message #482203] Tue, 25 August 2009 17:19 Go to previous messageGo to next message
Giampaolo Tomassoni is currently offline Giampaolo TomassoniFriend
Messages: 8
Registered: August 2009
Junior Member
This is bug#287585 now.
Re: re-publishing EAR on JBoss with Eclipse 3.5 won't work [message #482213 is a reply to message #482211] Tue, 25 August 2009 17:23 Go to previous message
Marcos is currently offline MarcosFriend
Messages: 68
Registered: July 2009
Member
Giampaolo Tomassoni wrote:

> This is https://bugs.eclipse.org/bugs/show_bug.cgi?id=287585 now.

Well done.

Marcos
Previous Topic:wb-module deploy-name keeps reverting!
Next Topic:404 error
Goto Forum:
  


Current Time: Sat Nov 22 16:57:06 GMT 2014

Powered by FUDForum. Page generated in 0.02303 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software