Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Newbie problem launching Eclipse Application
Newbie problem launching Eclipse Application [message #482032] Tue, 25 August 2009 03:52 Go to next message
Joel Greenyer is currently offline Joel Greenyer
Messages: 170
Registered: July 2009
Senior Member
Hi,
I've installed TPTP with the Galileo Modeling Tools Package. I would like to profile certain plug-ins that I'm
developing. So I selected "Profile As..." and selected my previous eclipse launch configuration and leave everything on
default. The "test availability" of the java profiler says that the connection is successful. However, when starting the
application (hitting "Profile") I get the following NullPointerException.


java.lang.NullPointerException
at
org.eclipse.pde.ui.launcher.EclipseApplicationLaunchConfigur ation.getVMArguments(EclipseApplicationLaunchConfiguration.j ava:278)
at
org.eclipse.tptp.platform.integration.pde.internal.delegator s.AbstractRuntimeWorkbenchDelegate.getVMArguments(AbstractRu ntimeWorkbenchDelegate.java:76)
at org.eclipse.tptp.trace.ui.provisional.launcher.AbstractProce ssLauncher.preLaunch(AbstractProcessLauncher.java:105)
at
org.eclipse.tptp.platform.integration.pde.internal.delegator s.AbstractRuntimeWorkbenchDelegate.preLaunch(AbstractRuntime WorkbenchDelegate.java:46)
at org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.launch(TIDelegateHelper.java:342)
at
org.eclipse.tptp.platform.jvmti.client.internal.launcher.TIR untimeWorkbenchDelegate.launch(TIRuntimeWorkbenchDelegate.ja va:32)
at org.eclipse.tptp.trace.ui.internal.launcher.core.LauncherUti lity.delegateInit(LauncherUtility.java:1164)
at org.eclipse.tptp.trace.ui.provisional.launcher.PrimaryLaunch Delegate.run(PrimaryLaunchDelegate.java:195)
at java.lang.Thread.run(Unknown Source)


What am I doing wrong?

Thanks for helping

Joel
Re: Newbie problem launching Eclipse Application [message #482044 is a reply to message #482032] Tue, 25 August 2009 04:29 Go to previous message
Joel Greenyer is currently offline Joel Greenyer
Messages: 170
Registered: July 2009
Senior Member
I just see that this is a known bug (280841). I downloaded an installed the 4.6.0 runtime package
tptp.runtime-TPTP-4.6.0.zip

Now it works

Joel Greenyer wrote:
> Hi,
> I've installed TPTP with the Galileo Modeling Tools Package. I would
> like to profile certain plug-ins that I'm developing. So I selected
> "Profile As..." and selected my previous eclipse launch configuration
> and leave everything on default. The "test availability" of the java
> profiler says that the connection is successful. However, when starting
> the application (hitting "Profile") I get the following
> NullPointerException.
>
>
> java.lang.NullPointerException
> at
> org.eclipse.pde.ui.launcher.EclipseApplicationLaunchConfigur ation.getVMArguments(EclipseApplicationLaunchConfiguration.j ava:278)
>
> at
> org.eclipse.tptp.platform.integration.pde.internal.delegator s.AbstractRuntimeWorkbenchDelegate.getVMArguments(AbstractRu ntimeWorkbenchDelegate.java:76)
>
> at
> org.eclipse.tptp.trace.ui.provisional.launcher.AbstractProce ssLauncher.preLaunch(AbstractProcessLauncher.java:105)
>
> at
> org.eclipse.tptp.platform.integration.pde.internal.delegator s.AbstractRuntimeWorkbenchDelegate.preLaunch(AbstractRuntime WorkbenchDelegate.java:46)
>
> at
> org.eclipse.tptp.platform.jvmti.client.internal.launcher.TID elegateHelper.launch(TIDelegateHelper.java:342)
>
> at
> org.eclipse.tptp.platform.jvmti.client.internal.launcher.TIR untimeWorkbenchDelegate.launch(TIRuntimeWorkbenchDelegate.ja va:32)
>
> at
> org.eclipse.tptp.trace.ui.internal.launcher.core.LauncherUti lity.delegateInit(LauncherUtility.java:1164)
>
> at
> org.eclipse.tptp.trace.ui.provisional.launcher.PrimaryLaunch Delegate.run(PrimaryLaunchDelegate.java:195)
>
> at java.lang.Thread.run(Unknown Source)
>
>
> What am I doing wrong?
>
> Thanks for helping
>
> Joel
Previous Topic:Mixed launch mode not Supported:[profile]
Next Topic:TPTP ran fine for first time but getting a time-out
Goto Forum:
  


Current Time: Fri Aug 29 22:24:13 EDT 2014

Powered by FUDForum. Page generated in 0.11418 seconds