Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » IMP » Problem installing IMP on Eclipse 3.5
Problem installing IMP on Eclipse 3.5 [message #481793] Mon, 24 August 2009 07:02 Go to next message
Brian Payton is currently offline Brian Payton
Messages: 152
Registered: July 2009
Senior Member
I'm trying to install IMP on Eclipse 3.5 GA using the Update site
http://download.eclipse.org/technology/imp/updates. I was able to
install the following IMP components:

IMP Program Analysis (Incubation) 0.1.6
IMP Program Analysis UI (Incubation) 0.1.5
IMP Runtime (Incubation) 0.1.99
IMP Source Formatting Support (Incubation) 0.1.4
LPG Generator and Templates 2.0.16
LPG Runtime (Incubation) 2.0.16

But I was not able to install these components:

IMP Language Meta-Tooling (Incubation) 0.1.94
LPG Meta-Tooling (Incubation) 0.1.90

Here's the message I get when I try to install the IMP Language
Meta-Tooling:

Cannot complete the install because one or more required items could not
be found.
Software currently installed: IMP Language Meta-Tooling (Incubation)
0.1.94 (org.eclipse.imp.metatooling.feature.group 0.1.94)
Missing requirement: IMP Cheat Sheets (Incubation) 0.1.82
(org.eclipse.imp.cheatsheets 0.1.82) requires 'bundle
org.eclipse.imp.lpg.metatooling 0.0.0' but it could not be found
Cannot satisfy dependency:
From: IMP Language Meta-Tooling (Incubation) 0.1.94
(org.eclipse.imp.metatooling.feature.group 0.1.94)
To: org.eclipse.imp.cheatsheets [0.1.82]

And here's the message when I try to install the LPG Meta-Tooling component:

Cannot complete the install because one or more required items could not
be found.
Software currently installed: LPG Meta-Tooling (Incubation) 0.1.90
(org.eclipse.imp.lpg.feature.group 0.1.90)
Missing requirement: LPG IDE (Incubation) 0.1.86
(org.eclipse.imp.lpg.metatooling 0.1.86) requires 'bundle
org.eclipse.imp.metatooling 0.0.0' but it could not be found
Cannot satisfy dependency:
From: LPG Meta-Tooling (Incubation) 0.1.90
(org.eclipse.imp.lpg.feature.group 0.1.90)
To: org.eclipse.imp.lpg.metatooling [0.1.86]

Am I doing something wrong? Is there a way to install the components in
my IDE without going through the Update manager?

Brian Payton
Optim Data Studio Development
IBM Silicon Valley Laboratory
Re: Problem installing IMP on Eclipse 3.5 [message #484257 is a reply to message #481793] Fri, 04 September 2009 16:43 Go to previous messageGo to next message
Robert M. Fuhrer is currently offline Robert M. Fuhrer
Messages: 294
Registered: July 2009
Senior Member
Hi there,

[Sorry for taking a while to respond to this.]

I think you shouldn't have any problems if you install the latest
release (published a few days ago) from the update site, and select
both the IMP Metatooling and LPG Metatooling features.

That said, I was surprised to see the dependency you discovered.
(But thanks for bringing this to our attention!)

Schematically, in ASCII art:

----------------------------------- -------------------------------
| IMP Metatooling feature | | LPG Metatooling feature |
| | | |
| ---------------------------- | | ------------------------| |
| | o.e.i.cheatsheets plugin | | | | o.e.i.lpg.metatooling | |
| | depends on: | | | | | |
| | o.e.i.lpg.metatooling | | | ------------------------- |
| ---------------------------- | | |
| depends on: | | depends on: |
| o.e.i.runtime | | <no feature deps> |
----------------------------------- -------------------------------


This obviously shouldn't be:

- For one thing, the feature deps should abstract their plugin deps.
[I.e., if feature F1 contains plugin P1, and feature F2 contains
plugin P2, and P1 depends on P2, then F1 should depend on F2.]

- Perhaps more importantly, if anything, the LPG Metatooling components
should depend on the IMP Metatooling components, and not the other
way around.

This will be fixed in the next release.

Brian Payton wrote:
> I'm trying to install IMP on Eclipse 3.5 GA using the Update site
> http://download.eclipse.org/technology/imp/updates. I was able to
> install the following IMP components:
>
> IMP Program Analysis (Incubation) 0.1.6
> IMP Program Analysis UI (Incubation) 0.1.5
> IMP Runtime (Incubation) 0.1.99
> IMP Source Formatting Support (Incubation) 0.1.4
> LPG Generator and Templates 2.0.16
> LPG Runtime (Incubation) 2.0.16
>
> But I was not able to install these components:
>
> IMP Language Meta-Tooling (Incubation) 0.1.94
> LPG Meta-Tooling (Incubation) 0.1.90
>
> Here's the message I get when I try to install the IMP Language
> Meta-Tooling:
>
> Cannot complete the install because one or more required items could not
> be found.
> Software currently installed: IMP Language Meta-Tooling (Incubation)
> 0.1.94 (org.eclipse.imp.metatooling.feature.group 0.1.94)
> Missing requirement: IMP Cheat Sheets (Incubation) 0.1.82
> (org.eclipse.imp.cheatsheets 0.1.82) requires 'bundle
> org.eclipse.imp.lpg.metatooling 0.0.0' but it could not be found
> Cannot satisfy dependency:
> From: IMP Language Meta-Tooling (Incubation) 0.1.94
> (org.eclipse.imp.metatooling.feature.group 0.1.94)
> To: org.eclipse.imp.cheatsheets [0.1.82]
>
> And here's the message when I try to install the LPG Meta-Tooling
> component:
>
> Cannot complete the install because one or more required items could not
> be found.
> Software currently installed: LPG Meta-Tooling (Incubation) 0.1.90
> (org.eclipse.imp.lpg.feature.group 0.1.90)
> Missing requirement: LPG IDE (Incubation) 0.1.86
> (org.eclipse.imp.lpg.metatooling 0.1.86) requires 'bundle
> org.eclipse.imp.metatooling 0.0.0' but it could not be found
> Cannot satisfy dependency:
> From: LPG Meta-Tooling (Incubation) 0.1.90
> (org.eclipse.imp.lpg.feature.group 0.1.90)
> To: org.eclipse.imp.lpg.metatooling [0.1.86]
>
> Am I doing something wrong? Is there a way to install the components in
> my IDE without going through the Update manager?
>
> Brian Payton
> Optim Data Studio Development
> IBM Silicon Valley Laboratory


--
Cheers,
-- Bob

--------------------------------
Robert M. Fuhrer
Research Staff Member
Programming Technologies Dept.
IBM T.J. Watson Research Center

IDE Meta-tooling Platform Project Lead (http://www.eclipse.org/imp)
X10: Productive High-Performance Parallel Programming (http://x10.sf.net)
Re: Problem installing IMP on Eclipse 3.5 [message #484701 is a reply to message #484257] Tue, 08 September 2009 15:20 Go to previous message
Brian Payton is currently offline Brian Payton
Messages: 152
Registered: July 2009
Senior Member
OK, thanks. The install of the latest IMP release completed successfully.

Robert M. Fuhrer wrote:
> Hi there,
>
> [Sorry for taking a while to respond to this.]
>
> I think you shouldn't have any problems if you install the latest
> release (published a few days ago) from the update site, and select
> both the IMP Metatooling and LPG Metatooling features.
>
> That said, I was surprised to see the dependency you discovered.
> (But thanks for bringing this to our attention!)
>
> Schematically, in ASCII art:
>
> ----------------------------------- -------------------------------
> | IMP Metatooling feature | | LPG Metatooling feature |
> | | | |
> | ---------------------------- | | ------------------------| |
> | | o.e.i.cheatsheets plugin | | | | o.e.i.lpg.metatooling | |
> | | depends on: | | | | | |
> | | o.e.i.lpg.metatooling | | | ------------------------- |
> | ---------------------------- | | |
> | depends on: | | depends on: |
> | o.e.i.runtime | | <no feature deps> |
> ----------------------------------- -------------------------------
>
>
> This obviously shouldn't be:
>
> - For one thing, the feature deps should abstract their plugin deps.
> [I.e., if feature F1 contains plugin P1, and feature F2 contains
> plugin P2, and P1 depends on P2, then F1 should depend on F2.]
>
> - Perhaps more importantly, if anything, the LPG Metatooling components
> should depend on the IMP Metatooling components, and not the other
> way around.
>
> This will be fixed in the next release.
>
> Brian Payton wrote:
>> I'm trying to install IMP on Eclipse 3.5 GA using the Update site
>> http://download.eclipse.org/technology/imp/updates. I was able to
>> install the following IMP components:
>>
>> IMP Program Analysis (Incubation) 0.1.6
>> IMP Program Analysis UI (Incubation) 0.1.5
>> IMP Runtime (Incubation) 0.1.99
>> IMP Source Formatting Support (Incubation) 0.1.4
>> LPG Generator and Templates 2.0.16
>> LPG Runtime (Incubation) 2.0.16
>>
>> But I was not able to install these components:
>>
>> IMP Language Meta-Tooling (Incubation) 0.1.94
>> LPG Meta-Tooling (Incubation) 0.1.90
>>
>> Here's the message I get when I try to install the IMP Language
>> Meta-Tooling:
>>
>> Cannot complete the install because one or more required items could
>> not be found.
>> Software currently installed: IMP Language Meta-Tooling (Incubation)
>> 0.1.94 (org.eclipse.imp.metatooling.feature.group 0.1.94)
>> Missing requirement: IMP Cheat Sheets (Incubation) 0.1.82
>> (org.eclipse.imp.cheatsheets 0.1.82) requires 'bundle
>> org.eclipse.imp.lpg.metatooling 0.0.0' but it could not be found
>> Cannot satisfy dependency:
>> From: IMP Language Meta-Tooling (Incubation) 0.1.94
>> (org.eclipse.imp.metatooling.feature.group 0.1.94)
>> To: org.eclipse.imp.cheatsheets [0.1.82]
>>
>> And here's the message when I try to install the LPG Meta-Tooling
>> component:
>>
>> Cannot complete the install because one or more required items could
>> not be found.
>> Software currently installed: LPG Meta-Tooling (Incubation) 0.1.90
>> (org.eclipse.imp.lpg.feature.group 0.1.90)
>> Missing requirement: LPG IDE (Incubation) 0.1.86
>> (org.eclipse.imp.lpg.metatooling 0.1.86) requires 'bundle
>> org.eclipse.imp.metatooling 0.0.0' but it could not be found
>> Cannot satisfy dependency:
>> From: LPG Meta-Tooling (Incubation) 0.1.90
>> (org.eclipse.imp.lpg.feature.group 0.1.90)
>> To: org.eclipse.imp.lpg.metatooling [0.1.86]
>>
>> Am I doing something wrong? Is there a way to install the components
>> in my IDE without going through the Update manager?
>>
>> Brian Payton
>> Optim Data Studio Development
>> IBM Silicon Valley Laboratory
>
>
Re: Problem installing IMP on Eclipse 3.5 [message #576472 is a reply to message #481793] Fri, 04 September 2009 16:43 Go to previous message
Robert M. Fuhrer is currently offline Robert M. Fuhrer
Messages: 294
Registered: July 2009
Senior Member
Hi there,

[Sorry for taking a while to respond to this.]

I think you shouldn't have any problems if you install the latest
release (published a few days ago) from the update site, and select
both the IMP Metatooling and LPG Metatooling features.

That said, I was surprised to see the dependency you discovered.
(But thanks for bringing this to our attention!)

Schematically, in ASCII art:

----------------------------------- -------------------------------
| IMP Metatooling feature | | LPG Metatooling feature |
| | | |
| ---------------------------- | | ------------------------| |
| | o.e.i.cheatsheets plugin | | | | o.e.i.lpg.metatooling | |
| | depends on: | | | | | |
| | o.e.i.lpg.metatooling | | | ------------------------- |
| ---------------------------- | | |
| depends on: | | depends on: |
| o.e.i.runtime | | <no feature deps> |
----------------------------------- -------------------------------


This obviously shouldn't be:

- For one thing, the feature deps should abstract their plugin deps.
[I.e., if feature F1 contains plugin P1, and feature F2 contains
plugin P2, and P1 depends on P2, then F1 should depend on F2.]

- Perhaps more importantly, if anything, the LPG Metatooling components
should depend on the IMP Metatooling components, and not the other
way around.

This will be fixed in the next release.

Brian Payton wrote:
> I'm trying to install IMP on Eclipse 3.5 GA using the Update site
> http://download.eclipse.org/technology/imp/updates I was able to
> install the following IMP components:
>
> IMP Program Analysis (Incubation) 0.1.6
> IMP Program Analysis UI (Incubation) 0.1.5
> IMP Runtime (Incubation) 0.1.99
> IMP Source Formatting Support (Incubation) 0.1.4
> LPG Generator and Templates 2.0.16
> LPG Runtime (Incubation) 2.0.16
>
> But I was not able to install these components:
>
> IMP Language Meta-Tooling (Incubation) 0.1.94
> LPG Meta-Tooling (Incubation) 0.1.90
>
> Here's the message I get when I try to install the IMP Language
> Meta-Tooling:
>
> Cannot complete the install because one or more required items could not
> be found.
> Software currently installed: IMP Language Meta-Tooling (Incubation)
> 0.1.94 (org.eclipse.imp.metatooling.feature.group 0.1.94)
> Missing requirement: IMP Cheat Sheets (Incubation) 0.1.82
> (org.eclipse.imp.cheatsheets 0.1.82) requires 'bundle
> org.eclipse.imp.lpg.metatooling 0.0.0' but it could not be found
> Cannot satisfy dependency:
> From: IMP Language Meta-Tooling (Incubation) 0.1.94
> (org.eclipse.imp.metatooling.feature.group 0.1.94)
> To: org.eclipse.imp.cheatsheets [0.1.82]
>
> And here's the message when I try to install the LPG Meta-Tooling
> component:
>
> Cannot complete the install because one or more required items could not
> be found.
> Software currently installed: LPG Meta-Tooling (Incubation) 0.1.90
> (org.eclipse.imp.lpg.feature.group 0.1.90)
> Missing requirement: LPG IDE (Incubation) 0.1.86
> (org.eclipse.imp.lpg.metatooling 0.1.86) requires 'bundle
> org.eclipse.imp.metatooling 0.0.0' but it could not be found
> Cannot satisfy dependency:
> From: LPG Meta-Tooling (Incubation) 0.1.90
> (org.eclipse.imp.lpg.feature.group 0.1.90)
> To: org.eclipse.imp.lpg.metatooling [0.1.86]
>
> Am I doing something wrong? Is there a way to install the components in
> my IDE without going through the Update manager?
>
> Brian Payton
> Optim Data Studio Development
> IBM Silicon Valley Laboratory


--
Cheers,
-- Bob

--------------------------------
Robert M. Fuhrer
Research Staff Member
Programming Technologies Dept.
IBM T.J. Watson Research Center

IDE Meta-tooling Platform Project Lead (http://www.eclipse.org/imp)
X10: Productive High-Performance Parallel Programming (http://x10.sf.net)
Re: Problem installing IMP on Eclipse 3.5 [message #576486 is a reply to message #484257] Tue, 08 September 2009 15:20 Go to previous message
Brian Payton is currently offline Brian Payton
Messages: 152
Registered: July 2009
Senior Member
OK, thanks. The install of the latest IMP release completed successfully.

Robert M. Fuhrer wrote:
> Hi there,
>
> [Sorry for taking a while to respond to this.]
>
> I think you shouldn't have any problems if you install the latest
> release (published a few days ago) from the update site, and select
> both the IMP Metatooling and LPG Metatooling features.
>
> That said, I was surprised to see the dependency you discovered.
> (But thanks for bringing this to our attention!)
>
> Schematically, in ASCII art:
>
> ----------------------------------- -------------------------------
> | IMP Metatooling feature | | LPG Metatooling feature |
> | | | |
> | ---------------------------- | | ------------------------| |
> | | o.e.i.cheatsheets plugin | | | | o.e.i.lpg.metatooling | |
> | | depends on: | | | | | |
> | | o.e.i.lpg.metatooling | | | ------------------------- |
> | ---------------------------- | | |
> | depends on: | | depends on: |
> | o.e.i.runtime | | <no feature deps> |
> ----------------------------------- -------------------------------
>
>
> This obviously shouldn't be:
>
> - For one thing, the feature deps should abstract their plugin deps.
> [I.e., if feature F1 contains plugin P1, and feature F2 contains
> plugin P2, and P1 depends on P2, then F1 should depend on F2.]
>
> - Perhaps more importantly, if anything, the LPG Metatooling components
> should depend on the IMP Metatooling components, and not the other
> way around.
>
> This will be fixed in the next release.
>
> Brian Payton wrote:
>> I'm trying to install IMP on Eclipse 3.5 GA using the Update site
>> http://download.eclipse.org/technology/imp/updates I was able to
>> install the following IMP components:
>>
>> IMP Program Analysis (Incubation) 0.1.6
>> IMP Program Analysis UI (Incubation) 0.1.5
>> IMP Runtime (Incubation) 0.1.99
>> IMP Source Formatting Support (Incubation) 0.1.4
>> LPG Generator and Templates 2.0.16
>> LPG Runtime (Incubation) 2.0.16
>>
>> But I was not able to install these components:
>>
>> IMP Language Meta-Tooling (Incubation) 0.1.94
>> LPG Meta-Tooling (Incubation) 0.1.90
>>
>> Here's the message I get when I try to install the IMP Language
>> Meta-Tooling:
>>
>> Cannot complete the install because one or more required items could
>> not be found.
>> Software currently installed: IMP Language Meta-Tooling (Incubation)
>> 0.1.94 (org.eclipse.imp.metatooling.feature.group 0.1.94)
>> Missing requirement: IMP Cheat Sheets (Incubation) 0.1.82
>> (org.eclipse.imp.cheatsheets 0.1.82) requires 'bundle
>> org.eclipse.imp.lpg.metatooling 0.0.0' but it could not be found
>> Cannot satisfy dependency:
>> From: IMP Language Meta-Tooling (Incubation) 0.1.94
>> (org.eclipse.imp.metatooling.feature.group 0.1.94)
>> To: org.eclipse.imp.cheatsheets [0.1.82]
>>
>> And here's the message when I try to install the LPG Meta-Tooling
>> component:
>>
>> Cannot complete the install because one or more required items could
>> not be found.
>> Software currently installed: LPG Meta-Tooling (Incubation) 0.1.90
>> (org.eclipse.imp.lpg.feature.group 0.1.90)
>> Missing requirement: LPG IDE (Incubation) 0.1.86
>> (org.eclipse.imp.lpg.metatooling 0.1.86) requires 'bundle
>> org.eclipse.imp.metatooling 0.0.0' but it could not be found
>> Cannot satisfy dependency:
>> From: LPG Meta-Tooling (Incubation) 0.1.90
>> (org.eclipse.imp.lpg.feature.group 0.1.90)
>> To: org.eclipse.imp.lpg.metatooling [0.1.86]
>>
>> Am I doing something wrong? Is there a way to install the components
>> in my IDE without going through the Update manager?
>>
>> Brian Payton
>> Optim Data Studio Development
>> IBM Silicon Valley Laboratory
>
>
Previous Topic:Reorganization of the IMP SVN repository on eclipse.org
Next Topic:IMP LPG editor syntax errors on %options declarations
Goto Forum:
  


Current Time: Sun Aug 31 02:31:19 EDT 2014

Powered by FUDForum. Page generated in 0.01812 seconds