Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DSDP - Mobile Tools for Java (MTJ) » Problems with Motorola device
Problems with Motorola device [message #480895] Tue, 18 August 2009 15:21 Go to next message
Eclipse User
Originally posted by: news.s237965939.online.de

I've newly installed Eclipse/Pulsar along with the Motodev SDK. After
problems with my own application I loaded a sample project from the SDK
called Scene3d. My device is a Motorola V3 and when I downloaded the
original jar I got an installation error. This probably because the
original is designed for CLDC-1.1 and my phone only supports CLDC-1.0.
So I changed that to 1.0 and rebuilt the project. Now it installs but
when I start it I simply get "Application error" message.

Same thing whith my own project. Can someone tell what's going wrong
here? Both run perfectly on the emulator and on my Sony/Ericsson too.
May it have to do with obfucation, I'm using Proguard 4.2 ?

TIA,
Hans
Re: Problems with Motorola device [message #480896 is a reply to message #480895] Tue, 18 August 2009 15:35 Go to previous messageGo to next message
Eclipse User
Originally posted by: news.s237965939.online.de

Hans-J. Ude wrote:

> May it have to do with obfucation, I'm using Proguard 4.2 ?

So far I can answer my own question. It is "No", Proguard is not the
problem.

Hans
Re: Problems with Motorola device [message #480937 is a reply to message #480895] Tue, 18 August 2009 22:22 Go to previous message
David Marques is currently offline David Marques
Messages: 80
Registered: July 2009
Member
Hello Hans,

Nice to hear from you again! Well i am not sure but i think that your
device might not have the 3d api does it ?? In case you are sure it does,
please try to get a stacktrace from your app since the error message does
not help a lot!

Regards,

David Marques

Hans-J. Ude wrote:

> I've newly installed Eclipse/Pulsar along with the Motodev SDK. After
> problems with my own application I loaded a sample project from the SDK
> called Scene3d. My device is a Motorola V3 and when I downloaded the
> original jar I got an installation error. This probably because the
> original is designed for CLDC-1.1 and my phone only supports CLDC-1.0.
> So I changed that to 1.0 and rebuilt the project. Now it installs but
> when I start it I simply get "Application error" message.

> Same thing whith my own project. Can someone tell what's going wrong
> here? Both run perfectly on the emulator and on my Sony/Ericsson too.
> May it have to do with obfucation, I'm using Proguard 4.2 ?

> TIA,
> Hans
Re: Problems with Motorola device [message #575962 is a reply to message #480895] Tue, 18 August 2009 15:35 Go to previous message
Eclipse User
Originally posted by: news.s237965939.online.de

Hans-J. Ude wrote:

> May it have to do with obfucation, I'm using Proguard 4.2 ?

So far I can answer my own question. It is "No", Proguard is not the
problem.

Hans
Re: Problems with Motorola device [message #575985 is a reply to message #480895] Tue, 18 August 2009 22:22 Go to previous message
David Marques is currently offline David Marques
Messages: 80
Registered: July 2009
Member
Hello Hans,

Nice to hear from you again! Well i am not sure but i think that your
device might not have the 3d api does it ?? In case you are sure it does,
please try to get a stacktrace from your app since the error message does
not help a lot!

Regards,

David Marques

Hans-J. Ude wrote:

> I've newly installed Eclipse/Pulsar along with the Motodev SDK. After
> problems with my own application I loaded a sample project from the SDK
> called Scene3d. My device is a Motorola V3 and when I downloaded the
> original jar I got an installation error. This probably because the
> original is designed for CLDC-1.1 and my phone only supports CLDC-1.0.
> So I changed that to 1.0 and rebuilt the project. Now it installs but
> when I start it I simply get "Application error" message.

> Same thing whith my own project. Can someone tell what's going wrong
> here? Both run perfectly on the emulator and on my Sony/Ericsson too.
> May it have to do with obfucation, I'm using Proguard 4.2 ?

> TIA,
> Hans
Previous Topic:Problems with Motorola device
Next Topic:Boolean clauses in preprocessor directives
Goto Forum:
  


Current Time: Sat Aug 23 09:31:58 EDT 2014

Powered by FUDForum. Page generated in 0.02089 seconds