Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Epsilon » Problem with generated wizards
Problem with generated wizards [message #480341] Sat, 15 August 2009 13:03 Go to next message
St is currently offline StFriend
Messages: 77
Registered: July 2009
Member
Hi list,
I have a project with wizards and operations files plus plugin.xml
declaration of wizards for my metamodel, but it doesn't work as it should
: there is only one eclass for which wizards work.

Here is the tar.gz of the workspace:
http://stephaneerard.fr/workspaces-epsilon-tools.tar.gz

The project in question is eclipse-project-0.1.
The working wizard is src/eclipse_project/Project/Project.ewl

I think the problem comes from the plugin.xml declarations as I tested the
ewl files using epsilon prefs and it worked.
I have tried two different nsURI declarations, like:
"http://eclipse-project/0.1"
and
"http://eclipse-project/0.1/Project/Building/Command"
for the eclipse_project::Project::Building::Command eclass as example.

There are no error or warning markers nowhere regarding this problem
(existing errors correspond to generated and copied files from
epsilonTools to eclipse-project, didn't clean the workspace, just delete
epsilonTools/src/src and actions dir somewhere else within to get them
away) :(

Thank you !
Re: Problem with generated wizards [message #480487 is a reply to message #480341] Mon, 17 August 2009 11:35 Go to previous message
Dimitrios Kolovos is currently offline Dimitrios KolovosFriend
Messages: 1776
Registered: July 2009
Senior Member
Hi Stephane,

Could you possibly come up with a minimal version that reproduces this
problem so that I can investigate? Off the top of my head, since it
works through the preferences, but not through plugin.xml, I suspect
that you may not include the folder in which the .ewl module is
contained in the build. Other than that, preferences and contributed
extensions are handled uniformly (see getEwlURIsForEObjects(...) in
https://dev.eclipse.org/svnroot/modeling/org.eclipse.gmt.eps ilon/trunk/plugins/org.eclipse.epsilon.ewl.emf/src/org/eclip se/epsilon/ewl/emf/AbstractContributeWizardsAction.java)


Cheers,
Dimitris

Stephane wrote:
> Hi list,
> I have a project with wizards and operations files plus plugin.xml
> declaration of wizards for my metamodel, but it doesn't work as it
> should : there is only one eclass for which wizards work.
>
> Here is the tar.gz of the workspace:
> http://stephaneerard.fr/workspaces-epsilon-tools.tar.gz
>
> The project in question is eclipse-project-0.1.
> The working wizard is src/eclipse_project/Project/Project.ewl
>
> I think the problem comes from the plugin.xml declarations as I tested
> the ewl files using epsilon prefs and it worked.
> I have tried two different nsURI declarations, like:
> "http://eclipse-project/0.1"
> and "http://eclipse-project/0.1/Project/Building/Command"
> for the eclipse_project::Project::Building::Command eclass as example.
> There are no error or warning markers nowhere regarding this problem
> (existing errors correspond to generated and copied files from
> epsilonTools to eclipse-project, didn't clean the workspace, just delete
> epsilonTools/src/src and actions dir somewhere else within to get them
> away) :(
>
> Thank you !
>
>
Re: Problem with generated wizards [message #574177 is a reply to message #480341] Mon, 17 August 2009 11:35 Go to previous message
Dimitrios Kolovos is currently offline Dimitrios KolovosFriend
Messages: 1776
Registered: July 2009
Senior Member
Hi Stephane,

Could you possibly come up with a minimal version that reproduces this
problem so that I can investigate? Off the top of my head, since it
works through the preferences, but not through plugin.xml, I suspect
that you may not include the folder in which the .ewl module is
contained in the build. Other than that, preferences and contributed
extensions are handled uniformly (see getEwlURIsForEObjects(...) in
https://dev.eclipse.org/svnroot/modeling/org.eclipse.gmt.eps ilon/trunk/plugins/org.eclipse.epsilon.ewl.emf/src/org/eclip se/epsilon/ewl/emf/AbstractContributeWizardsAction.java)


Cheers,
Dimitris

Stephane wrote:
> Hi list,
> I have a project with wizards and operations files plus plugin.xml
> declaration of wizards for my metamodel, but it doesn't work as it
> should : there is only one eclass for which wizards work.
>
> Here is the tar.gz of the workspace:
> http://stephaneerard.fr/workspaces-epsilon-tools.tar.gz
>
> The project in question is eclipse-project-0.1.
> The working wizard is src/eclipse_project/Project/Project.ewl
>
> I think the problem comes from the plugin.xml declarations as I tested
> the ewl files using epsilon prefs and it worked.
> I have tried two different nsURI declarations, like:
> "http://eclipse-project/0.1"
> and "http://eclipse-project/0.1/Project/Building/Command"
> for the eclipse_project::Project::Building::Command eclass as example.
> There are no error or warning markers nowhere regarding this problem
> (existing errors correspond to generated and copied files from
> epsilonTools to eclipse-project, didn't clean the workspace, just delete
> epsilonTools/src/src and actions dir somewhere else within to get them
> away) :(
>
> Thank you !
>
>
Previous Topic:[EuGENia | EOL] GMFMap Link mapping manipulation
Next Topic:[EuGENia | EOL] GMFMap Link mapping manipulation
Goto Forum:
  


Current Time: Sun Nov 23 03:51:11 GMT 2014

Powered by FUDForum. Page generated in 0.11441 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software