Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Web Tools Project (WTP) » Failed while installing Dynamic Web Module 2.5
Failed while installing Dynamic Web Module 2.5 [message #480304] Fri, 14 August 2009 20:55 Go to next message
Eclipse User
Originally posted by: louisseize.gmx.de

Eclipse IDE for Java Developers (Galileo)
Build id: 20090619-0625
Eclipse Web Developer Tools:
3.1.0.v200905242131-7R77FShEVw2xUGpF1LiNxdVAELXy

The creation of a Dynamic Web Project in Galileo with WTP via the Dynamic
Web Project wizard elicits an error message:

Failed while installing Dynamic Web Module 2.5
Reason: [ditto]
Details: java.lang.NullPointerException

Project contents: Use default
Target runtime: Apache Tomcat v6.0 (works)
Dynamic web module version: 2.5
Configuration: Default Configuration for Apache Tomcat v6.0
[all defaults accepted]

The error occurs on clicking "Finish".

The project "xxx" is created; however, when trying to add a servlet to
"xxx" via the wizard, the project "xxx" is not available in the selector
labeled "Web project". The web project creation appears to have been a
failure.

Googling for the error message brings up some hits (for 2.5 and 2.4), but
no resolution. What could it be?

Being an Eclipe noob, what could I do to track this down?

Note that I'm *not* using the "Eclipse IDE for Java EE Developers", but
the simply the "Eclipse IDE for Java Developers" with additional
components such as WST, Subclipse, Java EE Developer Tools installed.
Re: Failed while installing Dynamic Web Module 2.5 [message #480575 is a reply to message #480304] Mon, 17 August 2009 17:03 Go to previous messageGo to next message
Larry Isaacs is currently offline Larry Isaacs
Messages: 1305
Registered: July 2009
Senior Member
Michael Ludwig wrote:
> Eclipse IDE for Java Developers (Galileo)
> Build id: 20090619-0625
> Eclipse Web Developer Tools:
> 3.1.0.v200905242131-7R77FShEVw2xUGpF1LiNxdVAELXy
>
> The creation of a Dynamic Web Project in Galileo with WTP via the
> Dynamic Web Project wizard elicits an error message:
>
> Failed while installing Dynamic Web Module 2.5
> Reason: [ditto]
> Details: java.lang.NullPointerException
>
> Project contents: Use default
> Target runtime: Apache Tomcat v6.0 (works)
> Dynamic web module version: 2.5
> Configuration: Default Configuration for Apache Tomcat v6.0
> [all defaults accepted]
>
> The error occurs on clicking "Finish".
>
> The project "xxx" is created; however, when trying to add a servlet to
> "xxx" via the wizard, the project "xxx" is not available in the selector
> labeled "Web project". The web project creation appears to have been a
> failure.
>
> Googling for the error message brings up some hits (for 2.5 and 2.4),
> but no resolution. What could it be?
>
> Being an Eclipe noob, what could I do to track this down?
>
> Note that I'm *not* using the "Eclipse IDE for Java EE Developers", but
> the simply the "Eclipse IDE for Java Developers" with additional
> components such as WST, Subclipse, Java EE Developer Tools installed.
>

Michael,

Is this still a problem? If so, seeing the stack trace leading to the
NullPointerException would help.

Cheers,
Larry
Re: Failed while installing Dynamic Web Module 2.5 [message #480923 is a reply to message #480575] Tue, 18 August 2009 23:33 Go to previous messageGo to next message
Sebastiano Suraci is currently offline Sebastiano Suraci
Messages: 4
Registered: August 2009
Junior Member
Same problem for mee too. Stack trace follows ... Thanks in advance

java.lang.NullPointerException: No IModelProvider exists for project P/TestJSP of version: Dynamic Web Module 2.5
at org.eclipse.jst.j2ee.model.ModelProviderManager.getModelProv ider(ModelProviderManager.java:99)
at org.eclipse.jst.j2ee.web.project.facet.WebFacetInstallDelega te.createWeb25DeploymentDescriptor(WebFacetInstallDelegate.j ava:283)
at org.eclipse.jst.j2ee.web.project.facet.WebFacetInstallDelega te.execute(WebFacetInstallDelegate.java:116)
at org.eclipse.wst.common.project.facet.core.internal.FacetedPr oject.callDelegate(FacetedProject.java:1467)
at org.eclipse.wst.common.project.facet.core.internal.FacetedPr oject.modifyInternal(FacetedProject.java:438)
at org.eclipse.wst.common.project.facet.core.internal.FacetedPr oject.mergeChangesInternal(FacetedProject.java:1171)
at org.eclipse.wst.common.project.facet.core.internal.FacetedPr oject.access$2(FacetedProject.java:1107)
at org.eclipse.wst.common.project.facet.core.internal.FacetedPr oject$5.run(FacetedProject.java:1089)
at org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1800)
at org.eclipse.wst.common.project.facet.core.internal.FacetedPr oject.mergeChanges(FacetedProject.java:1099)
at org.eclipse.wst.common.project.facet.core.internal.FacetedPr ojectWorkingCopy.commitChanges(FacetedProjectWorkingCopy.jav a:1958)
at org.eclipse.wst.common.project.facet.ui.ModifyFacetedProject Wizard.performFinish(ModifyFacetedProjectWizard.java:400)
at org.eclipse.wst.web.ui.internal.wizards.NewProjectDataModelF acetWizard.performFinish(NewProjectDataModelFacetWizard.java :279)
at org.eclipse.wst.common.project.facet.ui.ModifyFacetedProject Wizard$3.run(ModifyFacetedProjectWizard.java:331)
at org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1800)
at org.eclipse.wst.common.project.facet.ui.ModifyFacetedProject Wizard$4.run(ModifyFacetedProjectWizard.java:345)
at org.eclipse.jface.operation.ModalContext$ModalContextThread. run(ModalContext.java:121)
Re: Failed while installing Dynamic Web Module 2.5 [message #480925 is a reply to message #480575] Wed, 19 August 2009 00:15 Go to previous messageGo to next message
Sebastiano Suraci is currently offline Sebastiano Suraci
Messages: 4
Registered: August 2009
Junior Member
Same problem for me too ... stack trace follows. Thanks in advance.

java.lang.NullPointerException: No IModelProvider exists for project P/TestJSP of version: Dynamic Web Module 2.5
at org.eclipse.jst.j2ee.model.ModelProviderManager.getModelProv ider(ModelProviderManager.java:99)
at org.eclipse.jst.j2ee.web.project.facet.WebFacetInstallDelega te.createWeb25DeploymentDescriptor(WebFacetInstallDelegate.j ava:283)
at org.eclipse.jst.j2ee.web.project.facet.WebFacetInstallDelega te.execute(WebFacetInstallDelegate.java:116)
at org.eclipse.wst.common.project.facet.core.internal.FacetedPr oject.callDelegate(FacetedProject.java:1467)
at org.eclipse.wst.common.project.facet.core.internal.FacetedPr oject.modifyInternal(FacetedProject.java:438)
at org.eclipse.wst.common.project.facet.core.internal.FacetedPr oject.mergeChangesInternal(FacetedProject.java:1171)
at org.eclipse.wst.common.project.facet.core.internal.FacetedPr oject.access$2(FacetedProject.java:1107)
at org.eclipse.wst.common.project.facet.core.internal.FacetedPr oject$5.run(FacetedProject.java:1089)
at org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1800)
at org.eclipse.wst.common.project.facet.core.internal.FacetedPr oject.mergeChanges(FacetedProject.java:1099)
at org.eclipse.wst.common.project.facet.core.internal.FacetedPr ojectWorkingCopy.commitChanges(FacetedProjectWorkingCopy.jav a:1958)
at org.eclipse.wst.common.project.facet.ui.ModifyFacetedProject Wizard.performFinish(ModifyFacetedProjectWizard.java:400)
at org.eclipse.wst.web.ui.internal.wizards.NewProjectDataModelF acetWizard.performFinish(NewProjectDataModelFacetWizard.java :279)
at org.eclipse.wst.common.project.facet.ui.ModifyFacetedProject Wizard$3.run(ModifyFacetedProjectWizard.java:331)
at org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1800)
at org.eclipse.wst.common.project.facet.ui.ModifyFacetedProject Wizard$4.run(ModifyFacetedProjectWizard.java:345)
at org.eclipse.jface.operation.ModalContext$ModalContextThread. run(ModalContext.java:121)
Re: Failed while installing Dynamic Web Module 2.5 [message #480928 is a reply to message #480925] Wed, 19 August 2009 00:34 Go to previous messageGo to next message
Sebastiano Suraci is currently offline Sebastiano Suraci
Messages: 4
Registered: August 2009
Junior Member
Sorry for double posting ...
Forgot to say that Dynamic Web Module 2.4 works without problems

Thanks again
Re: Failed while installing Dynamic Web Module 2.5 [message #480931 is a reply to message #480928] Wed, 19 August 2009 00:50 Go to previous messageGo to next message
Sebastiano Suraci is currently offline Sebastiano Suraci
Messages: 4
Registered: August 2009
Junior Member
Solved it, installing additional packages for j2ee develpment (not sure which package did the magic, installed almost all of them) ...

Anyway I think the cause is a dependency mismatch between WTP and J2EE plugins ...

Greetings
Re: Failed while installing Dynamic Web Module 2.5 [message #482830 is a reply to message #480575] Fri, 28 August 2009 09:39 Go to previous messageGo to next message
Michael Ludwig is currently offline Michael Ludwig
Messages: 8
Registered: August 2009
Junior Member
Larry,

sorry I lost of track this thread I started. Reading Sebastiano's reply below, I installed all items in the collection "Web, XML, and Java EE Development" from the Galileo release site. That fixed it.

Where does Eclipse write stack traces? Didn't see any in the Eclipse installation directory. Do I have to do some configuration to make log files appear?

Michael Ludwig
Re: Failed while installing Dynamic Web Module 2.5 [message #482841 is a reply to message #482830] Fri, 28 August 2009 10:20 Go to previous messageGo to next message
Wolfgang Knauf is currently offline Wolfgang Knauf
Messages: 63
Registered: July 2009
Member
Hi Michael,

> Where does Eclipse write stack traces? Didn't see any in the Eclipse
> installation directory. Do I have to do some configuration to make log
> files appear?
>

"...\workspace\.metadata\.log" contains all Eclipse errors.

Best regards

Wolfgang
Re: Failed while installing Dynamic Web Module 2.5 [message #482981 is a reply to message #482841] Fri, 28 August 2009 20:28 Go to previous messageGo to next message
Michael Ludwig is currently offline Michael Ludwig
Messages: 8
Registered: August 2009
Junior Member
Indeed. Besten Dank, Wolfgang!

Michael
Re: Failed while installing Dynamic Web Module 2.5 [message #483075 is a reply to message #482841] Sun, 30 August 2009 20:57 Go to previous messageGo to next message
Mark is currently offline Mark
Messages: 61
Registered: July 2009
Member
I'm having the same issue and nothing I try fixes it. Stack dump is
below. Please help!

!ENTRY org.eclipse.core.resources 4 2 2009-08-30 16:52:03.728
!MESSAGE Problems occurred when invoking code from plug-in:
"org.eclipse.core.resources".
!STACK 0
java.lang.NullPointerException
at
org.eclipse.jst.j2ee.refactor.operations.ProjectRefactorMeta data$RefererCachingVirtualComponent. <init>(ProjectRefactorMetadata.java:354)
at
org.eclipse.jst.j2ee.refactor.operations.ProjectRefactorMeta data.computeMetadata(ProjectRefactorMetadata.java:88)
at
org.eclipse.jst.j2ee.refactor.operations.ProjectRefactorMeta data.computeMetadata(ProjectRefactorMetadata.java:78)
at
org.eclipse.jst.j2ee.refactor.listeners.ProjectRefactoringLi stener.cacheDeletedProjectMetadata(ProjectRefactoringListene r.java:100)
at
org.eclipse.jst.j2ee.refactor.listeners.ProjectRefactoringLi stener.resourceChanged(ProjectRefactoringListener.java:87)
at
org.eclipse.core.internal.events.NotificationManager$2.run(N otificationManager.java:288)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at
org.eclipse.core.internal.events.NotificationManager.notify( NotificationManager.java:282)
at
org.eclipse.core.internal.events.NotificationManager.handleE vent(NotificationManager.java:260)
at
org.eclipse.core.internal.resources.Workspace.broadcastEvent (Workspace.java:307)
at
org.eclipse.core.internal.resources.Resource.broadcastPreDel eteEvent(Resource.java:1777)
at org.eclipse.core.internal.resources.Resource.delete(Resource .java:696)
at org.eclipse.core.internal.resources.Project.delete(Project.j ava:309)
at
org.eclipse.ltk.core.refactoring.resource.DeleteResourceChan ge.perform(DeleteResourceChange.java:131)
at
org.eclipse.ltk.core.refactoring.CompositeChange.perform(Com positeChange.java:278)
at
org.eclipse.ltk.core.refactoring.CompositeChange.perform(Com positeChange.java:278)
at
org.eclipse.ltk.core.refactoring.PerformChangeOperation$1.ru n(PerformChangeOperation.java:260)
at org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1800)
at
org.eclipse.ltk.core.refactoring.PerformChangeOperation.exec uteChange(PerformChangeOperation.java:308)
at
org.eclipse.ltk.internal.ui.refactoring.UIPerformChangeOpera tion.access$1(UIPerformChangeOperation.java:1)
at
org.eclipse.ltk.internal.ui.refactoring.UIPerformChangeOpera tion$1.run(UIPerformChangeOperation.java:66)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at
org.eclipse.ltk.internal.ui.refactoring.UIPerformChangeOpera tion$2.run(UIPerformChangeOperation.java:84)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:3 5)
at
org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchr onizer.java:133)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.jav a:3800)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3425)
at
org.eclipse.jface.operation.ModalContext$ModalContextThread. block(ModalContext.java:173)
at org.eclipse.jface.operation.ModalContext.run(ModalContext.ja va:388)
at
org.eclipse.ltk.internal.ui.refactoring.RefactoringWizardDia log2.run(RefactoringWizardDialog2.java:317)
at
org.eclipse.ltk.ui.refactoring.RefactoringWizard.internalPer formFinish(RefactoringWizard.java:558)
at
org.eclipse.ltk.ui.refactoring.UserInputWizardPage.performFi nish(UserInputWizardPage.java:154)
at
org.eclipse.ltk.ui.refactoring.resource.DeleteResourcesWizar d$DeleteResourcesRefactoringConfigurationPage.performFinish( DeleteResourcesWizard.java:147)
at
org.eclipse.ltk.ui.refactoring.RefactoringWizard.performFini sh(RefactoringWizard.java:622)
at
org.eclipse.ltk.internal.ui.refactoring.RefactoringWizardDia log2.okPressed(RefactoringWizardDialog2.java:446)
at org.eclipse.jface.dialogs.Dialog.buttonPressed(Dialog.java:4 72)
at org.eclipse.jface.dialogs.Dialog$2.widgetSelected(Dialog.jav a:624)
at
org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListe ner.java:228)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java :84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1003)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.ja va:3823)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3422)
at org.eclipse.jface.window.Window.runEventLoop(Window.java:825 )
at org.eclipse.jface.window.Window.open(Window.java:801)
at
org.eclipse.ltk.ui.refactoring.RefactoringWizardOpenOperatio n$1.run(RefactoringWizardOpenOperation.java:144)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator .java:70)
at
org.eclipse.ltk.ui.refactoring.RefactoringWizardOpenOperatio n.run(RefactoringWizardOpenOperation.java:156)
at
org.eclipse.ltk.internal.ui.refactoring.actions.DeleteResour cesHandler.execute(DeleteResourcesHandler.java:41)
at
org.eclipse.ui.internal.handlers.HandlerProxy.execute(Handle rProxy.java:281)
at org.eclipse.core.commands.Command.executeWithChecks(Command. java:476)
at
org.eclipse.core.commands.ParameterizedCommand.executeWithCh ecks(ParameterizedCommand.java:508)
at
org.eclipse.ui.internal.handlers.HandlerService.executeComma ndInContext(HandlerService.java:270)
at
org.eclipse.ui.internal.ide.actions.LTKLauncher.runCommand(L TKLauncher.java:95)
at
org.eclipse.ui.internal.ide.actions.LTKLauncher.openDeleteWi zard(LTKLauncher.java:47)
at
org.eclipse.ui.actions.DeleteResourceAction.run(DeleteResour ceAction.java:480)
at
org.eclipse.jdt.internal.ui.refactoring.reorg.DeleteAction.r un(DeleteAction.java:71)
at
org.eclipse.jdt.ui.actions.SelectionDispatchAction.dispatchR un(SelectionDispatchAction.java:274)
at
org.eclipse.jdt.ui.actions.SelectionDispatchAction.run(Selec tionDispatchAction.java:250)
at org.eclipse.jface.action.Action.runWithEvent(Action.java:498 )
at
org.eclipse.jface.action.ActionContributionItem.handleWidget Selection(ActionContributionItem.java:583)
at
org.eclipse.jface.action.ActionContributionItem.access$2(Act ionContributionItem.java:500)
at
org.eclipse.jface.action.ActionContributionItem$5.handleEven t(ActionContributionItem.java:411)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java :84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1003)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.ja va:3823)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java :3422)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.jav a:2384)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2348)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:22 00)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:495)
at
org.eclipse.core.databinding.observable.Realm.runWithDefault (Realm.java:288)
at
org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Work bench.java:490)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.j ava:149)
at
org.eclipse.ui.internal.ide.application.IDEApplication.start (IDEApplication.java:113)
at
org.eclipse.equinox.internal.app.EclipseAppHandle.run(Eclips eAppHandle.java:193)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .runApplication(EclipseAppLauncher.java:110)
at
org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher .start(EclipseAppLauncher.java:79)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:386)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseS tarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java: 549)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
Re: Failed while installing Dynamic Web Module 2.5 [message #483077 is a reply to message #483075] Sun, 30 August 2009 22:37 Go to previous messageGo to next message
Michael Ludwig is currently offline Michael Ludwig
Messages: 8
Registered: August 2009
Junior Member
Your stack trace is different from the one Sebastiano has posted, which is the same I've observed in my Eclipse log file once I discovered it.

So I don't think you're experiencing the same issue.

If you're still sure it's the same issue, you can try installing all items in the collection "Web, XML, and Java EE Development" from the Galileo release site. That fixed it for me and, apparently, for Sebastiano as well.
Re: Failed while installing Dynamic Web Mod ule 2.5 [message #483081 is a reply to message #483077] Mon, 31 August 2009 00:28 Go to previous messageGo to next message
Mark is currently offline Mark
Messages: 61
Registered: July 2009
Member
I just reinstalled the Java EE ones and that seems to have fixed it. It's
the 3rd time I tried that though so I guess 3rd time is the charm.
Strange.
Re: Failed while installing Dynamic Web Module 2.5 [message #490014 is a reply to message #480304] Tue, 06 October 2009 21:21 Go to previous messageGo to next message
No real name is currently offline No real name
Messages: 1
Registered: October 2009
Junior Member
It appears that you need to install one or all of the following:

JST Server UI
JST Web UI

It's probably a good idea to also install the following:

JST Server Adapters
WST Server Adapters

Hope this helps.
Re: Failed while installing Dynamic Web Module 2.5 [message #552372 is a reply to message #480304] Wed, 11 August 2010 23:18 Go to previous messageGo to next message
Rich Davies is currently offline Rich Davies
Messages: 1
Registered: August 2010
Junior Member
Thanks for everyone's input, you got me started in the right direction. I had the same symptom, similar solution, but my stacktrace is a bit different.

My Solution:
Installed "Java EE IDE Feature" from
http://download.eclipse.org/technology/epp/packages/galileo

My Log Entry:
!ENTRY org.eclipse.wst.common.project.facet.core 4 0 2010-08-11 16:16:31.599
!MESSAGE Failed while installing Dynamic Web Module 2.5.
!STACK 0
java.lang.NullPointerException
at org.eclipse.jst.j2ee.web.project.facet.WebFacetInstallDelega te.createWeb25DeploymentDescriptor(WebFacetInstallDelegate.j ava:247)
at org.eclipse.jst.j2ee.web.project.facet.WebFacetInstallDelega te.execute(WebFacetInstallDelegate.java:117)
at org.eclipse.wst.common.project.facet.core.internal.FacetedPr oject.callDelegate(FacetedProject.java:1467)
at org.eclipse.wst.common.project.facet.core.internal.FacetedPr oject.modifyInternal(FacetedProject.java:438)
at org.eclipse.wst.common.project.facet.core.internal.FacetedPr oject.mergeChangesInternal(FacetedProject.java:1171)
at org.eclipse.wst.common.project.facet.core.internal.FacetedPr oject.access$2(FacetedProject.java:1107)
at org.eclipse.wst.common.project.facet.core.internal.FacetedPr oject$5.run(FacetedProject.java:1089)
at org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1800)
at org.eclipse.wst.common.project.facet.core.internal.FacetedPr oject.mergeChanges(FacetedProject.java:1099)
at org.eclipse.wst.common.project.facet.core.internal.FacetedPr ojectWorkingCopy.commitChanges(FacetedProjectWorkingCopy.jav a:1958)
at org.eclipse.wst.common.project.facet.ui.ModifyFacetedProject Wizard.performFinish(ModifyFacetedProjectWizard.java:400)
at org.eclipse.wst.web.ui.internal.wizards.NewProjectDataModelF acetWizard.performFinish(NewProjectDataModelFacetWizard.java :279)
at org.eclipse.wst.common.project.facet.ui.ModifyFacetedProject Wizard$3.run(ModifyFacetedProjectWizard.java:331)
at org.eclipse.core.internal.resources.Workspace.run(Workspace. java:1800)
at org.eclipse.wst.common.project.facet.ui.ModifyFacetedProject Wizard$4.run(ModifyFacetedProjectWizard.java:345)
at org.eclipse.jface.operation.ModalContext$ModalContextThread. run(ModalContext.java:121)
!SESSION 2010-08-11 16:22:49.062 -----------------------------------------------
eclipse.buildId=
java.version=1.5.0_22
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Framework arguments: -product org.eclipse.epp.package.java.product
Re: Failed while installing Dynamic Web Module 2.5 [message #988832 is a reply to message #490014] Mon, 03 December 2012 11:34 Go to previous message
Hiep N is currently offline Hiep N
Messages: 1
Registered: December 2012
Junior Member
No real name wrote on Tue, 06 October 2009 17:21
It appears that you need to install one or all of the following:

JST Server UI
JST Web UI
JST Server Adapters
WST Server Adapters


This helped in my case with following stack trace:
!MESSAGE No IModelProvider exists for project P/hello-seam of version: Dynamic Web Module 2.5
!STACK 0
java.lang.NullPointerException: No IModelProvider exists for project P/hello-seam of version: Dynamic Web Module 2.5

Thanks Smile
Previous Topic:Eclipse freezes when opening XML schema Editor
Next Topic:Problem with update to version 3.4.1
Goto Forum:
  


Current Time: Tue Sep 16 13:46:08 GMT 2014

Powered by FUDForum. Page generated in 0.12340 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software