Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » BPEL Designer » BPEL Designer Install Fails after Fresh Ganymede Install
BPEL Designer Install Fails after Fresh Ganymede Install [message #480294] Fri, 14 August 2009 19:10 Go to next message
Christopher L. Simons is currently offline Christopher L. SimonsFriend
Messages: 1
Registered: August 2009
Junior Member
I have just installed the Eclipse Java EE IDE 3.4 (Ganymede), build 20090621-0832 from the Downloads front page (http://www.eclipse.org/downloads/). Then, following the instructions at http://download.eclipse.org/technology/bpel/update-site/ (which states: "You need a build of 3.4 (Ganymede) Eclipse SDK for your platform and that's it."), I tried to install the BPEL Visual Designer and received the following error message:

"Cannot complete the install because one or more required items could not be found.
Software being installed: BPEL Visual Designer 0.4.0 (org.eclipse.bpel.feature.feature.group 0.4.0)
Missing requirement: BPEL Visual Designer 0.4.0 (org.eclipse.bpel.feature.feature.group 0.4.0) requires 'javax.wsdl [1.4.0,1.5.0)' but it could not be found"

I am somewhat new to Eclipse. How can I resolve this dependency?

Thanks for your time and assistance.

[Updated on: Fri, 14 August 2009 19:15]

Report message to a moderator

Re: BPEL Visual Designer Fails after Fresh Gany mede Install [message #480971 is a reply to message #480294] Wed, 19 August 2009 08:23 Go to previous messageGo to next message
Youssouf is currently offline YoussoufFriend
Messages: 4
Registered: July 2009
Junior Member
Hi,

You should install the java.xsdl bundle by hand. Just copy the jar file in
the eclipse/pugins/ directory.

Here the different version :

http://download.eclipse.org/tools/orbit/downloads/drops/R200 90529135407/bundles/javax.wsdl_1.4.0.v200806030407.jar
http://download.eclipse.org/tools/orbit/downloads/drops/R200 90529135407/bundles/javax.wsdl_1.5.1.v200806030408.jar
http://download.eclipse.org/tools/orbit/downloads/drops/R200 90529135407/bundles/javax.wsdl_1.6.2.v200806030405.jar

But just take one of them (1.4 or 1.5)

Do the same for other jar if a similar message comes out.
Re: BPEL Visual Designer Fails after Fresh Gany mede Install [message #484955 is a reply to message #480971] Wed, 09 September 2009 21:31 Go to previous messageGo to next message
JIM  is currently offline JIM Friend
Messages: 1
Registered: September 2009
Junior Member
I just installed eclipse-jee-galileo-win32 and found that javax.wsdl_1.5.1.v200806030408.jar is already in the eclipse/plugins directory. However, I still get the same error message:

Cannot complete the install because one or more required items could not be found.
Software being installed: BPEL Visual Designer 0.4.0 (org.eclipse.bpel.feature.feature.group 0.4.0)
Missing requirement: BPEL Visual Designer 0.4.0 (org.eclipse.bpel.feature.feature.group 0.4.0) requires 'javax.wsdl [1.4.0,1.5.0)' but it could not be found

Any suggestions? Thanks in advance.
Re: BPEL Visual Designer Fails after Fresh Gany mede Install [message #485292 is a reply to message #484955] Fri, 11 September 2009 08:12 Go to previous messageGo to next message
Youssouf is currently offline YoussoufFriend
Messages: 4
Registered: July 2009
Junior Member
It seems that you have to stick with the version that is requried :

'javax.wsdl [1.4.0,1.5.0)'

So get exactly the version 1.4.0 or 1.5.0 and don't count on your 1.5.1
version already present in your plugin directory.

I have myself in my plugin directory the versions 1.4.0 and 1.5.1 at the
same time, and it is not problematic.
Re: BPEL Visual Designer Fails after Fresh Gany mede Install [message #486803 is a reply to message #485292] Sat, 19 September 2009 10:12 Go to previous message
cealex  is currently offline cealex Friend
Messages: 2
Registered: September 2009
Junior Member

I installed all versions of "javax.wsdl_1xxx" in the pluggins dir and it worked

I download all 3 version from the following location
http://download.eclipse.org/tools/orbit/downloads/drops/R200 90529135407/bundles/javax.wsdl_1.4.0.v200806030407.jar
http://download.eclipse.org/tools/orbit/downloads/drops/R200 90529135407/bundles/javax.wsdl_1.5.1.v200806030408.jar
http://download.eclipse.org/tools/orbit/downloads/drops/R200 90529135407/bundles/javax.wsdl_1.6.2.v200806030405.jar


i have eclipse-jee-galileo-win32 and
it had in the eclipse/plugins the 1.5 version, so I
deleted the original wsdl 1.5 and copy to the pluggins directory.

i reopen eclipse and after that i can install the bpel designer .




Previous Topic:Invoking Drools Rules Engine from GMF
Next Topic:BPEL Designer user guide?
Goto Forum:
  


Current Time: Mon Dec 22 03:42:19 GMT 2014

Powered by FUDForum. Page generated in 0.01724 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software