Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Mixed launch mode not Supported:[profile]
Mixed launch mode not Supported:[profile] [message #479704] Wed, 12 August 2009 06:23 Go to next message
Anand  is currently offline Anand Friend
Messages: 6
Registered: July 2009
Junior Member
hi all ,

when i try to profile web application (oracle weblogic 10gR3),after
entering all required details i get one message

'Mixed Launch Mode not supported:[Profile]'

so i cannot continue with the profiling of application

i know there are 3 ways the user can launch an application in eclipse
run,debug & profile

any solution to solve this problem

regards
anand
Re: Mixed launch mode not Supported:[profile] [message #480561 is a reply to message #479704] Mon, 17 August 2009 15:44 Go to previous messageGo to next message
Eugene Chan is currently offline Eugene ChanFriend
Messages: 287
Registered: July 2009
Senior Member
Hi Anand,

Could you provide more information on steps to reproduce the problem? What
JRE are you using?

Eugene

"Anand " <anand.prabhakar@wipro.com> wrote in message
news:1e416ccb5fad6e0fd78c56b1b3e340dc$1@www.eclipse.org...
> hi all ,
> when i try to profile web application (oracle weblogic 10gR3),after
> entering all required details i get one message
> 'Mixed Launch Mode not supported:[Profile]'
> so i cannot continue with the profiling of application
>
> i know there are 3 ways the user can launch an application in eclipse
> run,debug & profile
> any solution to solve this problem
>
> regards
> anand
Re: Mixed launch mode not Supported:[profile] [message #480990 is a reply to message #480561] Wed, 19 August 2009 10:01 Go to previous messageGo to next message
Anand  is currently offline Anand Friend
Messages: 6
Registered: July 2009
Junior Member
hi Eugene,
steps:-
1. download the server adapter from update site
2. select application project in workspace--> Profile on server
3. in the server tab 'Mixed launch mode not Supported:[profile]' error
appears, disabling the profile tab

it happens with all jdk version (1.5/1.6)

we're able to profile that application using the standalone agent
controller and then attaching the agent via eclipse workbench to analyze
the profile data

regards
Anand
Re: Mixed launch mode not Supported:[profile] [message #481139 is a reply to message #480990] Wed, 19 August 2009 17:24 Go to previous messageGo to next message
Eugene Chan is currently offline Eugene ChanFriend
Messages: 287
Registered: July 2009
Senior Member
Hi Anand,

It sounds like your workspace have multiple profilers support that cause
conflict and the launcher cannot start a launch with the multiple profilers.
Does the server adapter comes with any profiling support?

Eugene

"Anand " <anand.prabhakar@wipro.com> wrote in message
news:f7f40a74ad7b3c272fb3ac5ba17a6955$1@www.eclipse.org...
> hi Eugene,
> steps:-
> 1. download the server adapter from update site
> 2. select application project in workspace--> Profile on server
> 3. in the server tab 'Mixed launch mode not Supported:[profile]' error
> appears, disabling the profile tab
>
> it happens with all jdk version (1.5/1.6)
>
> we're able to profile that application using the standalone agent
> controller and then attaching the agent via eclipse workbench to analyze
> the profile data
>
> regards
> Anand
Re: Mixed launch mode not Supported:[profile] [message #481241 is a reply to message #481139] Thu, 20 August 2009 08:48 Go to previous messageGo to next message
Anand  is currently offline Anand Friend
Messages: 6
Registered: July 2009
Junior Member
Hi Eugene,

I'm not clear with the term 'multiple profilers',could you please explain

anand
Re: Mixed launch mode not Supported:[profile] [message #481604 is a reply to message #481241] Fri, 21 August 2009 17:50 Go to previous message
Eugene Chan is currently offline Eugene ChanFriend
Messages: 287
Registered: July 2009
Senior Member
Hi Anand,

eg, say you have both TPTP and Yourkit profilers deployed to the workbench.
How about Run mode or Debug mode, does the application run fine in Run mode?

Eugene

"Anand " <anand.prabhakar@wipro.com> wrote in message
news:fe9e0e73b7d133c3825586326945cf24$1@www.eclipse.org...
> Hi Eugene,
>
> I'm not clear with the term 'multiple profilers',could you please explain
>
> anand
>
Previous Topic:Editing WidgetReg.xml file
Next Topic:Newbie problem launching Eclipse Application
Goto Forum:
  


Current Time: Sat Nov 29 07:48:33 GMT 2014

Powered by FUDForum. Page generated in 0.03861 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software