Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 » EMF and UML versions compatibility in standalone application
EMF and UML versions compatibility in standalone application [message #478525] Fri, 19 June 2009 08:37 Go to next message
Martynas  L is currently offline Martynas L
Messages: 16
Registered: July 2009
Junior Member
Hi,

Is it possible to use the older UML version with newer EMF version?
E.g. UML 2.0.4 with EMF 2.4.2 (UML 2.0.4 was built with EMF 2.2.3)

Thanks,
Martynas
Re: EMF and UML versions compatibility in standalone application [message #478534 is a reply to message #478525] Mon, 22 June 2009 18:23 Go to previous message
james bruck is currently offline james bruck
Messages: 1724
Registered: July 2009
Senior Member
Hi Martynas,

Mixing and matching UML2 and EMF versions is not a good idea in general.
UML2 has very strict version range restrictions on dependencies in EMF. In
your particular case, I think you may be safe since I don't believe that
UML2 makes use of incompatible API but you would have to test this out to
make certain.

Cheers,
- James.

"Martynas Lelevicius" <marte@nomagic.com> wrote in message
news:h1fiov$7vn$1@build.eclipse.org...
> Hi,
>
> Is it possible to use the older UML version with newer EMF version?
> E.g. UML 2.0.4 with EMF 2.4.2 (UML 2.0.4 was built with EMF 2.2.3)
>
> Thanks,
> Martynas
Re: EMF and UML versions compatibility in standalone application [message #627713 is a reply to message #478525] Mon, 22 June 2009 18:23 Go to previous message
james bruck is currently offline james bruck
Messages: 1724
Registered: July 2009
Senior Member
Hi Martynas,

Mixing and matching UML2 and EMF versions is not a good idea in general.
UML2 has very strict version range restrictions on dependencies in EMF. In
your particular case, I think you may be safe since I don't believe that
UML2 makes use of incompatible API but you would have to test this out to
make certain.

Cheers,
- James.

"Martynas Lelevicius" <marte@nomagic.com> wrote in message
news:h1fiov$7vn$1@build.eclipse.org...
> Hi,
>
> Is it possible to use the older UML version with newer EMF version?
> E.g. UML 2.0.4 with EMF 2.4.2 (UML 2.0.4 was built with EMF 2.2.3)
>
> Thanks,
> Martynas
Previous Topic:UML Diagram Generation
Next Topic:Performance question:Extending the UML metamodel vs Using stereotypes & profiles
Goto Forum:
  


Current Time: Wed Oct 22 09:39:19 GMT 2014

Powered by FUDForum. Page generated in 0.19259 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software