Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » Mofscript doesn't show action button
Mofscript doesn't show action button [message #48553] Wed, 13 August 2008 12:19 Go to next message
yeliu is currently offline yeliu
Messages: 145
Registered: July 2009
Senior Member
Hello,
I have just installed Mofscript 1.3,0 on Eclipse 3,3,2.but no three
action buttons on the Eclipse UI even though I open .m2t file.What is the
reason?


Many thanks!


Ye
[MOFScript]Re: Mofscript doesn't show action button [message #48583 is a reply to message #48553] Thu, 14 August 2008 08:50 Go to previous messageGo to next message
Gøran K. Olsen is currently offline Gøran K. Olsen
Messages: 184
Registered: July 2009
Senior Member
Hello Ye,

First, MOFScript is not part of the M2T project but GMT and you should post
to eclipse.modeling.gmt and prefix your posting with [MOFScript].This reply
is cross-posted, any follow-ups should only be posted to the gmt list.

I am not sure why you have this problem. You should try the following:

Help -> about eclipse platform -> plug-ins, then sort by plug-in id,
check that you have all the org.eclipse.mofscript.xxx installed.

7 of them, and especially check for the org.eclipse.mofscript.editor.

If this is not the case, try to remove the plugins manually removing all
folders / files in both eclipse\plugins and eclipse\features starting with
org.eclipse.mofscript . Restart eclipse and try to get the latest version
from http://www.modelbased.net/mofscript/update (but it should the same as
the gmt update site)..

Cheers,
G
Re: [MOFScript]Re: Mofscript doesn't show action button [message #48613 is a reply to message #48583] Thu, 14 August 2008 12:40 Go to previous messageGo to next message
yeliu is currently offline yeliu
Messages: 145
Registered: July 2009
Senior Member
Hello,
I have tried to uninstall all the related mofscript plugin and reinstall
them.1.3.0 version from exactly the website you gave me .But the problem
is still the same:no mofscript wizard, no action buttons,no mofscript
preference.
Can you check if it's the following plugins that are required?
org.eclipse.mofscript.help;
org.eclipse.mofscript.model;
org.eclipse.mofscript.traceabilitymodel;
org.eclipse.mofscript.fileresourcemodel.
These are all the update website provide.
And according to the Mofscript guide,plugins related to ANTLR are also
installed:
org.antlr.runtime;
org.antlr.eclipse.ui;
org.antlr.eclipse.core;
org.antlr.doc
org.antlr
What else could be the reason?


Many thanks!
Re: [MOFScript]Re: Mofscript doesn't show action button [message #48672 is a reply to message #48613] Fri, 15 August 2008 07:05 Go to previous messageGo to next message
Eclipse User
Originally posted by: rivas_jorge55.hotmail.com

Hi, i have the same problem, all last week, i was follow the install
instruction but itŽs just dont work, some body have a link to a
bundle_mofscript or a preinstall mofscript UI in eclipse, thats will be
great, any help its usefull thanks.
Re: [MOFScript]Re: Mofscript doesn't show action button [message #48702 is a reply to message #48613] Fri, 15 August 2008 09:33 Go to previous message
Gøran K. Olsen is currently offline Gøran K. Olsen
Messages: 184
Registered: July 2009
Senior Member
Hello Ye (and Jorge)

My suggestion is to download and install the latest Eclipse Ganymede 3.4
Modeling bundle:

http://www.eclipse.org/downloads/download.php?file=/technolo gy/epp/downloads/release/ganymede/R/eclipse-modeling-ganymed e-incubation-win32.zip

Then use the updatesite for MOFScript (http://www.modelbased.net ) it will
be available on eclipse/gmt soon.

This is the configuration I am currently using, and it works.

It should be no problem to follow the same approach using Eclipse 3.3

The latest version of MOFScript does not require the antlr plugins, antlr
3.0 jars are included.

The User manual is unfortunately a bit outdated when it comes to the
installation..

Best Regards
G
Previous Topic:JET and JET2
Next Topic:RSS Feed error
Goto Forum:
  


Current Time: Wed Sep 24 04:36:47 GMT 2014

Powered by FUDForum. Page generated in 0.02120 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software