Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 Tools » Problem installing uml plug-in via update manager
Problem installing uml plug-in via update manager [message #476466] Thu, 07 May 2009 08:22 Go to next message
Geri Grolinger is currently offline Geri GrolingerFriend
Messages: 6
Registered: July 2009
Junior Member
Hi,

I am trying to install the uml2 plug in via the update manager and I have
a the following 'unsatisfied dependency' problem (this is jsut a part of
my Details view):
----
Cannot complete the request. See the details.
Unsatisfied dependency: [org.eclipse.uml2.diagram.feature.group
0.9.0.v200903192032] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.gmf.runtime.diagram.ui .properties/0.0.0
Unsatisfied dependency: [org.eclipse.uml2.diagram.feature.group
0.9.0.v200903192032] requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.gmf.runtime.draw2d.ui/ 0.0.0
----
I am using the Glassfish Tools Bundle for Eclipse.
I added the MDT Update site in my Eclipse Update Manager and from MDT
UML2TOOLs SDK, I tried to install UML2Diagramming and UML2 Tools. Is there
something I should have installed before installing these two?

Also, I'd like to ask if these two plug ins suffice for my purposes - I
only want to generate diagrams from an existing Java code?

Thanks a lot!

Geri
Re: Problem installing uml plug-in via update manager [message #476482 is a reply to message #476466] Thu, 14 May 2009 16:08 Go to previous message
Tatiana Fesenko is currently offline Tatiana FesenkoFriend
Messages: 530
Registered: July 2009
Senior Member
Hi Geri,

> I am trying to install the uml2 plug in via the update manager and I have
> a the following 'unsatisfied dependency' problem (this is jsut a part of
> my Details view):
> ----
> Cannot complete the request. See the details.
> Unsatisfied dependency: [org.eclipse.uml2.diagram.feature.group
> 0.9.0.v200903192032] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.gmf.runtime.diagram.ui .properties/0.0.0
> Unsatisfied dependency: [org.eclipse.uml2.diagram.feature.group
> 0.9.0.v200903192032] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.gmf.runtime.draw2d.ui/ 0.0.0
> ----
> I am using the Glassfish Tools Bundle for Eclipse.
> I added the MDT Update site in my Eclipse Update Manager and from MDT
> UML2TOOLs SDK, I tried to install UML2Diagramming and UML2 Tools. Is there
> something I should have installed before installing these two?

UML2Tools requires the following components to be installed:
EMF - Eclipse Modeling Framework Core Runtime
EMF Common
EMF Common UI
EMF Ecore Edit
EMF Edit
EMF Edit UI
EMF Model Query
EMF Model Transaction
EMF Validation Framework
Graphical Editing Framework GEF
Graphical Editing Framework Draw2d
Graphical Modeling Framework Runtime
EMF Model Transaction Workbench Integration
Graphical Modeling Framework Notation
Third-Party Components for GMF Runtime
Object Constraint Language (OCL) 2.0 Compatibility
UML2 End-User Features

The good news is that the components will be installed automatically if checkbox
'Contact all update sites during install to find required software' from
the first page of the update manager is enabled. I used Eclipse 3.5M7.

> Also, I'd like to ask if these two plug ins suffice for my purposes - I
only want to generate diagrams from an existing Java code?
No, UML2Tools doesn't support reverse ingineering.

Best wishes,
Tanya.
Re: Problem installing uml plug-in via update manager [message #623885 is a reply to message #476466] Thu, 14 May 2009 16:08 Go to previous message
Tatiana Fesenko is currently offline Tatiana FesenkoFriend
Messages: 530
Registered: July 2009
Senior Member
Hi Geri,

> I am trying to install the uml2 plug in via the update manager and I have
> a the following 'unsatisfied dependency' problem (this is jsut a part of
> my Details view):
> ----
> Cannot complete the request. See the details.
> Unsatisfied dependency: [org.eclipse.uml2.diagram.feature.group
> 0.9.0.v200903192032] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.gmf.runtime.diagram.ui .properties/0.0.0
> Unsatisfied dependency: [org.eclipse.uml2.diagram.feature.group
> 0.9.0.v200903192032] requiredCapability:
> org.eclipse.equinox.p2.iu/org.eclipse.gmf.runtime.draw2d.ui/ 0.0.0
> ----
> I am using the Glassfish Tools Bundle for Eclipse.
> I added the MDT Update site in my Eclipse Update Manager and from MDT
> UML2TOOLs SDK, I tried to install UML2Diagramming and UML2 Tools. Is there
> something I should have installed before installing these two?

UML2Tools requires the following components to be installed:
EMF - Eclipse Modeling Framework Core Runtime
EMF Common
EMF Common UI
EMF Ecore Edit
EMF Edit
EMF Edit UI
EMF Model Query
EMF Model Transaction
EMF Validation Framework
Graphical Editing Framework GEF
Graphical Editing Framework Draw2d
Graphical Modeling Framework Runtime
EMF Model Transaction Workbench Integration
Graphical Modeling Framework Notation
Third-Party Components for GMF Runtime
Object Constraint Language (OCL) 2.0 Compatibility
UML2 End-User Features

The good news is that the components will be installed automatically if checkbox
'Contact all update sites during install to find required software' from
the first page of the update manager is enabled. I used Eclipse 3.5M7.

> Also, I'd like to ask if these two plug ins suffice for my purposes - I
only want to generate diagrams from an existing Java code?
No, UML2Tools doesn't support reverse ingineering.

Best wishes,
Tanya.
Previous Topic:[CompositeStructuresD] InstanceSpecification with slots as boxes
Next Topic:Suggestion for UML2 newbie?
Goto Forum:
  


Current Time: Mon Dec 22 11:23:33 GMT 2014

Powered by FUDForum. Page generated in 0.02446 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software