Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 Tools » uml2tools 0.9.0M2 requirements
uml2tools 0.9.0M2 requirements [message #475803] Fri, 31 October 2008 18:20 Go to next message
Jörg von  Frantzius is currently offline Jörg von Frantzius
Messages: 17
Registered: July 2009
Junior Member
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
</head>
<body bgcolor="#ffffff" text="#000000">
Hi,<br>
<br>
I downloaded the modeling package of eclipse 3.4.1 and tried to install
uml2tools 0.9.0M2 from the MDT update site. Unfortunately, update
manager (p2) it tells me:<br>
<blockquote>Cannot find a solution satisfying the following
requirements Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui.workbench/[3.5.0,4. 0.0)]. <br>
<br>
</blockquote>
Now does uml2tools really require eclipse 3.5.0 by itself, or through
one of its dependencies? I may also have just messed up my installation
by installing some available updates, though.<br>
<br>
Regards,<br>
J&ouml;rg<br>
</body>
</html>
Re: uml2tools 0.9.0M2 requirements [message #475804 is a reply to message #475803] Fri, 31 October 2008 19:09 Go to previous messageGo to next message
Jörg von  Frantzius is currently offline Jörg von Frantzius
Messages: 17
Registered: July 2009
Junior Member
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Indeed <a class="moz-txt-link-freetext" href=" http://www.eclipse.org/modeling/mdt/downloads/?project=uml2t ools"> http://www.eclipse.org/modeling/mdt/downloads/?project=uml2t ools</a>
lists eclipse 3.5 as a requirement for 0.9.0.<br>
<br>
However, after downloading eclipse 3.5 and installing all requisites
from the appropriate update managers, this one remains:<br>
<blockquote>Cannot complete the request.&nbsp; See the details.<br>
Cannot find a solution satisfying the following requirements
org.eclipse.emf.edit [2.5.0.v200809231800].<br>
</blockquote>
When I look at my installed plugins, though, there is
org.eclipse.emf.edit 2.5.0.v200809231800 in the list.<br>
<br>
Uhm, what could be the problem here?<br>
<br>
Thanks for any hints,<br>
J&ouml;rg<br>
<br>
J&ouml;rg von Frantzius wrote:
<blockquote cite="mid:gefsq3$ogb$1@build.eclipse.org" type="cite">Hi,<br>
<br>
I downloaded the modeling package of eclipse 3.4.1 and tried to install
uml2tools 0.9.0M2 from the MDT update site. Unfortunately, update
manager (p2) it tells me:<br>
<blockquote>Cannot find a solution satisfying the following
requirements Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui.workbench/[3.5.0,4. 0.0)]. <br>
<br>
</blockquote>
Now does uml2tools really require eclipse 3.5.0 by itself, or through
one of its dependencies? I may also have just messed up my installation
by installing some available updates, though.<br>
<br>
Regards,<br>
J&ouml;rg<br>
</blockquote>
<br>
</body>
</html>
Re: uml2tools 0.9.0M2 requirements [message #475866 is a reply to message #475804] Mon, 03 November 2008 07:42 Go to previous messageGo to next message
Michael Golubev is currently offline Michael Golubev
Messages: 373
Registered: July 2009
Senior Member
Hello Jörg,

I have just re-checked that U2T 0.9.0M2 can be installed from update manager
into the following environment:

Eclipse platform 3.5M2
OCL 1.3.0M2
EMF 2.5.0M2
EMF Query 1.2.0
EMF Transaction 1.3.0M2
EMF Validation 1.3.0M2
GEF 3.5.0M2
GMF 2.2.0M2
UML2 3.0.0M2

In this configuration, P2 does not claim any problems while installing U2T
M2. Please make sure that you have all of these features in place.

As a possible workaround, you can install U2T dependencies without P2 by
downloading all dependencies in separate zips, and unpacking everything manually
into eclipse installation folder (dropins should aslo work).

Just in case, below is the list of URLs that were actually used by M2 build.

http://download.eclipse.org/eclipse/downloads/drops/S-3.5M2- 200809180100/
http://download.eclipse.org/modeling/emf/emf/downloads/drops /2.5.0/S200809231800/emf-sdo-xsd-SDK-2.5.0M2.zip
http://download.eclipse.org/modeling/mdt/uml2/downloads/drop s/3.0.0/S200809240156/mdt-uml2-SDK-3.0.0M2.zip
http://emft.eclipse.org/modeling/mdt/ocl/downloads/drops/1.3 .0/S200809241410/mdt-ocl-SDK-1.3.0M2.zip
http://download.eclipse.org/modeling/emf/query/downloads/dro ps/1.2.0/R200806091744/emf-query-SDK-1.2.0.zip
http://download.eclipse.org/modeling/emf/transaction/downloa ds/drops/1.3.0/S200809241724/emf-transaction-SDK-1.3.0M2.zip
http://download.eclipse.org/modeling/emf/validation/download s/drops/1.3.0/S200809241617/emf-validation-SDK-1.3.0M2.zip
http://download.eclipse.org/tools/gef/downloads/drops/3.5.0/ S200809240157/GEF-SDK-3.5.0M2.zip
http://emft.eclipse.org/modeling/gmf/gmf/downloads/drops/2.2 .0/S200809301125/gmf-sdk-2.2.0M2.zip

Please note that for any other build you can always find the list of actually
used binaries at the build log.
Say, log for M2 is here: http://download.eclipse.org/modeling/mdt/uml2tools/downloads /drops/0.9.0/S200810040708/buildlog.txt,

and at the very beginning of the log you can see the list of dependencies
download URL's.

Hope it helps,
Michael
Re: uml2tools 0.9.0M2 requirements [message #475870 is a reply to message #475866] Tue, 04 November 2008 11:14 Go to previous message
Eclipse User
Originally posted by: joerg.von.frantzius.artnology.com

Hi Michael,

thanks a lot for checking this. I must admit that in the meantime I
decided to go for the Topcased UML editor, since I found it to be more
easily useable. Also the Topcased SMUC plugin allows for generating Java
source code for a UML2 statemachine, which is exactly what I had been
looking for.

Sorry for stealing your time,
Jörg

Michael Golubev wrote:
> Hello Jörg,
>
> I have just re-checked that U2T 0.9.0M2 can be installed from update
> manager into the following environment:
> Eclipse platform 3.5M2 OCL 1.3.0M2 EMF 2.5.0M2 EMF Query 1.2.0 EMF
> Transaction 1.3.0M2 EMF Validation 1.3.0M2 GEF 3.5.0M2 GMF 2.2.0M2
> UML2 3.0.0M2
> In this configuration, P2 does not claim any problems while installing
> U2T M2. Please make sure that you have all of these features in place.
> As a possible workaround, you can install U2T dependencies without P2
> by downloading all dependencies in separate zips, and unpacking
> everything manually into eclipse installation folder (dropins should
> aslo work).
> Just in case, below is the list of URLs that were actually used by M2
> build.
> http://download.eclipse.org/eclipse/downloads/drops/S-3.5M2- 200809180100/
> http://download.eclipse.org/modeling/emf/emf/downloads/drops /2.5.0/S200809231800/emf-sdo-xsd-SDK-2.5.0M2.zip
>
> http://download.eclipse.org/modeling/mdt/uml2/downloads/drop s/3.0.0/S200809240156/mdt-uml2-SDK-3.0.0M2.zip
>
> http://emft.eclipse.org/modeling/mdt/ocl/downloads/drops/1.3 .0/S200809241410/mdt-ocl-SDK-1.3.0M2.zip
>
> http://download.eclipse.org/modeling/emf/query/downloads/dro ps/1.2.0/R200806091744/emf-query-SDK-1.2.0.zip
>
> http://download.eclipse.org/modeling/emf/transaction/downloa ds/drops/1.3.0/S200809241724/emf-transaction-SDK-1.3.0M2.zip
>
> http://download.eclipse.org/modeling/emf/validation/download s/drops/1.3.0/S200809241617/emf-validation-SDK-1.3.0M2.zip
>
> http://download.eclipse.org/tools/gef/downloads/drops/3.5.0/ S200809240157/GEF-SDK-3.5.0M2.zip
>
> http://emft.eclipse.org/modeling/gmf/gmf/downloads/drops/2.2 .0/S200809301125/gmf-sdk-2.2.0M2.zip
>
>
> Please note that for any other build you can always find the list of
> actually used binaries at the build log. Say, log for M2 is here:
> http://download.eclipse.org/modeling/mdt/uml2tools/downloads /drops/0.9.0/S200810040708/buildlog.txt,
>
> and at the very beginning of the log you can see the list of
> dependencies download URL's.
> Hope it helps, Michael
>
>
Re: uml2tools 0.9.0M2 requirements [message #623083 is a reply to message #475803] Fri, 31 October 2008 19:09 Go to previous message
Jörg von  Frantzius is currently offline Jörg von Frantzius
Messages: 17
Registered: July 2009
Junior Member
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Indeed <a class="moz-txt-link-freetext" href=" http://www.eclipse.org/modeling/mdt/downloads/?project=uml2t ools"> http://www.eclipse.org/modeling/mdt/downloads/?project=uml2t ools</a>
lists eclipse 3.5 as a requirement for 0.9.0.<br>
<br>
However, after downloading eclipse 3.5 and installing all requisites
from the appropriate update managers, this one remains:<br>
<blockquote>Cannot complete the request.&nbsp; See the details.<br>
Cannot find a solution satisfying the following requirements
org.eclipse.emf.edit [2.5.0.v200809231800].<br>
</blockquote>
When I look at my installed plugins, though, there is
org.eclipse.emf.edit 2.5.0.v200809231800 in the list.<br>
<br>
Uhm, what could be the problem here?<br>
<br>
Thanks for any hints,<br>
J&ouml;rg<br>
<br>
J&ouml;rg von Frantzius wrote:
<blockquote cite="mid:gefsq3$ogb$1@build.eclipse.org" type="cite">Hi,<br>
<br>
I downloaded the modeling package of eclipse 3.4.1 and tried to install
uml2tools 0.9.0M2 from the MDT update site. Unfortunately, update
manager (p2) it tells me:<br>
<blockquote>Cannot find a solution satisfying the following
requirements Match[requiredCapability:
org.eclipse.equinox.p2.iu/org.eclipse.ui.workbench/[3.5.0,4. 0.0)]. <br>
<br>
</blockquote>
Now does uml2tools really require eclipse 3.5.0 by itself, or through
one of its dependencies? I may also have just messed up my installation
by installing some available updates, though.<br>
<br>
Regards,<br>
J&ouml;rg<br>
</blockquote>
<br>
</body>
</html>
Re: uml2tools 0.9.0M2 requirements [message #623085 is a reply to message #475804] Mon, 03 November 2008 07:42 Go to previous message
Michael Golubev is currently offline Michael Golubev
Messages: 373
Registered: July 2009
Senior Member
Hello Jörg,

I have just re-checked that U2T 0.9.0M2 can be installed from update manager
into the following environment:

Eclipse platform 3.5M2
OCL 1.3.0M2
EMF 2.5.0M2
EMF Query 1.2.0
EMF Transaction 1.3.0M2
EMF Validation 1.3.0M2
GEF 3.5.0M2
GMF 2.2.0M2
UML2 3.0.0M2

In this configuration, P2 does not claim any problems while installing U2T
M2. Please make sure that you have all of these features in place.

As a possible workaround, you can install U2T dependencies without P2 by
downloading all dependencies in separate zips, and unpacking everything manually
into eclipse installation folder (dropins should aslo work).

Just in case, below is the list of URLs that were actually used by M2 build.

http://download.eclipse.org/eclipse/downloads/drops/S-3.5M2- 200809180100/
http://download.eclipse.org/modeling/emf/emf/downloads/drops /2.5.0/S200809231800/emf-sdo-xsd-SDK-2.5.0M2.zip
http://download.eclipse.org/modeling/mdt/uml2/downloads/drop s/3.0.0/S200809240156/mdt-uml2-SDK-3.0.0M2.zip
http://emft.eclipse.org/modeling/mdt/ocl/downloads/drops/1.3 .0/S200809241410/mdt-ocl-SDK-1.3.0M2.zip
http://download.eclipse.org/modeling/emf/query/downloads/dro ps/1.2.0/R200806091744/emf-query-SDK-1.2.0.zip
http://download.eclipse.org/modeling/emf/transaction/downloa ds/drops/1.3.0/S200809241724/emf-transaction-SDK-1.3.0M2.zip
http://download.eclipse.org/modeling/emf/validation/download s/drops/1.3.0/S200809241617/emf-validation-SDK-1.3.0M2.zip
http://download.eclipse.org/tools/gef/downloads/drops/3.5.0/ S200809240157/GEF-SDK-3.5.0M2.zip
http://emft.eclipse.org/modeling/gmf/gmf/downloads/drops/2.2 .0/S200809301125/gmf-sdk-2.2.0M2.zip

Please note that for any other build you can always find the list of actually
used binaries at the build log.
Say, log for M2 is here: http://download.eclipse.org/modeling/mdt/uml2tools/downloads /drops/0.9.0/S200810040708/buildlog.txt,

and at the very beginning of the log you can see the list of dependencies
download URL's.

Hope it helps,
Michael
Re: uml2tools 0.9.0M2 requirements [message #623092 is a reply to message #475866] Tue, 04 November 2008 11:14 Go to previous message
Eclipse User
Originally posted by: joerg.von.frantzius.artnology.com

Hi Michael,

thanks a lot for checking this. I must admit that in the meantime I
decided to go for the Topcased UML editor, since I found it to be more
easily useable. Also the Topcased SMUC plugin allows for generating Java
source code for a UML2 statemachine, which is exactly what I had been
looking for.

Sorry for stealing your time,
Jörg

Michael Golubev wrote:
> Hello Jörg,
>
> I have just re-checked that U2T 0.9.0M2 can be installed from update
> manager into the following environment:
> Eclipse platform 3.5M2 OCL 1.3.0M2 EMF 2.5.0M2 EMF Query 1.2.0 EMF
> Transaction 1.3.0M2 EMF Validation 1.3.0M2 GEF 3.5.0M2 GMF 2.2.0M2
> UML2 3.0.0M2
> In this configuration, P2 does not claim any problems while installing
> U2T M2. Please make sure that you have all of these features in place.
> As a possible workaround, you can install U2T dependencies without P2
> by downloading all dependencies in separate zips, and unpacking
> everything manually into eclipse installation folder (dropins should
> aslo work).
> Just in case, below is the list of URLs that were actually used by M2
> build.
> http://download.eclipse.org/eclipse/downloads/drops/S-3.5M2- 200809180100/
> http://download.eclipse.org/modeling/emf/emf/downloads/drops /2.5.0/S200809231800/emf-sdo-xsd-SDK-2.5.0M2.zip
>
> http://download.eclipse.org/modeling/mdt/uml2/downloads/drop s/3.0.0/S200809240156/mdt-uml2-SDK-3.0.0M2.zip
>
> http://emft.eclipse.org/modeling/mdt/ocl/downloads/drops/1.3 .0/S200809241410/mdt-ocl-SDK-1.3.0M2.zip
>
> http://download.eclipse.org/modeling/emf/query/downloads/dro ps/1.2.0/R200806091744/emf-query-SDK-1.2.0.zip
>
> http://download.eclipse.org/modeling/emf/transaction/downloa ds/drops/1.3.0/S200809241724/emf-transaction-SDK-1.3.0M2.zip
>
> http://download.eclipse.org/modeling/emf/validation/download s/drops/1.3.0/S200809241617/emf-validation-SDK-1.3.0M2.zip
>
> http://download.eclipse.org/tools/gef/downloads/drops/3.5.0/ S200809240157/GEF-SDK-3.5.0M2.zip
>
> http://emft.eclipse.org/modeling/gmf/gmf/downloads/drops/2.2 .0/S200809301125/gmf-sdk-2.2.0M2.zip
>
>
> Please note that for any other build you can always find the list of
> actually used binaries at the build log. Say, log for M2 is here:
> http://download.eclipse.org/modeling/mdt/uml2tools/downloads /drops/0.9.0/S200810040708/buildlog.txt,
>
> and at the very beginning of the log you can see the list of
> dependencies download URL's.
> Hope it helps, Michael
>
>
Previous Topic:Is there any tranformation tool that can translate an ecore domain model to UML2 model?
Next Topic:Hi, is it possible for the UML2 tool to ouput diagrams in a format which can be integrated into Late
Goto Forum:
  


Current Time: Sat Aug 30 04:25:56 EDT 2014

Powered by FUDForum. Page generated in 0.02381 seconds