Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 Tools » Versions
Versions [message #475314] Wed, 03 September 2008 08:51 Go to next message
Eclipse User
Originally posted by: ML1984.gmx.de

Hi.

What Eclipse version and GMF version do you use for development of
uml2tools?

Cheers,
Mark
Re: Versions [message #475315 is a reply to message #475314] Thu, 04 September 2008 11:24 Go to previous messageGo to next message
Sergey Gribovsky is currently offline Sergey Gribovsky
Messages: 42
Registered: July 2009
Member
Hi Mark,

Use following configuration for current version of source codes:
Eclipse: 3.4 release
GMF: 2.1 release + source code of GMF generation framework (all plugins from
"org.eclipse.gmf/plugins" folder without "runtime" in path) up to date for
today morning.

You can use 0.8 release configuration, but you should check out source code
by "Root_R0_8_0Maintenance" tag in such case.

Sergey.


"Mark L." <ML1984@gmx.de> wrote in message
news:g9m18q$rmf$1@build.eclipse.org...
> Hi.
>
> What Eclipse version and GMF version do you use for development of
> uml2tools?
>
> Cheers,
> Mark
Re: Versions [message #475319 is a reply to message #475315] Thu, 11 September 2008 09:59 Go to previous messageGo to next message
Eclipse User
Originally posted by: ML1984.gmx.de

Hi Sergey.

I tried to generate the GMF diagram code for UML activity diagrams on
the basis of the models in org.eclipse.uml2.diagram.def. It didn't work,
so I thought wrong version could be the problem.

I get strange errors about 'labelParsers'. It seems that you extended
the GMF generator model. Is this the reason?

How do you create diagram code?
Do you use the GMF dashboard?
(I do and at the moment I don't know how to handle all these different
..gmfgraph files.)

Any hints are greatly appreciated.

Cheers,
Mark

Sergey Gribovsky wrote:
> Hi Mark,
>
> Use following configuration for current version of source codes:
> Eclipse: 3.4 release
> GMF: 2.1 release + source code of GMF generation framework (all plugins from
> "org.eclipse.gmf/plugins" folder without "runtime" in path) up to date for
> today morning.
>
> You can use 0.8 release configuration, but you should check out source code
> by "Root_R0_8_0Maintenance" tag in such case.
>
> Sergey.
>
>
> "Mark L." <ML1984@gmx.de> wrote in message
> news:g9m18q$rmf$1@build.eclipse.org...
>> Hi.
>>
>> What Eclipse version and GMF version do you use for development of
>> uml2tools?
>>
>> Cheers,
>> Mark
>
>
Re: Versions [message #475320 is a reply to message #475319] Thu, 11 September 2008 11:40 Go to previous messageGo to next message
Sergey Gribovsky is currently offline Sergey Gribovsky
Messages: 42
Registered: July 2009
Member
I think the reason is old version of GMF. LabelParsers was implemented a
couple of weeks ago. Unfortunately we can't use 2.2M1, so we are using 2.1
release with checked out source codes generation framework up to date for
last Monday morning in development workspace. Also don't forget to check out
"org.eclipse.uml2.diagram.codegen" and
"org.eclipse.uml2.diagram.codegen.edit" plugins in development workspace as
well, and use "Generate UML2Tools Diagrams" action of context menu instead
of "Generate diagram code" in target platform.

I'm creating wiki page to describe how to regenerate UML2 tools diagrams
more in detail, but I think it will be done next week.

I'm not using GMF dashboard, I'm using default editor for GMF graph models.

Best regards,
Sergey.

"Mark L." <ML1984@gmx.de> wrote in message
news:gab86t$h7l$1@build.eclipse.org...
> Hi Sergey.
>
> I tried to generate the GMF diagram code for UML activity diagrams on the
> basis of the models in org.eclipse.uml2.diagram.def. It didn't work, so I
> thought wrong version could be the problem.
>
> I get strange errors about 'labelParsers'. It seems that you extended the
> GMF generator model. Is this the reason?
>
> How do you create diagram code?
> Do you use the GMF dashboard?
> (I do and at the moment I don't know how to handle all these different
> .gmfgraph files.)
>
> Any hints are greatly appreciated.
>
> Cheers,
> Mark
>
> Sergey Gribovsky wrote:
>> Hi Mark,
>>
>> Use following configuration for current version of source codes:
>> Eclipse: 3.4 release
>> GMF: 2.1 release + source code of GMF generation framework (all plugins
>> from "org.eclipse.gmf/plugins" folder without "runtime" in path) up to
>> date for today morning.
>>
>> You can use 0.8 release configuration, but you should check out source
>> code by "Root_R0_8_0Maintenance" tag in such case.
>>
>> Sergey.
>>
>>
>> "Mark L." <ML1984@gmx.de> wrote in message
>> news:g9m18q$rmf$1@build.eclipse.org...
>>> Hi.
>>>
>>> What Eclipse version and GMF version do you use for development of
>>> uml2tools?
>>>
>>> Cheers,
>>> Mark
>>
Re: Versions [message #475324 is a reply to message #475320] Wed, 17 September 2008 13:19 Go to previous message
Sergey Gribovsky is currently offline Sergey Gribovsky
Messages: 42
Registered: July 2009
Member
> I'm creating wiki page to describe how to regenerate UML2 tools diagrams
> more in detail, but I think it will be done next week.
Wiki page can be found here:
http://wiki.eclipse.org/MDT-UML2Tools_How_To_Regenerage_Diag rams

Sergey.
Re: Versions [message #622695 is a reply to message #475314] Thu, 04 September 2008 11:24 Go to previous message
Sergey Gribovsky is currently offline Sergey Gribovsky
Messages: 42
Registered: July 2009
Member
Hi Mark,

Use following configuration for current version of source codes:
Eclipse: 3.4 release
GMF: 2.1 release + source code of GMF generation framework (all plugins from
"org.eclipse.gmf/plugins" folder without "runtime" in path) up to date for
today morning.

You can use 0.8 release configuration, but you should check out source code
by "Root_R0_8_0Maintenance" tag in such case.

Sergey.


"Mark L." <ML1984@gmx.de> wrote in message
news:g9m18q$rmf$1@build.eclipse.org...
> Hi.
>
> What Eclipse version and GMF version do you use for development of
> uml2tools?
>
> Cheers,
> Mark
Re: Versions [message #622705 is a reply to message #475315] Thu, 11 September 2008 09:59 Go to previous message
Eclipse User
Originally posted by: ML1984.gmx.de

Hi Sergey.

I tried to generate the GMF diagram code for UML activity diagrams on
the basis of the models in org.eclipse.uml2.diagram.def. It didn't work,
so I thought wrong version could be the problem.

I get strange errors about 'labelParsers'. It seems that you extended
the GMF generator model. Is this the reason?

How do you create diagram code?
Do you use the GMF dashboard?
(I do and at the moment I don't know how to handle all these different
..gmfgraph files.)

Any hints are greatly appreciated.

Cheers,
Mark

Sergey Gribovsky wrote:
> Hi Mark,
>
> Use following configuration for current version of source codes:
> Eclipse: 3.4 release
> GMF: 2.1 release + source code of GMF generation framework (all plugins from
> "org.eclipse.gmf/plugins" folder without "runtime" in path) up to date for
> today morning.
>
> You can use 0.8 release configuration, but you should check out source code
> by "Root_R0_8_0Maintenance" tag in such case.
>
> Sergey.
>
>
> "Mark L." <ML1984@gmx.de> wrote in message
> news:g9m18q$rmf$1@build.eclipse.org...
>> Hi.
>>
>> What Eclipse version and GMF version do you use for development of
>> uml2tools?
>>
>> Cheers,
>> Mark
>
>
Re: Versions [message #622707 is a reply to message #475319] Thu, 11 September 2008 11:40 Go to previous message
Sergey Gribovsky is currently offline Sergey Gribovsky
Messages: 42
Registered: July 2009
Member
I think the reason is old version of GMF. LabelParsers was implemented a
couple of weeks ago. Unfortunately we can't use 2.2M1, so we are using 2.1
release with checked out source codes generation framework up to date for
last Monday morning in development workspace. Also don't forget to check out
"org.eclipse.uml2.diagram.codegen" and
"org.eclipse.uml2.diagram.codegen.edit" plugins in development workspace as
well, and use "Generate UML2Tools Diagrams" action of context menu instead
of "Generate diagram code" in target platform.

I'm creating wiki page to describe how to regenerate UML2 tools diagrams
more in detail, but I think it will be done next week.

I'm not using GMF dashboard, I'm using default editor for GMF graph models.

Best regards,
Sergey.

"Mark L." <ML1984@gmx.de> wrote in message
news:gab86t$h7l$1@build.eclipse.org...
> Hi Sergey.
>
> I tried to generate the GMF diagram code for UML activity diagrams on the
> basis of the models in org.eclipse.uml2.diagram.def. It didn't work, so I
> thought wrong version could be the problem.
>
> I get strange errors about 'labelParsers'. It seems that you extended the
> GMF generator model. Is this the reason?
>
> How do you create diagram code?
> Do you use the GMF dashboard?
> (I do and at the moment I don't know how to handle all these different
> .gmfgraph files.)
>
> Any hints are greatly appreciated.
>
> Cheers,
> Mark
>
> Sergey Gribovsky wrote:
>> Hi Mark,
>>
>> Use following configuration for current version of source codes:
>> Eclipse: 3.4 release
>> GMF: 2.1 release + source code of GMF generation framework (all plugins
>> from "org.eclipse.gmf/plugins" folder without "runtime" in path) up to
>> date for today morning.
>>
>> You can use 0.8 release configuration, but you should check out source
>> code by "Root_R0_8_0Maintenance" tag in such case.
>>
>> Sergey.
>>
>>
>> "Mark L." <ML1984@gmx.de> wrote in message
>> news:g9m18q$rmf$1@build.eclipse.org...
>>> Hi.
>>>
>>> What Eclipse version and GMF version do you use for development of
>>> uml2tools?
>>>
>>> Cheers,
>>> Mark
>>
Re: Versions [message #622735 is a reply to message #475320] Wed, 17 September 2008 13:19 Go to previous message
Sergey Gribovsky is currently offline Sergey Gribovsky
Messages: 42
Registered: July 2009
Member
> I'm creating wiki page to describe how to regenerate UML2 tools diagrams
> more in detail, but I think it will be done next week.
Wiki page can be found here:
http://wiki.eclipse.org/MDT-UML2Tools_How_To_Regenerage_Diag rams

Sergey.
Previous Topic:Re: Anyone still use UML 1.4? Anyone have a UML 1.4 to UML 2.1 XMI file converter?
Next Topic:New wiki page: How To Regenerage Diagrams
Goto Forum:
  


Current Time: Wed Apr 16 12:09:49 EDT 2014

Powered by FUDForum. Page generated in 0.02124 seconds