Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 Tools » Re: Problem while re-generating UML2Tools clazz diagram
Re: Problem while re-generating UML2Tools clazz diagram [message #475287] Fri, 08 August 2008 22:06 Go to next message
Kenn Hussey is currently offline Kenn HusseyFriend
Messages: 1618
Registered: July 2009
Senior Member
Niels,

This is a question for the UML2 Tools newsgroup (copied).

Kenn

"Niels Brouwers" <n.brouwers@gmail.com> wrote in message
news:a599e32901f7110148da7349d211631c$1@www.eclipse.org...
> Hi,
>
> for our project I want to make a customized version of the UML2Tools class
> diagram. To start, I want to re-generate the clazz diagram from the
> org.eclipse.uml2.diagram.def project. What I did was:
>
> - import plug-in org.eclipse.uml2.diagram.def as a source project.
> - started the UML2Tools generation by selecting the 'Generate UML2Tools
> Diagram' option from the context menu of 'classdiagram.gmfgen'
> - I have ignored the fact that the validation of the generator model did
> not pass.
>
> After a while, I get the following error:
>
> Problems while generating code
> Exception (Couldn't find operation
> 'hasConformableSemanticChildren(GenDiagram)' for GenDiagram.:in
> aspects::xpt::diagram::updater::containerBaseCanonicalMethod s on line 40
> 'hasConformableSemanticChildren(this)') while generating code
> Couldn't find operation 'hasConformableSemanticChildren(GenDiagram)' for
> GenDiagram.:in
> aspects::xpt::diagram::updater::containerBaseCanonicalMethod s on line 40
> 'hasConformableSemanticChildren(this)'
>
> Additional info:
> - I am working with Eclipse 3.4
> - Downloaded the newest UML2Tools & GMF this morning.
>
> Can someone please help me with this problem?
>
> Kind regards,
> Niels Brouwers.
>
Re: Problem while re-generating UML2Tools clazz diagram [message #475288 is a reply to message #475287] Mon, 11 August 2008 14:09 Go to previous message
Niels Brouwers is currently offline Niels BrouwersFriend
Messages: 67
Registered: July 2009
Member
Hi Kenn,

I was already confused about where I had left this message? Apparently, I
have posted it in the wrong news group, for which I apologize.

For others: the cause of the problem was already found as explained in one
of the previous posts.

Kind regards,
Niels Brouwers.



Kind regards,
Niels Brouwers.
Re: Problem while re-generating UML2Tools clazz diagram [message #622598 is a reply to message #475287] Mon, 11 August 2008 14:09 Go to previous message
Niels Brouwers is currently offline Niels BrouwersFriend
Messages: 67
Registered: July 2009
Member
Hi Kenn,

I was already confused about where I had left this message? Apparently, I
have posted it in the wrong news group, for which I apologize.

For others: the cause of the problem was already found as explained in one
of the previous posts.

Kind regards,
Niels Brouwers.



Kind regards,
Niels Brouwers.
Previous Topic:Re: Problem while re-generating UML2Tools clazz diagram
Next Topic:Interface viewmap of Component Diagram
Goto Forum:
  


Current Time: Tue Dec 23 03:46:56 GMT 2014

Powered by FUDForum. Page generated in 0.08896 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software