Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Platform - User Assistance (UA) » Print selected topic and subtopics uses server URL for pictures/CSS
Print selected topic and subtopics uses server URL for pictures/CSS [message #474978] Fri, 09 January 2009 18:55 Go to next message
Eclipse Webmaster is currently offline Eclipse WebmasterFriend
Messages: 538125
Registered: July 2009
Senior Member
I got this into the Webmaster Inbox:

I just wanted print the excellent Programmer's Guide under
http://help.eclipse.org/ganymede/index.jsp -> Contents -> Platform
Plug-in Developer Guide -> Programmer's Guide. So I pushed the
Print-Button Above the index of contents and from the drop-down menu I
selected 'Print selected topic and all subtopics'. Everything worked
fine, but there where no pictures included in the printed document. I
guess, that all the links to the pictures in the document to print are
broken.


Indeed, looking at the source, I see stuff like this:
<LINK REL="STYLESHEET"
HREF=" http://localhost:8086/help/topic/org.eclipse.platform.doc.is v/guide/../book.css"
CHARSET="ISO-8859-1" TYPE="text/css">
<TITLE>
Welcome to Eclipse
</TITLE>

<link rel="stylesheet" type="text/css"
HREF=" http://localhost:8086/help/topic/org.eclipse.platform.doc.is v/guide/../book.css">
</HEAD>


help.eclipse.org/ganymede is ProxyPassed to a localhost URL/port, and in
general all the content works, but the Print selected topic and
subtopics seems to want to use the server's URL of localhost, which
seems incorrect.

Is this a bug, or should I configure something differently?

Thanks!
Re: Print selected topic and subtopics uses server URL for pictures/CSS [message #474979 is a reply to message #474978] Fri, 09 January 2009 21:09 Go to previous messageGo to next message
Chris Goldthorpe is currently offline Chris GoldthorpeFriend
Messages: 815
Registered: July 2009
Senior Member
Hi Denis,

Yes it does indeed look like a bug.

Eclipse Webmaster (Denis Roy) wrote:
> I got this into the Webmaster Inbox:
>
> I just wanted print the excellent Programmer's Guide under
> http://help.eclipse.org/ganymede/index.jsp -> Contents -> Platform
> Plug-in Developer Guide -> Programmer's Guide. So I pushed the
> Print-Button Above the index of contents and from the drop-down menu I
> selected 'Print selected topic and all subtopics'. Everything worked
> fine, but there where no pictures included in the printed document. I
> guess, that all the links to the pictures in the document to print are
> broken.
>
>
> Indeed, looking at the source, I see stuff like this:
> <LINK REL="STYLESHEET"
> HREF=" http://localhost:8086/help/topic/org.eclipse.platform.doc.is v/guide/../book.css"
> CHARSET="ISO-8859-1" TYPE="text/css">
> <TITLE>
> Welcome to Eclipse
> </TITLE>
>
> <link rel="stylesheet" type="text/css"
> HREF=" http://localhost:8086/help/topic/org.eclipse.platform.doc.is v/guide/../book.css">
>
> </HEAD>
>
>
> help.eclipse.org/ganymede is ProxyPassed to a localhost URL/port, and in
> general all the content works, but the Print selected topic and
> subtopics seems to want to use the server's URL of localhost, which
> seems incorrect.
>
> Is this a bug, or should I configure something differently?
>
> Thanks!
Re: Print selected topic and subtopics uses server URL for pictures/CSS [message #474980 is a reply to message #474979] Sat, 10 January 2009 23:56 Go to previous messageGo to next message
Lee Anne Kowalski is currently offline Lee Anne KowalskiFriend
Messages: 54
Registered: July 2009
Member
Hi Chris,

Is it the same symptom as in this Bugzilla entry?:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=254996

Best regards,
Lee Anne

Chris Goldthorpe wrote:
> Hi Denis,
>
> Yes it does indeed look like a bug.
>
> Eclipse Webmaster (Denis Roy) wrote:
>> I got this into the Webmaster Inbox:
>>
>> I just wanted print the excellent Programmer's Guide under
>> http://help.eclipse.org/ganymede/index.jsp -> Contents -> Platform
>> Plug-in Developer Guide -> Programmer's Guide. So I pushed the
>> Print-Button Above the index of contents and from the drop-down menu I
>> selected 'Print selected topic and all subtopics'. Everything worked
>> fine, but there where no pictures included in the printed document. I
>> guess, that all the links to the pictures in the document to print are
>> broken.
>>
>>
>> Indeed, looking at the source, I see stuff like this:
>> <LINK REL="STYLESHEET"
>> HREF=" http://localhost:8086/help/topic/org.eclipse.platform.doc.is v/guide/../book.css"
>> CHARSET="ISO-8859-1" TYPE="text/css">
>> <TITLE>
>> Welcome to Eclipse
>> </TITLE>
>>
>> <link rel="stylesheet" type="text/css"
>> HREF=" http://localhost:8086/help/topic/org.eclipse.platform.doc.is v/guide/../book.css">
>>
>> </HEAD>
>>
>>
>> help.eclipse.org/ganymede is ProxyPassed to a localhost URL/port, and
>> in general all the content works, but the Print selected topic and
>> subtopics seems to want to use the server's URL of localhost, which
>> seems incorrect.
>>
>> Is this a bug, or should I configure something differently?
>>
>> Thanks!
Re: Print selected topic and subtopics uses server URL for pictures/CSS [message #474982 is a reply to message #474980] Mon, 12 January 2009 16:49 Go to previous messageGo to next message
Chris Goldthorpe is currently offline Chris GoldthorpeFriend
Messages: 815
Registered: July 2009
Senior Member
It may well be but I won't know until it gets investigated.

Lee Anne Kowalski wrote:
> Hi Chris,
>
> Is it the same symptom as in this Bugzilla entry?:
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=254996
>
> Best regards,
> Lee Anne
>
> Chris Goldthorpe wrote:
>> Hi Denis,
>>
>> Yes it does indeed look like a bug.
>>
>> Eclipse Webmaster (Denis Roy) wrote:
>>> I got this into the Webmaster Inbox:
>>>
>>> I just wanted print the excellent Programmer's Guide under
>>> http://help.eclipse.org/ganymede/index.jsp -> Contents -> Platform
>>> Plug-in Developer Guide -> Programmer's Guide. So I pushed the
>>> Print-Button Above the index of contents and from the drop-down menu I
>>> selected 'Print selected topic and all subtopics'. Everything worked
>>> fine, but there where no pictures included in the printed document. I
>>> guess, that all the links to the pictures in the document to print are
>>> broken.
>>>
>>>
>>> Indeed, looking at the source, I see stuff like this:
>>> <LINK REL="STYLESHEET"
>>> HREF=" http://localhost:8086/help/topic/org.eclipse.platform.doc.is v/guide/../book.css"
>>> CHARSET="ISO-8859-1" TYPE="text/css">
>>> <TITLE>
>>> Welcome to Eclipse
>>> </TITLE>
>>>
>>> <link rel="stylesheet" type="text/css"
>>> HREF=" http://localhost:8086/help/topic/org.eclipse.platform.doc.is v/guide/../book.css">
>>>
>>> </HEAD>
>>>
>>>
>>> help.eclipse.org/ganymede is ProxyPassed to a localhost URL/port, and
>>> in general all the content works, but the Print selected topic and
>>> subtopics seems to want to use the server's URL of localhost, which
>>> seems incorrect.
>>>
>>> Is this a bug, or should I configure something differently?
>>>
>>> Thanks!
Re: Print selected topic and subtopics uses server URL for pictures/CSS [message #475064 is a reply to message #474980] Tue, 13 January 2009 14:24 Go to previous message
Eclipse Webmaster is currently offline Eclipse WebmasterFriend
Messages: 538125
Registered: July 2009
Senior Member
Lee Anne Kowalski wrote:
> Hi Chris,
>
> Is it the same symptom as in this Bugzilla entry?:
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=254996

Yes, that's exactly it. I've cc'd myself. Thanks.

Denis



>
> Best regards,
> Lee Anne
>
> Chris Goldthorpe wrote:
>> Hi Denis,
>>
>> Yes it does indeed look like a bug.
>>
>> Eclipse Webmaster (Denis Roy) wrote:
>>> I got this into the Webmaster Inbox:
>>>
>>> I just wanted print the excellent Programmer's Guide under
>>> http://help.eclipse.org/ganymede/index.jsp -> Contents -> Platform
>>> Plug-in Developer Guide -> Programmer's Guide. So I pushed the
>>> Print-Button Above the index of contents and from the drop-down menu I
>>> selected 'Print selected topic and all subtopics'. Everything worked
>>> fine, but there where no pictures included in the printed document. I
>>> guess, that all the links to the pictures in the document to print are
>>> broken.
>>>
>>>
>>> Indeed, looking at the source, I see stuff like this:
>>> <LINK REL="STYLESHEET"
>>> HREF=" http://localhost:8086/help/topic/org.eclipse.platform.doc.is v/guide/../book.css"
>>> CHARSET="ISO-8859-1" TYPE="text/css">
>>> <TITLE>
>>> Welcome to Eclipse
>>> </TITLE>
>>>
>>> <link rel="stylesheet" type="text/css"
>>> HREF=" http://localhost:8086/help/topic/org.eclipse.platform.doc.is v/guide/../book.css">
>>>
>>> </HEAD>
>>>
>>>
>>> help.eclipse.org/ganymede is ProxyPassed to a localhost URL/port, and
>>> in general all the content works, but the Print selected topic and
>>> subtopics seems to want to use the server's URL of localhost, which
>>> seems incorrect.
>>>
>>> Is this a bug, or should I configure something differently?
>>>
>>> Thanks!
Re: Print selected topic and subtopics uses server URL for pictures/CSS [message #622769 is a reply to message #474978] Fri, 09 January 2009 21:09 Go to previous message
Chris Goldthorpe is currently offline Chris GoldthorpeFriend
Messages: 815
Registered: July 2009
Senior Member
Hi Denis,

Yes it does indeed look like a bug.

Eclipse Webmaster (Denis Roy) wrote:
> I got this into the Webmaster Inbox:
>
> I just wanted print the excellent Programmer's Guide under
> http://help.eclipse.org/ganymede/index.jsp -> Contents -> Platform
> Plug-in Developer Guide -> Programmer's Guide. So I pushed the
> Print-Button Above the index of contents and from the drop-down menu I
> selected 'Print selected topic and all subtopics'. Everything worked
> fine, but there where no pictures included in the printed document. I
> guess, that all the links to the pictures in the document to print are
> broken.
>
>
> Indeed, looking at the source, I see stuff like this:
> <LINK REL="STYLESHEET"
> HREF=" http://localhost:8086/help/topic/org.eclipse.platform.doc.is v/guide/../book.css"
> CHARSET="ISO-8859-1" TYPE="text/css">
> <TITLE>
> Welcome to Eclipse
> </TITLE>
>
> <link rel="stylesheet" type="text/css"
> HREF=" http://localhost:8086/help/topic/org.eclipse.platform.doc.is v/guide/../book.css">
>
> </HEAD>
>
>
> help.eclipse.org/ganymede is ProxyPassed to a localhost URL/port, and in
> general all the content works, but the Print selected topic and
> subtopics seems to want to use the server's URL of localhost, which
> seems incorrect.
>
> Is this a bug, or should I configure something differently?
>
> Thanks!
Re: Print selected topic and subtopics uses server URL for pictures/CSS [message #622770 is a reply to message #474979] Sat, 10 January 2009 23:56 Go to previous message
Lee Anne Kowalski is currently offline Lee Anne KowalskiFriend
Messages: 54
Registered: July 2009
Member
Hi Chris,

Is it the same symptom as in this Bugzilla entry?:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=254996

Best regards,
Lee Anne

Chris Goldthorpe wrote:
> Hi Denis,
>
> Yes it does indeed look like a bug.
>
> Eclipse Webmaster (Denis Roy) wrote:
>> I got this into the Webmaster Inbox:
>>
>> I just wanted print the excellent Programmer's Guide under
>> http://help.eclipse.org/ganymede/index.jsp -> Contents -> Platform
>> Plug-in Developer Guide -> Programmer's Guide. So I pushed the
>> Print-Button Above the index of contents and from the drop-down menu I
>> selected 'Print selected topic and all subtopics'. Everything worked
>> fine, but there where no pictures included in the printed document. I
>> guess, that all the links to the pictures in the document to print are
>> broken.
>>
>>
>> Indeed, looking at the source, I see stuff like this:
>> <LINK REL="STYLESHEET"
>> HREF=" http://localhost:8086/help/topic/org.eclipse.platform.doc.is v/guide/../book.css"
>> CHARSET="ISO-8859-1" TYPE="text/css">
>> <TITLE>
>> Welcome to Eclipse
>> </TITLE>
>>
>> <link rel="stylesheet" type="text/css"
>> HREF=" http://localhost:8086/help/topic/org.eclipse.platform.doc.is v/guide/../book.css">
>>
>> </HEAD>
>>
>>
>> help.eclipse.org/ganymede is ProxyPassed to a localhost URL/port, and
>> in general all the content works, but the Print selected topic and
>> subtopics seems to want to use the server's URL of localhost, which
>> seems incorrect.
>>
>> Is this a bug, or should I configure something differently?
>>
>> Thanks!
Re: Print selected topic and subtopics uses server URL for pictures/CSS [message #622772 is a reply to message #474980] Mon, 12 January 2009 16:49 Go to previous message
Chris Goldthorpe is currently offline Chris GoldthorpeFriend
Messages: 815
Registered: July 2009
Senior Member
It may well be but I won't know until it gets investigated.

Lee Anne Kowalski wrote:
> Hi Chris,
>
> Is it the same symptom as in this Bugzilla entry?:
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=254996
>
> Best regards,
> Lee Anne
>
> Chris Goldthorpe wrote:
>> Hi Denis,
>>
>> Yes it does indeed look like a bug.
>>
>> Eclipse Webmaster (Denis Roy) wrote:
>>> I got this into the Webmaster Inbox:
>>>
>>> I just wanted print the excellent Programmer's Guide under
>>> http://help.eclipse.org/ganymede/index.jsp -> Contents -> Platform
>>> Plug-in Developer Guide -> Programmer's Guide. So I pushed the
>>> Print-Button Above the index of contents and from the drop-down menu I
>>> selected 'Print selected topic and all subtopics'. Everything worked
>>> fine, but there where no pictures included in the printed document. I
>>> guess, that all the links to the pictures in the document to print are
>>> broken.
>>>
>>>
>>> Indeed, looking at the source, I see stuff like this:
>>> <LINK REL="STYLESHEET"
>>> HREF=" http://localhost:8086/help/topic/org.eclipse.platform.doc.is v/guide/../book.css"
>>> CHARSET="ISO-8859-1" TYPE="text/css">
>>> <TITLE>
>>> Welcome to Eclipse
>>> </TITLE>
>>>
>>> <link rel="stylesheet" type="text/css"
>>> HREF=" http://localhost:8086/help/topic/org.eclipse.platform.doc.is v/guide/../book.css">
>>>
>>> </HEAD>
>>>
>>>
>>> help.eclipse.org/ganymede is ProxyPassed to a localhost URL/port, and
>>> in general all the content works, but the Print selected topic and
>>> subtopics seems to want to use the server's URL of localhost, which
>>> seems incorrect.
>>>
>>> Is this a bug, or should I configure something differently?
>>>
>>> Thanks!
Re: Print selected topic and subtopics uses server URL for pictures/CSS [message #622794 is a reply to message #474980] Tue, 13 January 2009 14:24 Go to previous message
Eclipse Webmaster is currently offline Eclipse WebmasterFriend
Messages: 538125
Registered: July 2009
Senior Member
Lee Anne Kowalski wrote:
> Hi Chris,
>
> Is it the same symptom as in this Bugzilla entry?:
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=254996

Yes, that's exactly it. I've cc'd myself. Thanks.

Denis



>
> Best regards,
> Lee Anne
>
> Chris Goldthorpe wrote:
>> Hi Denis,
>>
>> Yes it does indeed look like a bug.
>>
>> Eclipse Webmaster (Denis Roy) wrote:
>>> I got this into the Webmaster Inbox:
>>>
>>> I just wanted print the excellent Programmer's Guide under
>>> http://help.eclipse.org/ganymede/index.jsp -> Contents -> Platform
>>> Plug-in Developer Guide -> Programmer's Guide. So I pushed the
>>> Print-Button Above the index of contents and from the drop-down menu I
>>> selected 'Print selected topic and all subtopics'. Everything worked
>>> fine, but there where no pictures included in the printed document. I
>>> guess, that all the links to the pictures in the document to print are
>>> broken.
>>>
>>>
>>> Indeed, looking at the source, I see stuff like this:
>>> <LINK REL="STYLESHEET"
>>> HREF=" http://localhost:8086/help/topic/org.eclipse.platform.doc.is v/guide/../book.css"
>>> CHARSET="ISO-8859-1" TYPE="text/css">
>>> <TITLE>
>>> Welcome to Eclipse
>>> </TITLE>
>>>
>>> <link rel="stylesheet" type="text/css"
>>> HREF=" http://localhost:8086/help/topic/org.eclipse.platform.doc.is v/guide/../book.css">
>>>
>>> </HEAD>
>>>
>>>
>>> help.eclipse.org/ganymede is ProxyPassed to a localhost URL/port, and
>>> in general all the content works, but the Print selected topic and
>>> subtopics seems to want to use the server's URL of localhost, which
>>> seems incorrect.
>>>
>>> Is this a bug, or should I configure something differently?
>>>
>>> Thanks!
Previous Topic:Ganymede infocenter deployment with Apache HTTPD and Tomcat
Next Topic:look and feel of eclipse & RCP HELP under linux gtk
Goto Forum:
  


Current Time: Mon Dec 22 20:07:09 GMT 2014

Powered by FUDForum. Page generated in 0.02548 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software