Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 » Migrating own Metamodel based on UML2.0.3
Migrating own Metamodel based on UML2.0.3 [message #474881] Mon, 06 August 2007 14:01 Go to next message
Andreas Morf is currently offline Andreas Morf
Messages: 14
Registered: July 2009
Junior Member
Hi all
Recently I developed a metamodel for a language which imported the
UML.merged.uml (V2.0.3) whith RSA. The exported .uml doesn't work anymore
with the genmodel from UML2.1
How can I handle this problem? Especially the RSA is not able to read the
new 2.1.0 UML.merged.uml. Is there a way to do this? How is the
UML.merged.uml in the UML2.1.x generated?

Thanks for any help
Andreas
Re: Migrating own Metamodel based on UML2.0.3 [message #474987 is a reply to message #474881] Tue, 07 August 2007 19:24 Go to previous messageGo to next message
james bruck is currently offline james bruck
Messages: 1724
Registered: July 2009
Senior Member
Hi Andreas,

- For some background info on the metamodel changes you might want to have a
look at
http://www.eclipse.org/modeling/mdt/uml2/docs/guides/UML2_2. 1_Migration_Guide/guide.html

- The latest UML2 2.0.4 can open up the UML2 2.1 version as well as the
older format so you might want to try to move to the 2.0.4 .

- Let me know what version of RSA you are using and I should be able to give
you instructions on how to "teach" RSA to open up the model you have.

- By the way, UML.merged.uml is generated by doing a package merge on
UML.uml but I think taking this approach would be problematic.


- James.


"Andreas Morf" <andreas_morf@bluewin.ch> wrote in message
news:f979jd$2ae$1@build.eclipse.org...
> Hi all
> Recently I developed a metamodel for a language which imported the
> UML.merged.uml (V2.0.3) whith RSA. The exported .uml doesn't work anymore
> with the genmodel from UML2.1
> How can I handle this problem? Especially the RSA is not able to read the
> new 2.1.0 UML.merged.uml. Is there a way to do this? How is the
> UML.merged.uml in the UML2.1.x generated?
>
> Thanks for any help
> Andreas
>
>
Re: Migrating own Metamodel based on UML2.0.3 [message #474992 is a reply to message #474987] Wed, 08 August 2007 12:11 Go to previous messageGo to next message
Andreas Morf is currently offline Andreas Morf
Messages: 14
Registered: July 2009
Junior Member
Hi James

Thanks for your answer!
A week ago, I updated my RSA to 7.0.3 - My workflow in the project is to
design my metamodel with RSA and export it as .uml continuing with Eclipse
genmodel.
Therefore I need to load the new (nsURI as 2.1.0) UML.merged.uml to RSA to
update my metamodel.
Can you provide me with instructions for RSA to load the model - I already
tried to load UML2 2.0.4 with the configuration manager but didn't work...

Andreas

"James Bruck" <jbruck@ca.ibm.com> wrote in message
news:f9agtp$17a$2@build.eclipse.org...
> Hi Andreas,
>
> - For some background info on the metamodel changes you might want to have
> a
> look at
> http://www.eclipse.org/modeling/mdt/uml2/docs/guides/UML2_2. 1_Migration_Guide/guide.html
>
> - The latest UML2 2.0.4 can open up the UML2 2.1 version as well as the
> older format so you might want to try to move to the 2.0.4 .
>
> - Let me know what version of RSA you are using and I should be able to
> give
> you instructions on how to "teach" RSA to open up the model you have.
>
> - By the way, UML.merged.uml is generated by doing a package merge on
> UML.uml but I think taking this approach would be problematic.
>
>
> - James.
>
>
> "Andreas Morf" <andreas_morf@bluewin.ch> wrote in message
> news:f979jd$2ae$1@build.eclipse.org...
>> Hi all
>> Recently I developed a metamodel for a language which imported the
>> UML.merged.uml (V2.0.3) whith RSA. The exported .uml doesn't work anymore
>> with the genmodel from UML2.1
>> How can I handle this problem? Especially the RSA is not able to read the
>> new 2.1.0 UML.merged.uml. Is there a way to do this? How is the
>> UML.merged.uml in the UML2.1.x generated?
>>
>> Thanks for any help
>> Andreas
>>
>>
>
>
Re: Migrating own Metamodel based on UML2.0.3 [message #475002 is a reply to message #474992] Thu, 09 August 2007 19:25 Go to previous message
james bruck is currently offline james bruck
Messages: 1724
Registered: July 2009
Senior Member
Hi Andreas,

Replacing plugins in RSA is a bit tricky. I'll send you some instructions
directly to your email :)

- James.

"Andreas Morf" <andreas_morf@bluewin.ch> wrote in message
news:f9cbtu$2p6$1@build.eclipse.org...
> Hi James
>
> Thanks for your answer!
> A week ago, I updated my RSA to 7.0.3 - My workflow in the project is to
> design my metamodel with RSA and export it as .uml continuing with Eclipse
> genmodel.
> Therefore I need to load the new (nsURI as 2.1.0) UML.merged.uml to RSA to
> update my metamodel.
> Can you provide me with instructions for RSA to load the model - I already
> tried to load UML2 2.0.4 with the configuration manager but didn't work...
>
> Andreas
>
> "James Bruck" <jbruck@ca.ibm.com> wrote in message
> news:f9agtp$17a$2@build.eclipse.org...
> > Hi Andreas,
> >
> > - For some background info on the metamodel changes you might want to
have
> > a
> > look at
> >
http://www.eclipse.org/modeling/mdt/uml2/docs/guides/UML2_2. 1_Migration_Guide/guide.html
> >
> > - The latest UML2 2.0.4 can open up the UML2 2.1 version as well as the
> > older format so you might want to try to move to the 2.0.4 .
> >
> > - Let me know what version of RSA you are using and I should be able to
> > give
> > you instructions on how to "teach" RSA to open up the model you have.
> >
> > - By the way, UML.merged.uml is generated by doing a package merge on
> > UML.uml but I think taking this approach would be problematic.
> >
> >
> > - James.
> >
> >
> > "Andreas Morf" <andreas_morf@bluewin.ch> wrote in message
> > news:f979jd$2ae$1@build.eclipse.org...
> >> Hi all
> >> Recently I developed a metamodel for a language which imported the
> >> UML.merged.uml (V2.0.3) whith RSA. The exported .uml doesn't work
anymore
> >> with the genmodel from UML2.1
> >> How can I handle this problem? Especially the RSA is not able to read
the
> >> new 2.1.0 UML.merged.uml. Is there a way to do this? How is the
> >> UML.merged.uml in the UML2.1.x generated?
> >>
> >> Thanks for any help
> >> Andreas
> >>
> >>
> >
> >
>
>
Re: Migrating own Metamodel based on UML2.0.3 [message #624262 is a reply to message #474881] Tue, 07 August 2007 19:24 Go to previous message
james bruck is currently offline james bruck
Messages: 1724
Registered: July 2009
Senior Member
Hi Andreas,

- For some background info on the metamodel changes you might want to have a
look at
http://www.eclipse.org/modeling/mdt/uml2/docs/guides/UML2_2. 1_Migration_Guide/guide.html

- The latest UML2 2.0.4 can open up the UML2 2.1 version as well as the
older format so you might want to try to move to the 2.0.4 .

- Let me know what version of RSA you are using and I should be able to give
you instructions on how to "teach" RSA to open up the model you have.

- By the way, UML.merged.uml is generated by doing a package merge on
UML.uml but I think taking this approach would be problematic.


- James.


"Andreas Morf" <andreas_morf@bluewin.ch> wrote in message
news:f979jd$2ae$1@build.eclipse.org...
> Hi all
> Recently I developed a metamodel for a language which imported the
> UML.merged.uml (V2.0.3) whith RSA. The exported .uml doesn't work anymore
> with the genmodel from UML2.1
> How can I handle this problem? Especially the RSA is not able to read the
> new 2.1.0 UML.merged.uml. Is there a way to do this? How is the
> UML.merged.uml in the UML2.1.x generated?
>
> Thanks for any help
> Andreas
>
>
Re: Migrating own Metamodel based on UML2.0.3 [message #624362 is a reply to message #474987] Wed, 08 August 2007 12:11 Go to previous message
Andreas Morf is currently offline Andreas Morf
Messages: 14
Registered: July 2009
Junior Member
Hi James

Thanks for your answer!
A week ago, I updated my RSA to 7.0.3 - My workflow in the project is to
design my metamodel with RSA and export it as .uml continuing with Eclipse
genmodel.
Therefore I need to load the new (nsURI as 2.1.0) UML.merged.uml to RSA to
update my metamodel.
Can you provide me with instructions for RSA to load the model - I already
tried to load UML2 2.0.4 with the configuration manager but didn't work...

Andreas

"James Bruck" <jbruck@ca.ibm.com> wrote in message
news:f9agtp$17a$2@build.eclipse.org...
> Hi Andreas,
>
> - For some background info on the metamodel changes you might want to have
> a
> look at
> http://www.eclipse.org/modeling/mdt/uml2/docs/guides/UML2_2. 1_Migration_Guide/guide.html
>
> - The latest UML2 2.0.4 can open up the UML2 2.1 version as well as the
> older format so you might want to try to move to the 2.0.4 .
>
> - Let me know what version of RSA you are using and I should be able to
> give
> you instructions on how to "teach" RSA to open up the model you have.
>
> - By the way, UML.merged.uml is generated by doing a package merge on
> UML.uml but I think taking this approach would be problematic.
>
>
> - James.
>
>
> "Andreas Morf" <andreas_morf@bluewin.ch> wrote in message
> news:f979jd$2ae$1@build.eclipse.org...
>> Hi all
>> Recently I developed a metamodel for a language which imported the
>> UML.merged.uml (V2.0.3) whith RSA. The exported .uml doesn't work anymore
>> with the genmodel from UML2.1
>> How can I handle this problem? Especially the RSA is not able to read the
>> new 2.1.0 UML.merged.uml. Is there a way to do this? How is the
>> UML.merged.uml in the UML2.1.x generated?
>>
>> Thanks for any help
>> Andreas
>>
>>
>
>
Re: Migrating own Metamodel based on UML2.0.3 [message #624382 is a reply to message #474992] Thu, 09 August 2007 19:25 Go to previous message
james bruck is currently offline james bruck
Messages: 1724
Registered: July 2009
Senior Member
Hi Andreas,

Replacing plugins in RSA is a bit tricky. I'll send you some instructions
directly to your email :)

- James.

"Andreas Morf" <andreas_morf@bluewin.ch> wrote in message
news:f9cbtu$2p6$1@build.eclipse.org...
> Hi James
>
> Thanks for your answer!
> A week ago, I updated my RSA to 7.0.3 - My workflow in the project is to
> design my metamodel with RSA and export it as .uml continuing with Eclipse
> genmodel.
> Therefore I need to load the new (nsURI as 2.1.0) UML.merged.uml to RSA to
> update my metamodel.
> Can you provide me with instructions for RSA to load the model - I already
> tried to load UML2 2.0.4 with the configuration manager but didn't work...
>
> Andreas
>
> "James Bruck" <jbruck@ca.ibm.com> wrote in message
> news:f9agtp$17a$2@build.eclipse.org...
> > Hi Andreas,
> >
> > - For some background info on the metamodel changes you might want to
have
> > a
> > look at
> >
http://www.eclipse.org/modeling/mdt/uml2/docs/guides/UML2_2. 1_Migration_Guide/guide.html
> >
> > - The latest UML2 2.0.4 can open up the UML2 2.1 version as well as the
> > older format so you might want to try to move to the 2.0.4 .
> >
> > - Let me know what version of RSA you are using and I should be able to
> > give
> > you instructions on how to "teach" RSA to open up the model you have.
> >
> > - By the way, UML.merged.uml is generated by doing a package merge on
> > UML.uml but I think taking this approach would be problematic.
> >
> >
> > - James.
> >
> >
> > "Andreas Morf" <andreas_morf@bluewin.ch> wrote in message
> > news:f979jd$2ae$1@build.eclipse.org...
> >> Hi all
> >> Recently I developed a metamodel for a language which imported the
> >> UML.merged.uml (V2.0.3) whith RSA. The exported .uml doesn't work
anymore
> >> with the genmodel from UML2.1
> >> How can I handle this problem? Especially the RSA is not able to read
the
> >> new 2.1.0 UML.merged.uml. Is there a way to do this? How is the
> >> UML.merged.uml in the UML2.1.x generated?
> >>
> >> Thanks for any help
> >> Andreas
> >>
> >>
> >
> >
>
>
Previous Topic:wsdl2uml
Next Topic:RE: Activity Diagram
Goto Forum:
  


Current Time: Thu Oct 02 02:37:04 GMT 2014

Powered by FUDForum. Page generated in 0.09677 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software