Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Platform - User Assistance (UA) » Error searching in remote infocenter
Error searching in remote infocenter [message #474764] Tue, 04 November 2008 07:35 Go to next message
Ch. Hager is currently offline Ch. Hager
Messages: 15
Registered: July 2009
Junior Member
Hello,

I have the following problem regarding our infocenter. We have an
infocenter serving all our help content. Now when I search something from
one of our client applications I get the follwing error.

E/A-Ausnahmebedingung während der Suche
Server returned HTTP response code: 500 for URL:
http://localhost:8081/help/search?searchWord=test&locale =de_DE

Does someone have any idea of where this may come from? Or is it maybe not
possible to search remote infocenters? Did I forget anything maybe when I
set up the Infocenter?

Thanks in advance for any help and hints.

Christian Hager
Re: Error searching in remote infocenter [message #474765 is a reply to message #474764] Tue, 04 November 2008 08:01 Go to previous messageGo to next message
Ch. Hager is currently offline Ch. Hager
Messages: 15
Registered: July 2009
Junior Member
I just found the corresponding error which is logged by the infocenter
instance.

04.11.2008 13:40:18 org.mortbay.jetty.servlet.ServletHandler handle
SCHWERWIEGEND: /help/search?searchWord=test&locale=de_DE:
java.lang.NullPointerException
at
org.eclipse.help.internal.util.URLCoder.urlDecode(URLCoder.j ava:45)
at org.eclipse.help.internal.util.URLCoder.decode(URLCoder.java :28)
at
org.eclipse.help.internal.webapp.servlet.SearchServlet.doGet (SearchSe
rvlet.java:58)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:596)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
at
org.eclipse.equinox.http.registry.internal.ServletManager$Se rvletWrap
per.service(ServletManager.java:180)
at
org.eclipse.equinox.http.servlet.internal.ServletRegistratio n.handleR
equest(ServletRegistration.java:90)
at
org.eclipse.equinox.http.servlet.internal.ProxyServlet.proce ssAlias(P
roxyServlet.java:111)
at
org.eclipse.equinox.http.servlet.internal.ProxyServlet.servi ce(ProxyS
ervlet.java:59)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
at
org.eclipse.equinox.http.jetty.internal.HttpServerManager$In ternalHtt
pServiceServlet.service(HttpServerManager.java:288)
at
org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder .java:428
)
at
org.mortbay.jetty.servlet.ServletHandler.dispatch(ServletHan dler.java
:677)
at
org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandl er.java:5
68)
at org.mortbay.http.HttpContext.handle(HttpContext.java:1530)
at org.mortbay.http.HttpContext.handle(HttpContext.java:1482)
at org.mortbay.http.HttpServer.service(HttpServer.java:909)
at org.mortbay.http.HttpConnection.service(HttpConnection.java: 820)
at
org.mortbay.http.HttpConnection.handleNext(HttpConnection.ja va:986)
at org.mortbay.http.HttpConnection.handle(HttpConnection.java:8 37)
at
org.mortbay.http.SocketListener.handleConnection(SocketListe ner.java:
245)
at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:3 57)
at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:5 34)

Maybe this helps.
Re: Error searching in remote infocenter [message #474770 is a reply to message #474765] Tue, 11 November 2008 19:44 Go to previous messageGo to next message
Chris Goldthorpe is currently offline Chris Goldthorpe
Messages: 815
Registered: July 2009
Senior Member
If you are sure that the error message corresponds to the search request
then file a bug in Bugzilla, this should not be generating a null
pointer check.
Re: Error searching in remote infocenter [message #474774 is a reply to message #474764] Wed, 12 November 2008 03:19 Go to previous message
Ch. Hager is currently offline Ch. Hager
Messages: 15
Registered: July 2009
Junior Member
I'm not really sure. I just tried to add the eclipse 3.3 infocenter
(http://help.eclipse.org/help33/) to the eclipse help view. When try to
search something after doing this I get this error (the same error I
currently get with my application):

I/O exception during search
Server returned HTTP response code: 500 for URL:
http://help.eclipse.org/help33/search?searchWord=Test&lo cale=de_DE


Am I doing something wrong or is this really a bug?
Re: Error searching in remote infocenter [message #621800 is a reply to message #474764] Tue, 04 November 2008 08:01 Go to previous message
Ch. Hager is currently offline Ch. Hager
Messages: 15
Registered: July 2009
Junior Member
I just found the corresponding error which is logged by the infocenter
instance.

04.11.2008 13:40:18 org.mortbay.jetty.servlet.ServletHandler handle
SCHWERWIEGEND: /help/search?searchWord=test&locale=de_DE:
java.lang.NullPointerException
at
org.eclipse.help.internal.util.URLCoder.urlDecode(URLCoder.j ava:45)
at org.eclipse.help.internal.util.URLCoder.decode(URLCoder.java :28)
at
org.eclipse.help.internal.webapp.servlet.SearchServlet.doGet (SearchSe
rvlet.java:58)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:596)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
at
org.eclipse.equinox.http.registry.internal.ServletManager$Se rvletWrap
per.service(ServletManager.java:180)
at
org.eclipse.equinox.http.servlet.internal.ServletRegistratio n.handleR
equest(ServletRegistration.java:90)
at
org.eclipse.equinox.http.servlet.internal.ProxyServlet.proce ssAlias(P
roxyServlet.java:111)
at
org.eclipse.equinox.http.servlet.internal.ProxyServlet.servi ce(ProxyS
ervlet.java:59)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
at
org.eclipse.equinox.http.jetty.internal.HttpServerManager$In ternalHtt
pServiceServlet.service(HttpServerManager.java:288)
at
org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder .java:428
)
at
org.mortbay.jetty.servlet.ServletHandler.dispatch(ServletHan dler.java
:677)
at
org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandl er.java:5
68)
at org.mortbay.http.HttpContext.handle(HttpContext.java:1530)
at org.mortbay.http.HttpContext.handle(HttpContext.java:1482)
at org.mortbay.http.HttpServer.service(HttpServer.java:909)
at org.mortbay.http.HttpConnection.service(HttpConnection.java: 820)
at
org.mortbay.http.HttpConnection.handleNext(HttpConnection.ja va:986)
at org.mortbay.http.HttpConnection.handle(HttpConnection.java:8 37)
at
org.mortbay.http.SocketListener.handleConnection(SocketListe ner.java:
245)
at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:3 57)
at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:5 34)

Maybe this helps.
Re: Error searching in remote infocenter [message #621807 is a reply to message #474765] Tue, 11 November 2008 19:44 Go to previous message
Chris Goldthorpe is currently offline Chris Goldthorpe
Messages: 815
Registered: July 2009
Senior Member
If you are sure that the error message corresponds to the search request
then file a bug in Bugzilla, this should not be generating a null
pointer check.
Re: Error searching in remote infocenter [message #621811 is a reply to message #474764] Wed, 12 November 2008 03:19 Go to previous message
Ch. Hager is currently offline Ch. Hager
Messages: 15
Registered: July 2009
Junior Member
I'm not really sure. I just tried to add the eclipse 3.3 infocenter
(http://help.eclipse.org/help33/) to the eclipse help view. When try to
search something after doing this I get this error (the same error I
currently get with my application):

I/O exception during search
Server returned HTTP response code: 500 for URL:
http://help.eclipse.org/help33/search?searchWord=Test&lo cale=de_DE


Am I doing something wrong or is this really a bug?
Previous Topic:Infocenter: Bookmarks only for IE?
Next Topic:Glitch in CSS usage
Goto Forum:
  


Current Time: Thu Apr 17 03:51:02 EDT 2014

Powered by FUDForum. Page generated in 0.02876 seconds