Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Platform - User Assistance (UA) » Standalone Help startup time, precompiled JSPs?
Standalone Help startup time, precompiled JSPs? [message #474718] Thu, 30 October 2008 01:30
Kyle Schwamkrug is currently offline Kyle SchwamkrugFriend
Messages: 2
Registered: July 2009
Junior Member
Hey all,

We've been looking into using a standalone Eclipse Help system with some
of our products. One of our roadblocks is the startup time. A "cold"
start, where the server is not already running, takes a really long time
on some of our older machines, and a fairly long time even on newer
machines. The standalone help viewer appears relatively quickly, but it
can take over 30 seconds for the UI to be completely filled in and ready
for use.

I have a theory that this is related to compiling the JSPs. Every time I
start Eclipse Help, a bunch of .java and .class files, one for each JSP in
org.eclipse.help.webapp, get written to a subdirectory within
configuration\org.eclipse.osgi\bundles\48\data\jettywork. When I stop the
help system and server, those files are deleted.

Is there a way to make Eclipse not do that? It looks like
org.eclipse.help.webapp includes all the compiled JSPs within
org\eclipse\help\internal\webapp\jsp.

Besides that, is there anything else I can do to improve the startup time?

Thanks,
Kyle
Previous Topic:Standalone Help startup time, precompiled JSPs?
Next Topic:org.dita.dost.contentProducer prevents plugin from loading
Goto Forum:
  


Current Time: Sat Dec 20 19:29:19 GMT 2014

Powered by FUDForum. Page generated in 0.02036 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software