Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » JavaServer Faces » Best jsf version to use
Best jsf version to use [message #474651] Thu, 28 June 2007 23:03 Go to next message
Eclipse UserFriend
Originally posted by: caioabecia.yahoo.com.br

Hi to everyone!

I'm in the jsf begining road..
I'm trying first to create the best* enviroment for developing my java web
app.
I've the eclipse sdk: eclipse-platform-3.2.2-win32.zip installed with
webtools and visual editor.
Now I want to install the JSF Tooling in my eclipse enviroment.

What's the best version to use (JSF Tooling)? The most stable.
After the answer of what version I should use.. how I do that instalation?

Thanks a lot !
Re: Best jsf version to use [message #474652 is a reply to message #474651] Fri, 29 June 2007 03:14 Go to previous messageGo to next message
epson wang is currently offline epson wangFriend
Messages: 32
Registered: July 2009
Member
Now you should use jsf 1.2, the 1.2 version use the # el and support
the jsp 2.1 tag, this is very good for develop. I think the wtp2 is
support the 1.2 version. If you just began the jsf, I will like the
jsf 1.2.
The basic tool is all in the wtp2, the exadel is good for jsf develop.
the bea studio workshop and the myeclipse is a good tool,

the wtp2 will released today. Good News.




On Thu, 28 Jun 2007 20:03:04 -0300, "Caio Figueiredo Abecia"
<caioabecia@yahoo.com.br> wrote:

>Hi to everyone!
>
>I'm in the jsf begining road..
>I'm trying first to create the best* enviroment for developing my java web
>app.
>I've the eclipse sdk: eclipse-platform-3.2.2-win32.zip installed with
>webtools and visual editor.
>Now I want to install the JSF Tooling in my eclipse enviroment.
>
>What's the best version to use (JSF Tooling)? The most stable.
>After the answer of what version I should use.. how I do that instalation?
>
>Thanks a lot !
>
Re: Best jsf version to use [message #474653 is a reply to message #474652] Fri, 29 June 2007 03:15 Go to previous messageGo to next message
epson wang is currently offline epson wangFriend
Messages: 32
Registered: July 2009
Member
Btw the bea studio workshop is just support jsf1.1.
Re: Best jsf version to use [message #474654 is a reply to message #474653] Fri, 29 June 2007 13:28 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: caioabecia.yahoo.com.br

Thanks for the quick answer!
I've now Eclipse working with the JSF Tooling + Sun JSF implementation..
Obs: I've done well the last tutorial sample in the project web site.

My Eclipse show the following configuration that is installed:
Eclipse Java development tools 3.2.2
Eclipse Modeling Framework (EMF) Runtime + End-User Tools 2.2.3
Eclipse Plataform 3.2.2
Eclipse Plug-in Development Environment 3.2.1
EMF Service Data Objects (SDO) Runtime + End-User Tools 2.2.1
Graphical Editing Framework 3.2.2
J2EE Standard Tools (JST) Project 1.5.4
JavaServer Faces Tooling (JSF) Project 0.5.1
Visual Editor 1.2.1
Web Standard Tools (WST) Project 1.5.4
XML Schema Infoset Model (XSD) Runtime + End-User Tools 2.2.2

Well.. that's all..

I would like to integrate my enviroment with Hibernate and with Spring.

What version of both do you recomend me to install in my eclipse
environment!?

Thanks


"ginkgo_w" <ginkgo_w@yahoo.com.cn> escreveu na mensagem
news:v9u883lsh96164po2g8lg3j42pi77n2utl@4ax.com...
> Btw the bea studio workshop is just support jsf1.1.
>
Re: Best jsf version to use [message #474657 is a reply to message #474654] Sat, 30 June 2007 00:08 Go to previous messageGo to next message
Raghu Srinivasan is currently offline Raghu SrinivasanFriend
Messages: 265
Registered: July 2009
Senior Member
>What version of both do you recomend me to install in my eclipse environment!?

Please use the Web Tools Plarform (WTP) 2.0 release which is part of the
Eclipse Europa release. JSF Tools is included in WTP 2.0 and supports JSF
1.2
-Raghu


Raghu Srinivasan,
Project Lead - JSF
Re: Best jsf version to use [message #474658 is a reply to message #474654] Sat, 30 June 2007 14:37 Go to previous message
epson wang is currently offline epson wangFriend
Messages: 32
Registered: July 2009
Member
Hi Caio Figueiredo Abecia
If you begin the jsf, the wtp 1.5 do Not support the tomcat 6,
it is to say you can not run the jsf 1.2 on the tomcat 5.5 ,
only the tomcat 6 support 1.2

The spring you should use the springide the 2.0 final just release.

Believe me you should like the eclipse 3.3 and wtp2.


On Fri, 29 Jun 2007 10:28:38 -0300, "Caio Figueiredo Abecia"
<caioabecia@yahoo.com.br> wrote:

>Thanks for the quick answer!
>I've now Eclipse working with the JSF Tooling + Sun JSF implementation..
>Obs: I've done well the last tutorial sample in the project web site.
Re: Best jsf version to use [message #612070 is a reply to message #474651] Fri, 29 June 2007 03:14 Go to previous message
epson wang is currently offline epson wangFriend
Messages: 32
Registered: July 2009
Member
Now you should use jsf 1.2, the 1.2 version use the # el and support
the jsp 2.1 tag, this is very good for develop. I think the wtp2 is
support the 1.2 version. If you just began the jsf, I will like the
jsf 1.2.
The basic tool is all in the wtp2, the exadel is good for jsf develop.
the bea studio workshop and the myeclipse is a good tool,

the wtp2 will released today. Good News.




On Thu, 28 Jun 2007 20:03:04 -0300, "Caio Figueiredo Abecia"
<caioabecia@yahoo.com.br> wrote:

>Hi to everyone!
>
>I'm in the jsf begining road..
>I'm trying first to create the best* enviroment for developing my java web
>app.
>I've the eclipse sdk: eclipse-platform-3.2.2-win32.zip installed with
>webtools and visual editor.
>Now I want to install the JSF Tooling in my eclipse enviroment.
>
>What's the best version to use (JSF Tooling)? The most stable.
>After the answer of what version I should use.. how I do that instalation?
>
>Thanks a lot !
>
Re: Best jsf version to use [message #612071 is a reply to message #474652] Fri, 29 June 2007 03:15 Go to previous message
epson wang is currently offline epson wangFriend
Messages: 32
Registered: July 2009
Member
Btw the bea studio workshop is just support jsf1.1.
Re: Best jsf version to use [message #612072 is a reply to message #474653] Fri, 29 June 2007 13:28 Go to previous message
Eclipse UserFriend
Originally posted by: caioabecia.yahoo.com.br

Thanks for the quick answer!
I've now Eclipse working with the JSF Tooling + Sun JSF implementation..
Obs: I've done well the last tutorial sample in the project web site.

My Eclipse show the following configuration that is installed:
Eclipse Java development tools 3.2.2
Eclipse Modeling Framework (EMF) Runtime + End-User Tools 2.2.3
Eclipse Plataform 3.2.2
Eclipse Plug-in Development Environment 3.2.1
EMF Service Data Objects (SDO) Runtime + End-User Tools 2.2.1
Graphical Editing Framework 3.2.2
J2EE Standard Tools (JST) Project 1.5.4
JavaServer Faces Tooling (JSF) Project 0.5.1
Visual Editor 1.2.1
Web Standard Tools (WST) Project 1.5.4
XML Schema Infoset Model (XSD) Runtime + End-User Tools 2.2.2

Well.. that's all..

I would like to integrate my enviroment with Hibernate and with Spring.

What version of both do you recomend me to install in my eclipse
environment!?

Thanks


"ginkgo_w" <ginkgo_w@yahoo.com.cn> escreveu na mensagem
news:v9u883lsh96164po2g8lg3j42pi77n2utl@4ax.com...
> Btw the bea studio workshop is just support jsf1.1.
>
Re: Best jsf version to use [message #612075 is a reply to message #474654] Sat, 30 June 2007 00:08 Go to previous message
Raghu Srinivasan is currently offline Raghu SrinivasanFriend
Messages: 265
Registered: July 2009
Senior Member
>What version of both do you recomend me to install in my eclipse environment!?

Please use the Web Tools Plarform (WTP) 2.0 release which is part of the
Eclipse Europa release. JSF Tools is included in WTP 2.0 and supports JSF
1.2
-Raghu


Raghu Srinivasan,
Project Lead - JSF
Re: Best jsf version to use [message #612076 is a reply to message #474654] Sat, 30 June 2007 14:37 Go to previous message
epson wang is currently offline epson wangFriend
Messages: 32
Registered: July 2009
Member
Hi Caio Figueiredo Abecia
If you begin the jsf, the wtp 1.5 do Not support the tomcat 6,
it is to say you can not run the jsf 1.2 on the tomcat 5.5 ,
only the tomcat 6 support 1.2

The spring you should use the springide the 2.0 final just release.

Believe me you should like the eclipse 3.3 and wtp2.


On Fri, 29 Jun 2007 10:28:38 -0300, "Caio Figueiredo Abecia"
<caioabecia@yahoo.com.br> wrote:

>Thanks for the quick answer!
>I've now Eclipse working with the JSF Tooling + Sun JSF implementation..
>Obs: I've done well the last tutorial sample in the project web site.
Previous Topic:Announcing JSF Tools Release 1.0..
Next Topic:[Fwd: Re: Announcing Webtools 2.0]
Goto Forum:
  


Current Time: Sat Dec 20 15:56:45 GMT 2014

Powered by FUDForum. Page generated in 0.01897 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software