Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 Tools » OCL expression problem extending UML2 editor
OCL expression problem extending UML2 editor [message #474438] Tue, 10 June 2008 18:45 Go to next message
Joel Greenyer is currently offline Joel GreenyerFriend
Messages: 170
Registered: July 2009
Senior Member
Hi,
I'm trying to build a customized/extended composite structure editor for my middleweight-extension of UML.
My model contains a specialized Port (in addition to the regular Port from UML) which shall be displayed differently.
I copied the Port Node Mapping entry from the compositeStructures.gmfmap and adapted it to fit the new Port.
While the editor works as expected with the regular UML Ports, I have a problem with the feature initializers of the new
Port. For example, there is one OCL feature initializer saying that feature "aggregation" should be
"AggregationKind::composite". When I create a new Port in the editor, I get the following error:

Expression problem:Unknown type ([AggregationKind, composite])body:AggregationKind::composite

Any ideas why that is?
Thanks

Joel
Re: OCL expression problem extending UML2 editor [message #474439 is a reply to message #474438] Tue, 10 June 2008 19:56 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: cdamus.zeligsoft.com

--=-H2IB3guNpr85iYI5d/Ri
Content-Type: text/plain
Content-Transfer-Encoding: 7bit

Hi, Joel,

If the context classifier of your OCL init expression isn't in the UML
metamodel namespace, then you will have to fully qualify your
enumeration:

uml::AggregationKind::composite

HTH,

Christian


On Tue, 2008-06-10 at 20:45 +0200, Joel Greenyer wrote:

> Hi,
> I'm trying to build a customized/extended composite structure editor for my middleweight-extension of UML.
> My model contains a specialized Port (in addition to the regular Port from UML) which shall be displayed differently.
> I copied the Port Node Mapping entry from the compositeStructures.gmfmap and adapted it to fit the new Port.
> While the editor works as expected with the regular UML Ports, I have a problem with the feature initializers of the new
> Port. For example, there is one OCL feature initializer saying that feature "aggregation" should be
> "AggregationKind::composite". When I create a new Port in the editor, I get the following error:
>
> Expression problem:Unknown type ([AggregationKind, composite])body:AggregationKind::composite
>
> Any ideas why that is?
> Thanks
>
> Joel

--=-H2IB3guNpr85iYI5d/Ri
Content-Type: text/html; charset=utf-8

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 TRANSITIONAL//EN">
<HTML>
<HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; CHARSET=UTF-8">
<META NAME="GENERATOR" CONTENT="GtkHTML/3.16.0">
</HEAD>
<BODY>
Hi, Joel,<BR>
<BR>
If the context classifier of your OCL init expression isn't in the UML metamodel namespace, then you will have to fully qualify your enumeration:<BR>
<BR>
&nbsp;&nbsp;&nbsp; uml::AggregationKind::composite<BR>
<BR>
HTH,<BR>
<BR>
Christian<BR>
<BR>
<BR>
On Tue, 2008-06-10 at 20:45 +0200, Joel Greenyer wrote:
<BLOCKQUOTE TYPE=CITE>
<PRE>
<FONT COLOR="#000000">Hi,</FONT>
<FONT COLOR="#000000">I'm trying to build a customized/extended composite structure editor for my middleweight-extension of UML.</FONT>
<FONT COLOR="#000000">My model contains a specialized Port (in addition to the regular Port from UML) which shall be displayed differently.</FONT>
<FONT COLOR="#000000">I copied the Port Node Mapping entry from the compositeStructures.gmfmap and adapted it to fit the new Port.</FONT>
<FONT COLOR="#000000">While the editor works as expected with the regular UML Ports, I have a problem with the feature initializers of the new </FONT>
<FONT COLOR="#000000">Port. For example, there is one OCL feature initializer saying that feature &quot;aggregation&quot; should be </FONT>
<FONT COLOR="#000000">&quot;AggregationKind::composite&quot;. When I create a new Port in the editor, I get the following error:</FONT>

<FONT COLOR="#000000">Expression problem:Unknown type ([AggregationKind, composite])body:AggregationKind::composite</FONT>

<FONT COLOR="#000000">Any ideas why that is?</FONT>
<FONT COLOR="#000000">Thanks</FONT>

<FONT COLOR="#000000">Joel</FONT>
</PRE>
</BLOCKQUOTE>
</BODY>
</HTML>

--=-H2IB3guNpr85iYI5d/Ri--
Re: OCL expression problem extending UML2 editor [message #474440 is a reply to message #474439] Tue, 10 June 2008 21:14 Go to previous message
Joel Greenyer is currently offline Joel GreenyerFriend
Messages: 170
Registered: July 2009
Senior Member
Hi Christian,
I already suspected it had to do with the metamodel namespace.
Now it works!

Thanks for the quick reply

Joel


Christian W. Damus wrote:
> Hi, Joel,
>
> If the context classifier of your OCL init expression isn't in the UML
> metamodel namespace, then you will have to fully qualify your enumeration:
>
> uml::AggregationKind::composite
>
> HTH,
>
> Christian
>
>
> On Tue, 2008-06-10 at 20:45 +0200, Joel Greenyer wrote:
>> Hi,
>> I'm trying to build a customized/extended composite structure editor for my middleweight-extension of UML.
>> My model contains a specialized Port (in addition to the regular Port from UML) which shall be displayed differently.
>> I copied the Port Node Mapping entry from the compositeStructures.gmfmap and adapted it to fit the new Port.
>> While the editor works as expected with the regular UML Ports, I have a problem with the feature initializers of the new
>> Port. For example, there is one OCL feature initializer saying that feature "aggregation" should be
>> "AggregationKind::composite". When I create a new Port in the editor, I get the following error:
>>
>> Expression problem:Unknown type ([AggregationKind, composite])body:AggregationKind::composite
>>
>> Any ideas why that is?
>> Thanks
>>
>> Joel
Re: OCL expression problem extending UML2 editor [message #619990 is a reply to message #474438] Tue, 10 June 2008 19:56 Go to previous message
Eclipse UserFriend
Originally posted by: cdamus.zeligsoft.com

--=-H2IB3guNpr85iYI5d/Ri
Content-Type: text/plain
Content-Transfer-Encoding: 7bit

Hi, Joel,

If the context classifier of your OCL init expression isn't in the UML
metamodel namespace, then you will have to fully qualify your
enumeration:

uml::AggregationKind::composite

HTH,

Christian


On Tue, 2008-06-10 at 20:45 +0200, Joel Greenyer wrote:

> Hi,
> I'm trying to build a customized/extended composite structure editor for my middleweight-extension of UML.
> My model contains a specialized Port (in addition to the regular Port from UML) which shall be displayed differently.
> I copied the Port Node Mapping entry from the compositeStructures.gmfmap and adapted it to fit the new Port.
> While the editor works as expected with the regular UML Ports, I have a problem with the feature initializers of the new
> Port. For example, there is one OCL feature initializer saying that feature "aggregation" should be
> "AggregationKind::composite". When I create a new Port in the editor, I get the following error:
>
> Expression problem:Unknown type ([AggregationKind, composite])body:AggregationKind::composite
>
> Any ideas why that is?
> Thanks
>
> Joel

--=-H2IB3guNpr85iYI5d/Ri
Content-Type: text/html; charset=utf-8

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 TRANSITIONAL//EN">
<HTML>
<HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; CHARSET=UTF-8">
<META NAME="GENERATOR" CONTENT="GtkHTML/3.16.0">
</HEAD>
<BODY>
Hi, Joel,<BR>
<BR>
If the context classifier of your OCL init expression isn't in the UML metamodel namespace, then you will have to fully qualify your enumeration:<BR>
<BR>
&nbsp;&nbsp;&nbsp; uml::AggregationKind::composite<BR>
<BR>
HTH,<BR>
<BR>
Christian<BR>
<BR>
<BR>
On Tue, 2008-06-10 at 20:45 +0200, Joel Greenyer wrote:
<BLOCKQUOTE TYPE=CITE>
<PRE>
<FONT COLOR="#000000">Hi,</FONT>
<FONT COLOR="#000000">I'm trying to build a customized/extended composite structure editor for my middleweight-extension of UML.</FONT>
<FONT COLOR="#000000">My model contains a specialized Port (in addition to the regular Port from UML) which shall be displayed differently.</FONT>
<FONT COLOR="#000000">I copied the Port Node Mapping entry from the compositeStructures.gmfmap and adapted it to fit the new Port.</FONT>
<FONT COLOR="#000000">While the editor works as expected with the regular UML Ports, I have a problem with the feature initializers of the new </FONT>
<FONT COLOR="#000000">Port. For example, there is one OCL feature initializer saying that feature &quot;aggregation&quot; should be </FONT>
<FONT COLOR="#000000">&quot;AggregationKind::composite&quot;. When I create a new Port in the editor, I get the following error:</FONT>

<FONT COLOR="#000000">Expression problem:Unknown type ([AggregationKind, composite])body:AggregationKind::composite</FONT>

<FONT COLOR="#000000">Any ideas why that is?</FONT>
<FONT COLOR="#000000">Thanks</FONT>

<FONT COLOR="#000000">Joel</FONT>
</PRE>
</BLOCKQUOTE>
</BODY>
</HTML>

--=-H2IB3guNpr85iYI5d/Ri--
Re: OCL expression problem extending UML2 editor [message #619991 is a reply to message #474439] Tue, 10 June 2008 21:14 Go to previous message
Joel Greenyer is currently offline Joel GreenyerFriend
Messages: 170
Registered: July 2009
Senior Member
Hi Christian,
I already suspected it had to do with the metamodel namespace.
Now it works!

Thanks for the quick reply

Joel


Christian W. Damus wrote:
> Hi, Joel,
>
> If the context classifier of your OCL init expression isn't in the UML
> metamodel namespace, then you will have to fully qualify your enumeration:
>
> uml::AggregationKind::composite
>
> HTH,
>
> Christian
>
>
> On Tue, 2008-06-10 at 20:45 +0200, Joel Greenyer wrote:
>> Hi,
>> I'm trying to build a customized/extended composite structure editor for my middleweight-extension of UML.
>> My model contains a specialized Port (in addition to the regular Port from UML) which shall be displayed differently.
>> I copied the Port Node Mapping entry from the compositeStructures.gmfmap and adapted it to fit the new Port.
>> While the editor works as expected with the regular UML Ports, I have a problem with the feature initializers of the new
>> Port. For example, there is one OCL feature initializer saying that feature "aggregation" should be
>> "AggregationKind::composite". When I create a new Port in the editor, I get the following error:
>>
>> Expression problem:Unknown type ([AggregationKind, composite])body:AggregationKind::composite
>>
>> Any ideas why that is?
>> Thanks
>>
>> Joel
Previous Topic:OCL expression problem extending UML2 editor
Next Topic:Re: XML/XMI import/export issues?
Goto Forum:
  


Current Time: Sat Dec 20 23:16:25 GMT 2014

Powered by FUDForum. Page generated in 0.01654 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software