Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » JavaServer Faces » Firefox working, but not with IE
Firefox working, but not with IE [message #474184] Tue, 15 May 2007 09:39 Go to next message
John Smith is currently offline John Smith
Messages: 137
Registered: July 2009
Senior Member
My JSF application, a war packed with WTP and applied to JBoss
jboss-4.2.0.CR2 (i tried v4.0.5, too), does well work when viewed with
Firefox. However when viewed in Internet Explorer, the ".faces" files
entered in the address bar seem to be not processed by the JSP or JSF
processor, instead I get the pure contents from the mapped ".jsp" file,
displayed as XML in the IE window.
(I have deployed the Web application locally and e.g. access
http://localhost:8080/login.faces. I have Windows XP).

Any idea?
Re: Firefox working, but not with IE [message #474185 is a reply to message #474184] Tue, 15 May 2007 20:56 Go to previous messageGo to next message
Cameron Bateman is currently offline Cameron Bateman
Messages: 480
Registered: July 2009
Senior Member
Hi John,

Could you try the same test but with no JSF in the application? That is,
can you try creating a similar simple application that is just using JSPs
with no JSF? This will help us isolate whether this is a general problem
or one specific to JSF.


Thanks,

Cameron

John Smith wrote:

> My JSF application, a war packed with WTP and applied to JBoss
> jboss-4.2.0.CR2 (i tried v4.0.5, too), does well work when viewed with
> Firefox. However when viewed in Internet Explorer, the ".faces" files
> entered in the address bar seem to be not processed by the JSP or JSF
> processor, instead I get the pure contents from the mapped ".jsp" file,
> displayed as XML in the IE window.
> (I have deployed the Web application locally and e.g. access
> http://localhost:8080/login.faces. I have Windows XP).

> Any idea?
Re: Firefox working, but not with IE [message #474642 is a reply to message #474185] Mon, 18 June 2007 13:37 Go to previous messageGo to next message
John Smith is currently offline John Smith
Messages: 137
Registered: July 2009
Senior Member
Cameron Bateman wrote:
> Hi John,
>
> Could you try the same test but with no JSF in the application? That
> is, can you try creating a similar simple application that is just using
> JSPs with no JSF? This will help us isolate whether this is a general
> problem or one specific to JSF.
>
>
> Thanks,
>
> Cameron
>
> John Smith wrote:
>
>> My JSF application, a war packed with WTP and applied to JBoss
>> jboss-4.2.0.CR2 (i tried v4.0.5, too), does well work when viewed with
>> Firefox. However when viewed in Internet Explorer, the ".faces" files
>> entered in the address bar seem to be not processed by the JSP or JSF
>> processor, instead I get the pure contents from the mapped ".jsp"
>> file, displayed as XML in the IE window.
>> (I have deployed the Web application locally and e.g. access
>> http://localhost:8080/login.faces. I have Windows XP).
>
>> Any idea?
>



I figured out that using .jsf as files extension and not .faces in the
url (with changing the url-pattern in web.xml from *.faces to *.jsf,
too) solved the problem! The only question now is: WHY??

In the not-working case at Internet Explorer , Internet Explorer still
displays the correct HTML as I view the page source, but in the Browser
its not interpreted as HTML but as XML. So why is it interpreted as HTML
by IE when I use .jsf instead of .faces? Is there a fix list of
allowed extensions build into Internet Explorer ? (I would not wonder if
this is the case..)

Thanks
Re: Firefox working, but not with IE [message #474643 is a reply to message #474642] Mon, 18 June 2007 13:47 Go to previous message
John Smith is currently offline John Smith
Messages: 137
Registered: July 2009
Senior Member
Ok the problem is solved, I have to add the content type, so this works now:

<?xml version="1.0"?>
<jsp:root xmlns:jsp="http://java.sun.com/JSP/Page"
xmlns:h="http://java.sun.com/jsf/html"
xmlns:f="http://java.sun.com/jsf/core"
xmlns:c="http://java.sun.com/jstl/core"
xmlns:s="http://jboss.com/products/seam/taglib"
xmlns="http://www.w3.org/1999/xhtml" version="2.0">
<jsp:directive.page contentType="text/html;charset=ISO-8859-1"
pageEncoding="ISO-8859-1"></jsp:directive.page>
<html...
Re: Firefox working, but not with IE [message #610960 is a reply to message #474184] Tue, 15 May 2007 20:56 Go to previous message
Cameron Bateman is currently offline Cameron Bateman
Messages: 480
Registered: July 2009
Senior Member
Hi John,

Could you try the same test but with no JSF in the application? That is,
can you try creating a similar simple application that is just using JSPs
with no JSF? This will help us isolate whether this is a general problem
or one specific to JSF.


Thanks,

Cameron

John Smith wrote:

> My JSF application, a war packed with WTP and applied to JBoss
> jboss-4.2.0.CR2 (i tried v4.0.5, too), does well work when viewed with
> Firefox. However when viewed in Internet Explorer, the ".faces" files
> entered in the address bar seem to be not processed by the JSP or JSF
> processor, instead I get the pure contents from the mapped ".jsp" file,
> displayed as XML in the IE window.
> (I have deployed the Web application locally and e.g. access
> http://localhost:8080/login.faces I have Windows XP).

> Any idea?
Re: Firefox working, but not with IE [message #612060 is a reply to message #474185] Mon, 18 June 2007 13:37 Go to previous message
John Smith is currently offline John Smith
Messages: 137
Registered: July 2009
Senior Member
Cameron Bateman wrote:
> Hi John,
>
> Could you try the same test but with no JSF in the application? That
> is, can you try creating a similar simple application that is just using
> JSPs with no JSF? This will help us isolate whether this is a general
> problem or one specific to JSF.
>
>
> Thanks,
>
> Cameron
>
> John Smith wrote:
>
>> My JSF application, a war packed with WTP and applied to JBoss
>> jboss-4.2.0.CR2 (i tried v4.0.5, too), does well work when viewed with
>> Firefox. However when viewed in Internet Explorer, the ".faces" files
>> entered in the address bar seem to be not processed by the JSP or JSF
>> processor, instead I get the pure contents from the mapped ".jsp"
>> file, displayed as XML in the IE window.
>> (I have deployed the Web application locally and e.g. access
>> http://localhost:8080/login.faces I have Windows XP).
>
>> Any idea?
>



I figured out that using .jsf as files extension and not .faces in the
url (with changing the url-pattern in web.xml from *.faces to *.jsf,
too) solved the problem! The only question now is: WHY??

In the not-working case at Internet Explorer , Internet Explorer still
displays the correct HTML as I view the page source, but in the Browser
its not interpreted as HTML but as XML. So why is it interpreted as HTML
by IE when I use .jsf instead of .faces? Is there a fix list of
allowed extensions build into Internet Explorer ? (I would not wonder if
this is the case..)

Thanks
Re: Firefox working, but not with IE [message #612061 is a reply to message #474642] Mon, 18 June 2007 13:47 Go to previous message
John Smith is currently offline John Smith
Messages: 137
Registered: July 2009
Senior Member
Ok the problem is solved, I have to add the content type, so this works now:

<?xml version="1.0"?>
<jsp:root xmlns:jsp="http://java.sun.com/JSP/Page"
xmlns:h="http://java.sun.com/jsf/html"
xmlns:f="http://java.sun.com/jsf/core"
xmlns:c="http://java.sun.com/jstl/core"
xmlns:s="http://jboss.com/products/seam/taglib"
xmlns="http://www.w3.org/1999/xhtml" version="2.0">
<jsp:directive.page contentType="text/html;charset=ISO-8859-1"
pageEncoding="ISO-8859-1"></jsp:directive.page>
<html...
Previous Topic:Missing the Visual Page Designer Feature in WTP 2.0 - default configuration?
Next Topic:JSF & Eclipse project
Goto Forum:
  


Current Time: Thu Sep 18 03:46:49 GMT 2014

Powered by FUDForum. Page generated in 0.09319 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software