Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » JavaServer Faces » JSF unknown tag since WTP 1.5.1 and JSF 0.5.1 upgrade
JSF unknown tag since WTP 1.5.1 and JSF 0.5.1 upgrade [message #473665] Thu, 26 October 2006 15:16 Go to next message
Arnaud MERGEY is currently offline Arnaud MERGEY
Messages: 34
Registered: July 2009
Member
Hi,

I have used JSF 0.5.0 and WTP 1.5.0 pluginq in order to develop JSF web
apps.
Since upgrade of my Eclipse (3.2.0 -> 3.2.1, WTP 1.5.0 -> 1.5.1 and JSF
O.5.0 -> 0.5.1), JSF tags aren't anymore recognized in my apps.
I have tried to clean all projects, to launch Eclipse with -clean option ,
I have plenty of unknow tags warning in my JSF pages.
Content assist doesn't work anymore.

What can I do ? thanks for help.
Arnaud
Re: JSF unknown tag since WTP 1.5.1 and JSF 0.5.1 upgrade [message #473666 is a reply to message #473665] Thu, 26 October 2006 18:11 Go to previous messageGo to next message
Cameron Bateman is currently offline Cameron Bateman
Messages: 480
Registered: July 2009
Senior Member
Are the projects showing problems ones that have been imported from
existing or that you created new using the WTP 1.5.1 build?

--Cam
Re: JSF unknown tag since WTP 1.5.1 and JSF 0.5.1 upgrade [message #473667 is a reply to message #473666] Fri, 27 October 2006 08:42 Go to previous messageGo to next message
user is currently offline user
Messages: 296
Registered: July 2009
Senior Member
Hi,
new projects works perfectly
"Old" WTP 1.5.0 and JSF 0.5.0 created projects doesn't work anymore.

I tried without success to manually change properties setting in old
projects

Thanks
Arnaud

Cameron Bateman a écrit :
> Are the projects showing problems ones that have been imported from
> existing or that you created new using the WTP 1.5.1 build?
>
> --Cam
>
Re: JSF unknown tag since WTP 1.5.1 and JSF 0.5.1 upgrade [message #473669 is a reply to message #473667] Fri, 27 October 2006 09:29 Go to previous messageGo to next message
Arnaud MERGEY is currently offline Arnaud MERGEY
Messages: 34
Registered: July 2009
Member
Hi,
new projects works perfectly
"Old" WTP 1.5.0 and JSF 0.5.0 created projects doesn't work anymore.

I tried without success to manually change properties setting in old
projects

Thanks
Arnaud

> Cameron Bateman a écrit :
> Are the projects showing problems ones that have been imported from
> existing or that you created new using the WTP 1.5.1 build?
>
> --Cam
>
Re: JSF unknown tag since WTP 1.5.1 and JSF 0.5.1 upgrade [message #473670 is a reply to message #473669] Fri, 27 October 2006 22:31 Go to previous messageGo to next message
Cameron Bateman is currently offline Cameron Bateman
Messages: 480
Registered: July 2009
Senior Member
I think there may be an issue with the TLD loading. Can see what happens
if you delete and re-add the module dependencies for the jars in one of
your projects?


--Cam
Re: JSF unknown tag since WTP 1.5.1 and JSF 0.5.1 upgrade [message #473673 is a reply to message #473670] Mon, 30 October 2006 08:11 Go to previous messageGo to next message
Arnaud MERGEY is currently offline Arnaud MERGEY
Messages: 34
Registered: July 2009
Member
I have tried but it changes anything.

I have tried to clean and rebuild, to clean eclipse internet cache and
so on ..., without success.

Arnaud

Cameron Bateman a écrit :
> I think there may be an issue with the TLD loading. Can see what
> happens if you delete and re-add the module dependencies for the jars in
> one of your projects?
>
>
> --Cam
>
Re: JSF unknown tag since WTP 1.5.1 and JSF 0.5.1 upgrade [message #473674 is a reply to message #473673] Mon, 30 October 2006 10:18 Go to previous messageGo to next message
Arnaud MERGEY is currently offline Arnaud MERGEY
Messages: 34
Registered: July 2009
Member
Hi,
I have solved the problem copying all .settings properties, .project and
..classpath of a new JSF project into an old JSF project. I have manually
changed param like project name when it was necessary, and now tags are
recognized.

Arnaud

amergey@sunopsis.com a écrit :
> I have tried but it changes anything.
>
> I have tried to clean and rebuild, to clean eclipse internet cache and
> so on ..., without success.
>
> Arnaud
>
> Cameron Bateman a écrit :
>> I think there may be an issue with the TLD loading. Can see what
>> happens if you delete and re-add the module dependencies for the jars
>> in one of your projects?
>>
>>
>> --Cam
>>
Re: JSF unknown tag since WTP 1.5.1 and JSF 0.5.1 upgrade [message #473697 is a reply to message #473674] Mon, 30 October 2006 22:46 Go to previous messageGo to next message
Cameron Bateman is currently offline Cameron Bateman
Messages: 480
Registered: July 2009
Senior Member
Hmm.. that's not good. I try to follow that up with WTP.


--Cam
Re: JSF unknown tag since WTP 1.5.1 and JSF 0.5.1 upgrade [message #473699 is a reply to message #473697] Fri, 03 November 2006 09:31 Go to previous messageGo to next message
Arnaud MERGEY is currently offline Arnaud MERGEY
Messages: 34
Registered: July 2009
Member
Hi,

I 'have updated to WTP 1.5.2, removing/re-adding JSF libs dependency,
JSF tags are recognized, something should be probably fixed in WTP.

thanks
Arnaud

Cameron Bateman a écrit :
> Hmm.. that's not good. I try to follow that up with WTP.
>
>
> --Cam
>
Re: JSF unknown tag since WTP 1.5.1 and JSF 0.5.1 upgrade [message #473700 is a reply to message #473699] Fri, 03 November 2006 21:25 Go to previous messageGo to next message
Cameron Bateman is currently offline Cameron Bateman
Messages: 480
Registered: July 2009
Senior Member
Could you clarify? Are you saying that your problem went away in 1.5.2
builds? Or is there still a problem?


--Cam

amergey@sunopsis.com wrote:

> Hi,

> I 'have updated to WTP 1.5.2, removing/re-adding JSF libs dependency,
> JSF tags are recognized, something should be probably fixed in WTP.

> thanks
> Arnaud

> Cameron Bateman a écrit :
>> Hmm.. that's not good. I try to follow that up with WTP.
>>
>>
>> --Cam
>>
Re: JSF unknown tag since WTP 1.5.1 and JSF 0.5.1 upgrade [message #473704 is a reply to message #473700] Mon, 06 November 2006 08:44 Go to previous messageGo to next message
Arnaud MERGEY is currently offline Arnaud MERGEY
Messages: 34
Registered: July 2009
Member
Sorry for my poor english,
with WTP 1.5.2 the problem doesn't exist anymore.

Regards,
Arnaud

Cameron Bateman a écrit :
> Could you clarify? Are you saying that your problem went away in 1.5.2
> builds? Or is there still a problem?
>
>
> --Cam
>
> amergey@sunopsis.com wrote:
>
>> Hi,
>
>> I 'have updated to WTP 1.5.2, removing/re-adding JSF libs dependency,
>> JSF tags are recognized, something should be probably fixed in WTP.
>
>> thanks
>> Arnaud
>
>> Cameron Bateman a écrit :
>>> Hmm.. that's not good. I try to follow that up with WTP.
>>>
>>>
>>> --Cam
>>>
>
>
Re: JSF unknown tag since WTP 1.5.1 and JSF 0.5.1 upgrade [message #473705 is a reply to message #473704] Mon, 06 November 2006 18:45 Go to previous message
Cameron Bateman is currently offline Cameron Bateman
Messages: 480
Registered: July 2009
Senior Member
Thanks Arnaud. That's good to hear.

amergey@sunopsis.com wrote:

> Sorry for my poor english,
> with WTP 1.5.2 the problem doesn't exist anymore.

> Regards,
> Arnaud

>
Re: JSF unknown tag since WTP 1.5.1 and JSF 0.5.1 upgrade [message #608340 is a reply to message #473665] Thu, 26 October 2006 18:11 Go to previous message
Cameron Bateman is currently offline Cameron Bateman
Messages: 480
Registered: July 2009
Senior Member
Are the projects showing problems ones that have been imported from
existing or that you created new using the WTP 1.5.1 build?

--Cam
Re: JSF unknown tag since WTP 1.5.1 and JSF 0.5.1 upgrade [message #608342 is a reply to message #473666] Fri, 27 October 2006 08:42 Go to previous message
user is currently offline user
Messages: 296
Registered: July 2009
Senior Member
Hi,
new projects works perfectly
"Old" WTP 1.5.0 and JSF 0.5.0 created projects doesn't work anymore.

I tried without success to manually change properties setting in old
projects

Thanks
Arnaud

Cameron Bateman a écrit :
> Are the projects showing problems ones that have been imported from
> existing or that you created new using the WTP 1.5.1 build?
>
> --Cam
>
Re: JSF unknown tag since WTP 1.5.1 and JSF 0.5.1 upgrade [message #608348 is a reply to message #473667] Fri, 27 October 2006 09:29 Go to previous message
Arnaud MERGEY is currently offline Arnaud MERGEY
Messages: 34
Registered: July 2009
Member
Hi,
new projects works perfectly
"Old" WTP 1.5.0 and JSF 0.5.0 created projects doesn't work anymore.

I tried without success to manually change properties setting in old
projects

Thanks
Arnaud

> Cameron Bateman a écrit :
> Are the projects showing problems ones that have been imported from
> existing or that you created new using the WTP 1.5.1 build?
>
> --Cam
>
Re: JSF unknown tag since WTP 1.5.1 and JSF 0.5.1 upgrade [message #608350 is a reply to message #473669] Fri, 27 October 2006 22:31 Go to previous message
Cameron Bateman is currently offline Cameron Bateman
Messages: 480
Registered: July 2009
Senior Member
I think there may be an issue with the TLD loading. Can see what happens
if you delete and re-add the module dependencies for the jars in one of
your projects?


--Cam
Re: JSF unknown tag since WTP 1.5.1 and JSF 0.5.1 upgrade [message #608357 is a reply to message #473670] Mon, 30 October 2006 08:11 Go to previous message
Arnaud MERGEY is currently offline Arnaud MERGEY
Messages: 34
Registered: July 2009
Member
I have tried but it changes anything.

I have tried to clean and rebuild, to clean eclipse internet cache and
so on ..., without success.

Arnaud

Cameron Bateman a écrit :
> I think there may be an issue with the TLD loading. Can see what
> happens if you delete and re-add the module dependencies for the jars in
> one of your projects?
>
>
> --Cam
>
Re: JSF unknown tag since WTP 1.5.1 and JSF 0.5.1 upgrade [message #608359 is a reply to message #473673] Mon, 30 October 2006 10:18 Go to previous message
Arnaud MERGEY is currently offline Arnaud MERGEY
Messages: 34
Registered: July 2009
Member
Hi,
I have solved the problem copying all .settings properties, .project and
..classpath of a new JSF project into an old JSF project. I have manually
changed param like project name when it was necessary, and now tags are
recognized.

Arnaud

amergey@sunopsis.com a écrit :
> I have tried but it changes anything.
>
> I have tried to clean and rebuild, to clean eclipse internet cache and
> so on ..., without success.
>
> Arnaud
>
> Cameron Bateman a écrit :
>> I think there may be an issue with the TLD loading. Can see what
>> happens if you delete and re-add the module dependencies for the jars
>> in one of your projects?
>>
>>
>> --Cam
>>
Re: JSF unknown tag since WTP 1.5.1 and JSF 0.5.1 upgrade [message #608364 is a reply to message #473674] Mon, 30 October 2006 22:46 Go to previous message
Cameron Bateman is currently offline Cameron Bateman
Messages: 480
Registered: July 2009
Senior Member
Hmm.. that's not good. I try to follow that up with WTP.


--Cam
Re: JSF unknown tag since WTP 1.5.1 and JSF 0.5.1 upgrade [message #608366 is a reply to message #473697] Fri, 03 November 2006 09:31 Go to previous message
Arnaud MERGEY is currently offline Arnaud MERGEY
Messages: 34
Registered: July 2009
Member
Hi,

I 'have updated to WTP 1.5.2, removing/re-adding JSF libs dependency,
JSF tags are recognized, something should be probably fixed in WTP.

thanks
Arnaud

Cameron Bateman a écrit :
> Hmm.. that's not good. I try to follow that up with WTP.
>
>
> --Cam
>
Re: JSF unknown tag since WTP 1.5.1 and JSF 0.5.1 upgrade [message #608367 is a reply to message #473699] Fri, 03 November 2006 21:25 Go to previous message
Cameron Bateman is currently offline Cameron Bateman
Messages: 480
Registered: July 2009
Senior Member
Could you clarify? Are you saying that your problem went away in 1.5.2
builds? Or is there still a problem?


--Cam

amergey@sunopsis.com wrote:

> Hi,

> I 'have updated to WTP 1.5.2, removing/re-adding JSF libs dependency,
> JSF tags are recognized, something should be probably fixed in WTP.

> thanks
> Arnaud

> Cameron Bateman a écrit :
>> Hmm.. that's not good. I try to follow that up with WTP.
>>
>>
>> --Cam
>>
Re: JSF unknown tag since WTP 1.5.1 and JSF 0.5.1 upgrade [message #608371 is a reply to message #473700] Mon, 06 November 2006 08:44 Go to previous message
Arnaud MERGEY is currently offline Arnaud MERGEY
Messages: 34
Registered: July 2009
Member
Sorry for my poor english,
with WTP 1.5.2 the problem doesn't exist anymore.

Regards,
Arnaud

Cameron Bateman a écrit :
> Could you clarify? Are you saying that your problem went away in 1.5.2
> builds? Or is there still a problem?
>
>
> --Cam
>
> amergey@sunopsis.com wrote:
>
>> Hi,
>
>> I 'have updated to WTP 1.5.2, removing/re-adding JSF libs dependency,
>> JSF tags are recognized, something should be probably fixed in WTP.
>
>> thanks
>> Arnaud
>
>> Cameron Bateman a écrit :
>>> Hmm.. that's not good. I try to follow that up with WTP.
>>>
>>>
>>> --Cam
>>>
>
>
Re: JSF unknown tag since WTP 1.5.1 and JSF 0.5.1 upgrade [message #608372 is a reply to message #473704] Mon, 06 November 2006 18:45 Go to previous message
Cameron Bateman is currently offline Cameron Bateman
Messages: 480
Registered: July 2009
Senior Member
Thanks Arnaud. That's good to hear.

amergey@sunopsis.com wrote:

> Sorry for my poor english,
> with WTP 1.5.2 the problem doesn't exist anymore.

> Regards,
> Arnaud

>
Previous Topic:JSP import problems
Next Topic:Exception when accessing JSP page
Goto Forum:
  


Current Time: Tue Sep 02 23:48:29 GMT 2014

Powered by FUDForum. Page generated in 0.02451 seconds