Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 Tools » Transitions are not updated in state machine diagrams
Transitions are not updated in state machine diagrams [message #472463] Thu, 17 January 2008 16:08 Go to next message
Dimitrios Kolovos is currently offline Dimitrios KolovosFriend
Messages: 1776
Registered: July 2009
Senior Member
In a state machine diagram, if I create a transition between two states
and then change its source or target state via the properties view, the
arrow is not updated accordingly until I close/open the diagram again.

I'm using 0.7.1. Any ideas?

Cheers,
Dimitrios
Re: Transitions are not updated in state machine diagrams [message #472475 is a reply to message #472463] Fri, 18 January 2008 10:39 Go to previous messageGo to next message
Sergey Gribovsky is currently offline Sergey GribovskyFriend
Messages: 42
Registered: July 2009
Member
Hi Dimitrios,

It looks like a bug in implementation. I've submit a request
https://bugs.eclipse.org/bugs/show_bug.cgi?id=215772

Thank you,
Sergey

"Dimitrios Kolovos" <dskolovos@gmail.com> wrote in message
news:fmnuhq$m1c$1@build.eclipse.org...
> In a state machine diagram, if I create a transition between two states
> and then change its source or target state via the properties view, the
> arrow is not updated accordingly until I close/open the diagram again.
>
> I'm using 0.7.1. Any ideas?
>
> Cheers,
> Dimitrios
Re: Transitions are not updated in state machine diagrams [message #472477 is a reply to message #472475] Fri, 18 January 2008 10:52 Go to previous messageGo to next message
Dimitrios Kolovos is currently offline Dimitrios KolovosFriend
Messages: 1776
Registered: July 2009
Senior Member
Hi Sergey,

Thanks. I've also seen the same issue in other places too (e.g. control
flows of activity diagrams). This looks suspiciously similar to
https://bugs.eclipse.org/bugs/show_bug.cgi?id=170328 which however seems
to have been fixed a year ago...

Cheers,
Dimitrios

Sergey Gribovsky wrote:
> Hi Dimitrios,
>
> It looks like a bug in implementation. I've submit a request
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=215772
>
> Thank you,
> Sergey
>
> "Dimitrios Kolovos" <dskolovos@gmail.com> wrote in message
> news:fmnuhq$m1c$1@build.eclipse.org...
>> In a state machine diagram, if I create a transition between two states
>> and then change its source or target state via the properties view, the
>> arrow is not updated accordingly until I close/open the diagram again.
>>
>> I'm using 0.7.1. Any ideas?
>>
>> Cheers,
>> Dimitrios
>
>
Re: Transitions are not updated in state machine diagrams [message #472483 is a reply to message #472477] Fri, 18 January 2008 16:38 Go to previous message
Sergey Gribovsky is currently offline Sergey GribovskyFriend
Messages: 42
Registered: July 2009
Member
I have updated the request accordingly.

It seems to me that reason of the bug is unimplemented functionality in
updater of State/Activity diagrams, there will be more details after
investigation.

Sergey.

"Dimitrios Kolovos" <dskolovos@gmail.com> wrote in message
news:fmq0e2$5k9$1@build.eclipse.org...
> Hi Sergey,
>
> Thanks. I've also seen the same issue in other places too (e.g. control
> flows of activity diagrams). This looks suspiciously similar to
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=170328 which however seems
> to have been fixed a year ago...
>
> Cheers,
> Dimitrios
>
> Sergey Gribovsky wrote:
>> Hi Dimitrios,
>>
>> It looks like a bug in implementation. I've submit a request
>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=215772
>>
>> Thank you,
>> Sergey
>>
>> "Dimitrios Kolovos" <dskolovos@gmail.com> wrote in message
>> news:fmnuhq$m1c$1@build.eclipse.org...
>>> In a state machine diagram, if I create a transition between two states
>>> and then change its source or target state via the properties view, the
>>> arrow is not updated accordingly until I close/open the diagram again.
>>>
>>> I'm using 0.7.1. Any ideas?
>>>
>>> Cheers,
>>> Dimitrios
>>
Re: Transitions are not updated in state machine diagrams [message #616744 is a reply to message #472463] Fri, 18 January 2008 10:39 Go to previous message
Sergey Gribovsky is currently offline Sergey GribovskyFriend
Messages: 42
Registered: July 2009
Member
Hi Dimitrios,

It looks like a bug in implementation. I've submit a request
https://bugs.eclipse.org/bugs/show_bug.cgi?id=215772

Thank you,
Sergey

"Dimitrios Kolovos" <dskolovos@gmail.com> wrote in message
news:fmnuhq$m1c$1@build.eclipse.org...
> In a state machine diagram, if I create a transition between two states
> and then change its source or target state via the properties view, the
> arrow is not updated accordingly until I close/open the diagram again.
>
> I'm using 0.7.1. Any ideas?
>
> Cheers,
> Dimitrios
Re: Transitions are not updated in state machine diagrams [message #616745 is a reply to message #472475] Fri, 18 January 2008 10:52 Go to previous message
Dimitrios Kolovos is currently offline Dimitrios KolovosFriend
Messages: 1776
Registered: July 2009
Senior Member
Hi Sergey,

Thanks. I've also seen the same issue in other places too (e.g. control
flows of activity diagrams). This looks suspiciously similar to
https://bugs.eclipse.org/bugs/show_bug.cgi?id=170328 which however seems
to have been fixed a year ago...

Cheers,
Dimitrios

Sergey Gribovsky wrote:
> Hi Dimitrios,
>
> It looks like a bug in implementation. I've submit a request
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=215772
>
> Thank you,
> Sergey
>
> "Dimitrios Kolovos" <dskolovos@gmail.com> wrote in message
> news:fmnuhq$m1c$1@build.eclipse.org...
>> In a state machine diagram, if I create a transition between two states
>> and then change its source or target state via the properties view, the
>> arrow is not updated accordingly until I close/open the diagram again.
>>
>> I'm using 0.7.1. Any ideas?
>>
>> Cheers,
>> Dimitrios
>
>
Re: Transitions are not updated in state machine diagrams [message #617050 is a reply to message #472477] Fri, 18 January 2008 16:38 Go to previous message
Sergey Gribovsky is currently offline Sergey GribovskyFriend
Messages: 42
Registered: July 2009
Member
I have updated the request accordingly.

It seems to me that reason of the bug is unimplemented functionality in
updater of State/Activity diagrams, there will be more details after
investigation.

Sergey.

"Dimitrios Kolovos" <dskolovos@gmail.com> wrote in message
news:fmq0e2$5k9$1@build.eclipse.org...
> Hi Sergey,
>
> Thanks. I've also seen the same issue in other places too (e.g. control
> flows of activity diagrams). This looks suspiciously similar to
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=170328 which however seems
> to have been fixed a year ago...
>
> Cheers,
> Dimitrios
>
> Sergey Gribovsky wrote:
>> Hi Dimitrios,
>>
>> It looks like a bug in implementation. I've submit a request
>> https://bugs.eclipse.org/bugs/show_bug.cgi?id=215772
>>
>> Thank you,
>> Sergey
>>
>> "Dimitrios Kolovos" <dskolovos@gmail.com> wrote in message
>> news:fmnuhq$m1c$1@build.eclipse.org...
>>> In a state machine diagram, if I create a transition between two states
>>> and then change its source or target state via the properties view, the
>>> arrow is not updated accordingly until I close/open the diagram again.
>>>
>>> I'm using 0.7.1. Any ideas?
>>>
>>> Cheers,
>>> Dimitrios
>>
Previous Topic:source of TOPCASED
Next Topic:Loop Nodes and Conditional Nodes in Activity Diagrams
Goto Forum:
  


Current Time: Wed Dec 17 20:01:16 GMT 2014

Powered by FUDForum. Page generated in 0.02295 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software