Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Platform - User Assistance (UA) » Help view doesn't update
Help view doesn't update [message #472387] Tue, 25 March 2008 03:20 Go to next message
Eclipse User
Originally posted by: torbjorn.ghostwriter.no

I have two views in my RCP application, and in each views's
createPartControl method I have a line like this:

PlatformUI.getWorkbench().getHelpSystem().setHelp(parent,
"com.whatever.viewA");

In contexts.xml (referenced in plugin.xml) I have this:

<contexts>
<context id="viewA" title="One view">
<description>This view is the best!</description>
</context>

<context id="viewB" title="Another View">
<description>No, this is the best view!</description>
</context>
</contexts>

Everything looking good, right? Well, when I run the application and select
view B, the help view shows only the header (About Another View), but when I
select view A the correct help is shown. However, even if I change back to
view B, the help text remains (though the header changes correctly), so it's
like this:

About Another View: This view is the best!

Basically, view A's context description "sticks". Does anyone know what can
cause this?
Re: Help view doesn't update [message #472388 is a reply to message #472387] Tue, 25 March 2008 03:22 Go to previous messageGo to next message
Eclipse User
Originally posted by: torbjorn.ghostwriter.no

Also, I forgot to mention I'm on 3.3.

"Torbj
Re: Help view doesn't update [message #472389 is a reply to message #472388] Tue, 25 March 2008 03:53 Go to previous message
Eclipse User
Originally posted by: torbjorn.ghostwriter.no

Sorry, found the problem. It was a focus issue: The one view didn't give
pass its main control its focus.

"Torbj
Re: Help view doesn't update [message #610626 is a reply to message #472387] Tue, 25 March 2008 03:22 Go to previous message
Eclipse User
Originally posted by: torbjorn.ghostwriter.no

Also, I forgot to mention I'm on 3.3.

"Torbj
Re: Help view doesn't update [message #610628 is a reply to message #472388] Tue, 25 March 2008 03:53 Go to previous message
Eclipse User
Originally posted by: torbjorn.ghostwriter.no

Sorry, found the problem. It was a focus issue: The one view didn't give
pass its main control its focus.

"Torbj
Previous Topic:Help view doesn't update
Next Topic:Secure Infocenter
Goto Forum:
  


Current Time: Thu Aug 21 22:06:25 EDT 2014

Powered by FUDForum. Page generated in 0.02910 seconds