Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Platform - User Assistance (UA) » eclipse 3.2 system help
eclipse 3.2 system help [message #472379] Thu, 13 March 2008 09:17 Go to next message
Miguel is currently offline MiguelFriend
Messages: 4
Registered: July 2009
Junior Member
Hi all,

I´ve a 'little' problem with eclipse help system.

I'm building and RCP app and i´d like to include help system with some
information. My app const of two elements:

-> A plugin product: this plugin contains autentication an help system
-> A plugin: this plugin adds functionallity to the previous plugin product

If I run my app from the link "Launch the product" in Overview section
all goes ok and the help system works fine

In order to distrib my app i use a maven task. ¿How do I?

-> I remove the dependencies of my two plugins in product configuration
(if a use the export wizard i obtain circular dependencies).

-> Export the product with the Wizard an make a zip with the result
(This way i´ve a generic product with basics plugins)

-> The maven task unzip the previous zip and includes my two plugins
(the plugin product and the plugin)


When i start the app from app.exe all the application goes fine except
when i try to start help system. Eclipse says me that the embedded
application server couldn´t be started.

¿Somebody has any idea?

Thanks a lot!

PD: sorry about my english
PD2: i didn´t paste the whole exception because this message was too
long :) . If it would be useful tell it me please.
Re: eclipse 3.2 system help [message #472382 is a reply to message #472379] Fri, 14 March 2008 20:01 Go to previous message
Chris Goldthorpe is currently offline Chris GoldthorpeFriend
Messages: 815
Registered: July 2009
Senior Member
There is an article in Eclipse Corner about how to do this, it's based
on Eclipse 3.3 but if you follow the steps in 3.3 you should be able to
get things to work in 3.2.

http://www.eclipse.org/articles/article.php?file=Article-Add ingHelpToRCP/index.html

From your symptoms it seems likely that you don't have all the plugins
included that are needed to launch the help system.
Re: eclipse 3.2 system help [message #610607 is a reply to message #472379] Fri, 14 March 2008 20:01 Go to previous message
Chris Goldthorpe is currently offline Chris GoldthorpeFriend
Messages: 815
Registered: July 2009
Senior Member
There is an article in Eclipse Corner about how to do this, it's based
on Eclipse 3.3 but if you follow the steps in 3.3 you should be able to
get things to work in 3.2.

http://www.eclipse.org/articles/article.php?file=Article-Add ingHelpToRCP/index.html

From your symptoms it seems likely that you don't have all the plugins
included that are needed to launch the help system.
Previous Topic:Format of Help contexts XML file
Next Topic:Ctrl-C, Ctrl-V, or Ctrl-X doesn't work in swt widgets
Goto Forum:
  


Current Time: Thu Dec 18 08:42:12 GMT 2014

Powered by FUDForum. Page generated in 0.22905 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software