Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 Tools » Error in Drawing Position
Error in Drawing Position [message #472250] Fri, 11 January 2008 07:21 Go to next message
Raphael is currently offline Raphael
Messages: 47
Registered: July 2009
Member
Hello friends...

I downloaded the last UML2Tools version (0.8.0M4) and its dependencies.

After compile any project, when I try to draw any kind of object in the
screen, the object goes to the left/top of the screen. It never goes in
the position where I try to draw it. =(

Has anybody got this error too?!?

Thanks,
Raphael
Re: Error in Drawing Position [message #472251 is a reply to message #472250] Fri, 11 January 2008 07:52 Go to previous messageGo to next message
Michael Golubev is currently offline Michael Golubev
Messages: 373
Registered: July 2009
Senior Member
Hello Raphael,

Odd, I can not observe this in my development environment :).

Could you please try to open one of the sample diagrams (from [oeu2d.examples.class
plugin]) and check that the contents is somehow layouted.
It would allow to find whether it is the problem related to element creation
or to more general issue.

Also I would appreciate to see the error log on creating an wrong positioned
element.

Regards,
Michael

> Hello friends...
>
> I downloaded the last UML2Tools version (0.8.0M4) and its
> dependencies.
>
> After compile any project, when I try to draw any kind of object in
> the screen, the object goes to the left/top of the screen. It never
> goes in the position where I try to draw it. =(
>
> Has anybody got this error too?!?
>
> Thanks,
> Raphael
Re: Error in Drawing Position [message #472254 is a reply to message #472251] Fri, 11 January 2008 12:12 Go to previous messageGo to next message
Raphael is currently offline Raphael
Messages: 47
Registered: July 2009
Member
Hello Michael!!!

Well, when I try to run an example, it works fine, since I donŽt move any
object from its original position. If I change any object from his
original position, I got the same error.

I uploaded a print screen with the error at:
http://www.dc.ufscar.br/~raphael_oliveira/bug.JPG

I didnŽt get any error message when this error happens. The object just go
to the left/top of the window.

Thanks for your attencion,
Raphael



Michael Golubev wrote:

> Hello Raphael,

> Odd, I can not observe this in my development environment :).

> Could you please try to open one of the sample diagrams (from
[oeu2d.examples.class
> plugin]) and check that the contents is somehow layouted.
> It would allow to find whether it is the problem related to element creation
> or to more general issue.

> Also I would appreciate to see the error log on creating an wrong positioned
> element.

> Regards,
> Michael

>> Hello friends...
>>
>> I downloaded the last UML2Tools version (0.8.0M4) and its
>> dependencies.
>>
>> After compile any project, when I try to draw any kind of object in
>> the screen, the object goes to the left/top of the screen. It never
>> goes in the position where I try to draw it. =(
>>
>> Has anybody got this error too?!?
>>
>> Thanks,
>> Raphael
Re: Error in Drawing Position [message #472255 is a reply to message #472254] Fri, 11 January 2008 13:42 Go to previous messageGo to next message
Michael Golubev is currently offline Michael Golubev
Messages: 373
Registered: July 2009
Senior Member
Hello Raphael,

There are some strange things on your screenshot.
Say, the class name is truncated to "..." -- the issue covered by bugzilla
209648 that was fixed in M3 build.
Is it true that you have tried to regenerate the diagrams from gmf artifacts,
not just using the sources from repository?
Also please make sure that you are using M4 jars for depending projects,
in particular GMF runtimes and GEF.

Regards,
Michael

> Hello Michael!!!
>
> Well, when I try to run an example, it works fine, since I donŽt move
> any object from its original position. If I change any object from his
> original position, I got the same error.
>
> I uploaded a print screen with the error at:
> http://www.dc.ufscar.br/~raphael_oliveira/bug.JPG
>
> I didnŽt get any error message when this error happens. The object
> just go to the left/top of the window.
>
> Thanks for your attencion,
> Raphael
> Michael Golubev wrote:
>
>> Hello Raphael,
>>
>> Odd, I can not observe this in my development environment :).
>>
>> Could you please try to open one of the sample diagrams (from
>>
> [oeu2d.examples.class
>
>> plugin]) and check that the contents is somehow layouted. It would
>> allow to find whether it is the problem related to element creation
>> or to more general issue.
>>
>> Also I would appreciate to see the error log on creating an wrong
>> positioned element.
>>
>> Regards, Michael
>>
>>> Hello friends...
>>>
>>> I downloaded the last UML2Tools version (0.8.0M4) and its
>>> dependencies.
>>>
>>> After compile any project, when I try to draw any kind of object in
>>> the screen, the object goes to the left/top of the screen. It never
>>> goes in the position where I try to draw it. =(
>>>
>>> Has anybody got this error too?!?
>>>
>>> Thanks,
>>> Raphael
Re: Error in Drawing Position [message #472258 is a reply to message #472255] Mon, 14 January 2008 06:50 Go to previous messageGo to next message
Raphael is currently offline Raphael
Messages: 47
Registered: July 2009
Member
Hello Michael...

IŽm just using the sources from CVS, and still not working.

I tested another thing. If I select the class object and click just once
to draw it, it will be drawed where I clicked. But, if I try to move this
object, it always goes to the screen lef/top.

Another test that done: when I select the class object and try to draw it
holding on the mouse button (to create a custom size), the object goes
always to the screen lef/top.

Also, IŽm using all M4 jars and its dependencies, and the error still
happening.

Regards,
Raphael

Michael Golubev wrote:

> Hello Raphael,

> There are some strange things on your screenshot.
> Say, the class name is truncated to "..." -- the issue covered by bugzilla
> 209648 that was fixed in M3 build.
> Is it true that you have tried to regenerate the diagrams from gmf
artifacts,
> not just using the sources from repository?
> Also please make sure that you are using M4 jars for depending projects,
> in particular GMF runtimes and GEF.

> Regards,
> Michael

>> Hello Michael!!!
>>
>> Well, when I try to run an example, it works fine, since I donÅœt move
>> any object from its original position. If I change any object from his
>> original position, I got the same error.
>>
>> I uploaded a print screen with the error at:
>> http://www.dc.ufscar.br/~raphael_oliveira/bug.JPG
>>
>> I didnÅœt get any error message when this error happens. The object
>> just go to the left/top of the window.
>>
>> Thanks for your attencion,
>> Raphael
>> Michael Golubev wrote:
>>
>>> Hello Raphael,
>>>
>>> Odd, I can not observe this in my development environment :).
>>>
>>> Could you please try to open one of the sample diagrams (from
>>>
>> [oeu2d.examples.class
>>
>>> plugin]) and check that the contents is somehow layouted. It would
>>> allow to find whether it is the problem related to element creation
>>> or to more general issue.
>>>
>>> Also I would appreciate to see the error log on creating an wrong
>>> positioned element.
>>>
>>> Regards, Michael
>>>
>>>> Hello friends...
>>>>
>>>> I downloaded the last UML2Tools version (0.8.0M4) and its
>>>> dependencies.
>>>>
>>>> After compile any project, when I try to draw any kind of object in
>>>> the screen, the object goes to the left/top of the screen. It never
>>>> goes in the position where I try to draw it. =(
>>>>
>>>> Has anybody got this error too?!?
>>>>
>>>> Thanks,
>>>> Raphael
Re: Error in Drawing Position [message #472261 is a reply to message #472258] Mon, 14 January 2008 09:12 Go to previous messageGo to next message
Tatiana Fesenko is currently offline Tatiana Fesenko
Messages: 530
Registered: July 2009
Senior Member
Hello Raphael,

I installed Eclipse and UML2Tools dependencies of M4 version. Everything
works properly.

Situation you described looks strange. Is there anything in your error log?
If so, could you, please, send us its content?

Best wishes,
Tatiana.

> Hello Michael...
>
> IŽm just using the sources from CVS, and still not working.
>
> I tested another thing. If I select the class object and click just
> once to draw it, it will be drawed where I clicked. But, if I try to
> move this object, it always goes to the screen lef/top.
>
> Another test that done: when I select the class object and try to draw
> it holding on the mouse button (to create a custom size), the object
> goes always to the screen lef/top.
>
> Also, IŽm using all M4 jars and its dependencies, and the error still
> happening.
>
> Regards,
> Raphael
> Michael Golubev wrote:
>
>> Hello Raphael,
>>
>> There are some strange things on your screenshot.
>> Say, the class name is truncated to "..." -- the issue covered by
>> bugzilla
>> 209648 that was fixed in M3 build.
>> Is it true that you have tried to regenerate the diagrams from gmf
> artifacts,
>
>> not just using the sources from repository? Also please make sure
>> that you are using M4 jars for depending projects, in particular GMF
>> runtimes and GEF.
>>
>> Regards, Michael
>>
>>> Hello Michael!!!
>>>
>>> Well, when I try to run an example, it works fine, since I donÅœt
>>> move any object from its original position. If I change any object
>>> from his original position, I got the same error.
>>>
>>> I uploaded a print screen with the error at:
>>> http://www.dc.ufscar.br/~raphael_oliveira/bug.JPG
>>> I didnÅœt get any error message when this error happens. The object
>>> just go to the left/top of the window.
>>>
>>> Thanks for your attencion,
>>> Raphael
>>> Michael Golubev wrote:
>>>> Hello Raphael,
>>>>
>>>> Odd, I can not observe this in my development environment :).
>>>>
>>>> Could you please try to open one of the sample diagrams (from
>>>>
>>> [oeu2d.examples.class
>>>
>>>> plugin]) and check that the contents is somehow layouted. It would
>>>> allow to find whether it is the problem related to element creation
>>>> or to more general issue.
>>>>
>>>> Also I would appreciate to see the error log on creating an wrong
>>>> positioned element.
>>>>
>>>> Regards, Michael
>>>>
>>>>> Hello friends...
>>>>>
>>>>> I downloaded the last UML2Tools version (0.8.0M4) and its
>>>>> dependencies.
>>>>>
>>>>> After compile any project, when I try to draw any kind of object
>>>>> in the screen, the object goes to the left/top of the screen. It
>>>>> never goes in the position where I try to draw it. =(
>>>>>
>>>>> Has anybody got this error too?!?
>>>>>
>>>>> Thanks,
>>>>> Raphael
Re: Error in Drawing Position [message #472267 is a reply to message #472261] Tue, 15 January 2008 08:28 Go to previous messageGo to next message
Raphael is currently offline Raphael
Messages: 47
Registered: July 2009
Member
Hello Tatiana!

Unfortunately, in my error log there is nothing =(
Well, letŽs just check. IŽm using the following resources:

Eclipse S-3.4M4-200712131700 (Windows XP)
EMF 2.4.0M4 S200712160044
Query 1.2.0M4 S200712171224
Transaction 1.2.0M4 S200712171243
Validation 1.2.0M4 S200712171225
OCL 1.2.0M4 S200712171124
UML2 2.2.0M4 S200712170918
GEF S-3.4M4-200712181544
GMF S-2.1M4-200801071111
UML2TOOLS 0.8.0M4

Is that all right?!

Thanks for your attention!
Raphael


Tatiana Fesenko wrote:

> Hello Raphael,

> I installed Eclipse and UML2Tools dependencies of M4 version. Everything
> works properly.

> Situation you described looks strange. Is there anything in your error log?
> If so, could you, please, send us its content?

> Best wishes,
> Tatiana.

>> Hello Michael...
>>
>> IÅœm just using the sources from CVS, and still not working.
>>
>> I tested another thing. If I select the class object and click just
>> once to draw it, it will be drawed where I clicked. But, if I try to
>> move this object, it always goes to the screen lef/top.
>>
>> Another test that done: when I select the class object and try to draw
>> it holding on the mouse button (to create a custom size), the object
>> goes always to the screen lef/top.
>>
>> Also, IÅœm using all M4 jars and its dependencies, and the error still
>> happening.
>>
>> Regards,
>> Raphael
>> Michael Golubev wrote:
>>
>>> Hello Raphael,
>>>
>>> There are some strange things on your screenshot.
>>> Say, the class name is truncated to "..." -- the issue covered by
>>> bugzilla
>>> 209648 that was fixed in M3 build.
>>> Is it true that you have tried to regenerate the diagrams from gmf
>> artifacts,
>>
>>> not just using the sources from repository? Also please make sure
>>> that you are using M4 jars for depending projects, in particular GMF
>>> runtimes and GEF.
>>>
>>> Regards, Michael
>>>
>>>> Hello Michael!!!
>>>>
>>>> Well, when I try to run an example, it works fine, since I donÅœt
>>>> move any object from its original position. If I change any object
>>>> from his original position, I got the same error.
>>>>
>>>> I uploaded a print screen with the error at:
>>>> http://www.dc.ufscar.br/~raphael_oliveira/bug.JPG
>>>> I didnÅœt get any error message when this error happens. The object
>>>> just go to the left/top of the window.
>>>>
>>>> Thanks for your attencion,
>>>> Raphael
>>>> Michael Golubev wrote:
>>>>> Hello Raphael,
>>>>>
>>>>> Odd, I can not observe this in my development environment :).
>>>>>
>>>>> Could you please try to open one of the sample diagrams (from
>>>>>
>>>> [oeu2d.examples.class
>>>>
>>>>> plugin]) and check that the contents is somehow layouted. It would
>>>>> allow to find whether it is the problem related to element creation
>>>>> or to more general issue.
>>>>>
>>>>> Also I would appreciate to see the error log on creating an wrong
>>>>> positioned element.
>>>>>
>>>>> Regards, Michael
>>>>>
>>>>>> Hello friends...
>>>>>>
>>>>>> I downloaded the last UML2Tools version (0.8.0M4) and its
>>>>>> dependencies.
>>>>>>
>>>>>> After compile any project, when I try to draw any kind of object
>>>>>> in the screen, the object goes to the left/top of the screen. It
>>>>>> never goes in the position where I try to draw it. =(
>>>>>>
>>>>>> Has anybody got this error too?!?
>>>>>>
>>>>>> Thanks,
>>>>>> Raphael
Hello Tatiana
Re: Error in Drawing Position [message #472369 is a reply to message #472267] Wed, 16 January 2008 15:53 Go to previous message
Tatiana Fesenko is currently offline Tatiana Fesenko
Messages: 530
Registered: July 2009
Senior Member
Hi Raphael,

I puzzle over your problem... No ideas =(
You know both Michael and I checked it, but we have everything working correctly.

The only advice I can give is cruel - re-install everything(eclipse, uml2tools
and its dependencies) from zips clean.

Good luck,
Tatiana.

> Hello Tatiana!
>
> Unfortunately, in my error log there is nothing =( Well, letŽs just
> check. IŽm using the following resources:
>
> Eclipse S-3.4M4-200712131700 (Windows XP)
> EMF 2.4.0M4 S200712160044
> Query 1.2.0M4 S200712171224
> Transaction 1.2.0M4 S200712171243
> Validation 1.2.0M4 S200712171225
> OCL 1.2.0M4 S200712171124
> UML2 2.2.0M4 S200712170918
> GEF S-3.4M4-200712181544
> GMF S-2.1M4-200801071111
> UML2TOOLS 0.8.0M4
> Is that all right?!
>
> Thanks for your attention!
> Raphael
> Tatiana Fesenko wrote:
>
>> Hello Raphael,
>>
>> I installed Eclipse and UML2Tools dependencies of M4 version.
>> Everything works properly.
>>
>> Situation you described looks strange. Is there anything in your
>> error log? If so, could you, please, send us its content?
>>
>> Best wishes,
>> Tatiana.
>>> Hello Michael...
>>>
>>> IÅœm just using the sources from CVS, and still not working.
>>>
>>> I tested another thing. If I select the class object and click just
>>> once to draw it, it will be drawed where I clicked. But, if I try to
>>> move this object, it always goes to the screen lef/top.
>>>
>>> Another test that done: when I select the class object and try to
>>> draw it holding on the mouse button (to create a custom size), the
>>> object goes always to the screen lef/top.
>>>
>>> Also, IÅœm using all M4 jars and its dependencies, and the error
>>> still happening.
>>>
>>> Regards,
>>> Raphael
>>> Michael Golubev wrote:
>>>> Hello Raphael,
>>>>
>>>> There are some strange things on your screenshot.
>>>> Say, the class name is truncated to "..." -- the issue covered by
>>>> bugzilla
>>>> 209648 that was fixed in M3 build.
>>>> Is it true that you have tried to regenerate the diagrams from gmf
>>> artifacts,
>>>
>>>> not just using the sources from repository? Also please make sure
>>>> that you are using M4 jars for depending projects, in particular
>>>> GMF runtimes and GEF.
>>>>
>>>> Regards, Michael
>>>>
>>>>> Hello Michael!!!
>>>>>
>>>>> Well, when I try to run an example, it works fine, since I donÃ
>>>>> œt move any object from its original position. If I change any
>>>>> object from his original position, I got the same error.
>>>>>
>>>>> I uploaded a print screen with the error at:
>>>>> http://www.dc.ufscar.br/~raphael_oliveira/bug.JPG
>>>>> I didnÅœt get any error message when this error happens. The
>>>>> object
>>>>> just go to the left/top of the window.
>>>>> Thanks for your attencion,
>>>>> Raphael
>>>>> Michael Golubev wrote:
>>>>>> Hello Raphael,
>>>>>>
>>>>>> Odd, I can not observe this in my development environment :).
>>>>>>
>>>>>> Could you please try to open one of the sample diagrams (from
>>>>>>
>>>>> [oeu2d.examples.class
>>>>>
>>>>>> plugin]) and check that the contents is somehow layouted. It
>>>>>> would allow to find whether it is the problem related to element
>>>>>> creation or to more general issue.
>>>>>>
>>>>>> Also I would appreciate to see the error log on creating an wrong
>>>>>> positioned element.
>>>>>>
>>>>>> Regards, Michael
>>>>>>
>>>>>>> Hello friends...
>>>>>>>
>>>>>>> I downloaded the last UML2Tools version (0.8.0M4) and its
>>>>>>> dependencies.
>>>>>>>
>>>>>>> After compile any project, when I try to draw any kind of object
>>>>>>> in the screen, the object goes to the left/top of the screen. It
>>>>>>> never goes in the position where I try to draw it. =(
>>>>>>>
>>>>>>> Has anybody got this error too?!?
>>>>>>>
>>>>>>> Thanks,
>>>>>>> Raphael
> Hello Tatiana
>
Re: Error in Drawing Position [message #615749 is a reply to message #472250] Fri, 11 January 2008 07:52 Go to previous message
Michael Golubev is currently offline Michael Golubev
Messages: 373
Registered: July 2009
Senior Member
Hello Raphael,

Odd, I can not observe this in my development environment :).

Could you please try to open one of the sample diagrams (from [oeu2d.examples.class
plugin]) and check that the contents is somehow layouted.
It would allow to find whether it is the problem related to element creation
or to more general issue.

Also I would appreciate to see the error log on creating an wrong positioned
element.

Regards,
Michael

> Hello friends...
>
> I downloaded the last UML2Tools version (0.8.0M4) and its
> dependencies.
>
> After compile any project, when I try to draw any kind of object in
> the screen, the object goes to the left/top of the screen. It never
> goes in the position where I try to draw it. =(
>
> Has anybody got this error too?!?
>
> Thanks,
> Raphael
Re: Error in Drawing Position [message #615753 is a reply to message #472251] Fri, 11 January 2008 12:12 Go to previous message
Raphael is currently offline Raphael
Messages: 47
Registered: July 2009
Member
Hello Michael!!!

Well, when I try to run an example, it works fine, since I donŽt move any
object from its original position. If I change any object from his
original position, I got the same error.

I uploaded a print screen with the error at:
http://www.dc.ufscar.br/~raphael_oliveira/bug.JPG

I didnŽt get any error message when this error happens. The object just go
to the left/top of the window.

Thanks for your attencion,
Raphael



Michael Golubev wrote:

> Hello Raphael,

> Odd, I can not observe this in my development environment :).

> Could you please try to open one of the sample diagrams (from
[oeu2d.examples.class
> plugin]) and check that the contents is somehow layouted.
> It would allow to find whether it is the problem related to element creation
> or to more general issue.

> Also I would appreciate to see the error log on creating an wrong positioned
> element.

> Regards,
> Michael

>> Hello friends...
>>
>> I downloaded the last UML2Tools version (0.8.0M4) and its
>> dependencies.
>>
>> After compile any project, when I try to draw any kind of object in
>> the screen, the object goes to the left/top of the screen. It never
>> goes in the position where I try to draw it. =(
>>
>> Has anybody got this error too?!?
>>
>> Thanks,
>> Raphael
Re: Error in Drawing Position [message #615756 is a reply to message #472254] Fri, 11 January 2008 13:42 Go to previous message
Michael Golubev is currently offline Michael Golubev
Messages: 373
Registered: July 2009
Senior Member
Hello Raphael,

There are some strange things on your screenshot.
Say, the class name is truncated to "..." -- the issue covered by bugzilla
209648 that was fixed in M3 build.
Is it true that you have tried to regenerate the diagrams from gmf artifacts,
not just using the sources from repository?
Also please make sure that you are using M4 jars for depending projects,
in particular GMF runtimes and GEF.

Regards,
Michael

> Hello Michael!!!
>
> Well, when I try to run an example, it works fine, since I donŽt move
> any object from its original position. If I change any object from his
> original position, I got the same error.
>
> I uploaded a print screen with the error at:
> http://www.dc.ufscar.br/~raphael_oliveira/bug.JPG
>
> I didnŽt get any error message when this error happens. The object
> just go to the left/top of the window.
>
> Thanks for your attencion,
> Raphael
> Michael Golubev wrote:
>
>> Hello Raphael,
>>
>> Odd, I can not observe this in my development environment :).
>>
>> Could you please try to open one of the sample diagrams (from
>>
> [oeu2d.examples.class
>
>> plugin]) and check that the contents is somehow layouted. It would
>> allow to find whether it is the problem related to element creation
>> or to more general issue.
>>
>> Also I would appreciate to see the error log on creating an wrong
>> positioned element.
>>
>> Regards, Michael
>>
>>> Hello friends...
>>>
>>> I downloaded the last UML2Tools version (0.8.0M4) and its
>>> dependencies.
>>>
>>> After compile any project, when I try to draw any kind of object in
>>> the screen, the object goes to the left/top of the screen. It never
>>> goes in the position where I try to draw it. =(
>>>
>>> Has anybody got this error too?!?
>>>
>>> Thanks,
>>> Raphael
Re: Error in Drawing Position [message #615758 is a reply to message #472255] Mon, 14 January 2008 06:50 Go to previous message
Raphael is currently offline Raphael
Messages: 47
Registered: July 2009
Member
Hello Michael...

IŽm just using the sources from CVS, and still not working.

I tested another thing. If I select the class object and click just once
to draw it, it will be drawed where I clicked. But, if I try to move this
object, it always goes to the screen lef/top.

Another test that done: when I select the class object and try to draw it
holding on the mouse button (to create a custom size), the object goes
always to the screen lef/top.

Also, IŽm using all M4 jars and its dependencies, and the error still
happening.

Regards,
Raphael

Michael Golubev wrote:

> Hello Raphael,

> There are some strange things on your screenshot.
> Say, the class name is truncated to "..." -- the issue covered by bugzilla
> 209648 that was fixed in M3 build.
> Is it true that you have tried to regenerate the diagrams from gmf
artifacts,
> not just using the sources from repository?
> Also please make sure that you are using M4 jars for depending projects,
> in particular GMF runtimes and GEF.

> Regards,
> Michael

>> Hello Michael!!!
>>
>> Well, when I try to run an example, it works fine, since I donÅœt move
>> any object from its original position. If I change any object from his
>> original position, I got the same error.
>>
>> I uploaded a print screen with the error at:
>> http://www.dc.ufscar.br/~raphael_oliveira/bug.JPG
>>
>> I didnÅœt get any error message when this error happens. The object
>> just go to the left/top of the window.
>>
>> Thanks for your attencion,
>> Raphael
>> Michael Golubev wrote:
>>
>>> Hello Raphael,
>>>
>>> Odd, I can not observe this in my development environment :).
>>>
>>> Could you please try to open one of the sample diagrams (from
>>>
>> [oeu2d.examples.class
>>
>>> plugin]) and check that the contents is somehow layouted. It would
>>> allow to find whether it is the problem related to element creation
>>> or to more general issue.
>>>
>>> Also I would appreciate to see the error log on creating an wrong
>>> positioned element.
>>>
>>> Regards, Michael
>>>
>>>> Hello friends...
>>>>
>>>> I downloaded the last UML2Tools version (0.8.0M4) and its
>>>> dependencies.
>>>>
>>>> After compile any project, when I try to draw any kind of object in
>>>> the screen, the object goes to the left/top of the screen. It never
>>>> goes in the position where I try to draw it. =(
>>>>
>>>> Has anybody got this error too?!?
>>>>
>>>> Thanks,
>>>> Raphael
Re: Error in Drawing Position [message #615760 is a reply to message #472258] Mon, 14 January 2008 09:12 Go to previous message
Tatiana Fesenko is currently offline Tatiana Fesenko
Messages: 530
Registered: July 2009
Senior Member
Hello Raphael,

I installed Eclipse and UML2Tools dependencies of M4 version. Everything
works properly.

Situation you described looks strange. Is there anything in your error log?
If so, could you, please, send us its content?

Best wishes,
Tatiana.

> Hello Michael...
>
> IŽm just using the sources from CVS, and still not working.
>
> I tested another thing. If I select the class object and click just
> once to draw it, it will be drawed where I clicked. But, if I try to
> move this object, it always goes to the screen lef/top.
>
> Another test that done: when I select the class object and try to draw
> it holding on the mouse button (to create a custom size), the object
> goes always to the screen lef/top.
>
> Also, IŽm using all M4 jars and its dependencies, and the error still
> happening.
>
> Regards,
> Raphael
> Michael Golubev wrote:
>
>> Hello Raphael,
>>
>> There are some strange things on your screenshot.
>> Say, the class name is truncated to "..." -- the issue covered by
>> bugzilla
>> 209648 that was fixed in M3 build.
>> Is it true that you have tried to regenerate the diagrams from gmf
> artifacts,
>
>> not just using the sources from repository? Also please make sure
>> that you are using M4 jars for depending projects, in particular GMF
>> runtimes and GEF.
>>
>> Regards, Michael
>>
>>> Hello Michael!!!
>>>
>>> Well, when I try to run an example, it works fine, since I donÅœt
>>> move any object from its original position. If I change any object
>>> from his original position, I got the same error.
>>>
>>> I uploaded a print screen with the error at:
>>> http://www.dc.ufscar.br/~raphael_oliveira/bug.JPG
>>> I didnÅœt get any error message when this error happens. The object
>>> just go to the left/top of the window.
>>>
>>> Thanks for your attencion,
>>> Raphael
>>> Michael Golubev wrote:
>>>> Hello Raphael,
>>>>
>>>> Odd, I can not observe this in my development environment :).
>>>>
>>>> Could you please try to open one of the sample diagrams (from
>>>>
>>> [oeu2d.examples.class
>>>
>>>> plugin]) and check that the contents is somehow layouted. It would
>>>> allow to find whether it is the problem related to element creation
>>>> or to more general issue.
>>>>
>>>> Also I would appreciate to see the error log on creating an wrong
>>>> positioned element.
>>>>
>>>> Regards, Michael
>>>>
>>>>> Hello friends...
>>>>>
>>>>> I downloaded the last UML2Tools version (0.8.0M4) and its
>>>>> dependencies.
>>>>>
>>>>> After compile any project, when I try to draw any kind of object
>>>>> in the screen, the object goes to the left/top of the screen. It
>>>>> never goes in the position where I try to draw it. =(
>>>>>
>>>>> Has anybody got this error too?!?
>>>>>
>>>>> Thanks,
>>>>> Raphael
Re: Error in Drawing Position [message #615767 is a reply to message #472261] Tue, 15 January 2008 08:28 Go to previous message
Raphael is currently offline Raphael
Messages: 47
Registered: July 2009
Member
Hello Tatiana!

Unfortunately, in my error log there is nothing =(
Well, letŽs just check. IŽm using the following resources:

Eclipse S-3.4M4-200712131700 (Windows XP)
EMF 2.4.0M4 S200712160044
Query 1.2.0M4 S200712171224
Transaction 1.2.0M4 S200712171243
Validation 1.2.0M4 S200712171225
OCL 1.2.0M4 S200712171124
UML2 2.2.0M4 S200712170918
GEF S-3.4M4-200712181544
GMF S-2.1M4-200801071111
UML2TOOLS 0.8.0M4

Is that all right?!

Thanks for your attention!
Raphael


Tatiana Fesenko wrote:

> Hello Raphael,

> I installed Eclipse and UML2Tools dependencies of M4 version. Everything
> works properly.

> Situation you described looks strange. Is there anything in your error log?
> If so, could you, please, send us its content?

> Best wishes,
> Tatiana.

>> Hello Michael...
>>
>> IÅœm just using the sources from CVS, and still not working.
>>
>> I tested another thing. If I select the class object and click just
>> once to draw it, it will be drawed where I clicked. But, if I try to
>> move this object, it always goes to the screen lef/top.
>>
>> Another test that done: when I select the class object and try to draw
>> it holding on the mouse button (to create a custom size), the object
>> goes always to the screen lef/top.
>>
>> Also, IÅœm using all M4 jars and its dependencies, and the error still
>> happening.
>>
>> Regards,
>> Raphael
>> Michael Golubev wrote:
>>
>>> Hello Raphael,
>>>
>>> There are some strange things on your screenshot.
>>> Say, the class name is truncated to "..." -- the issue covered by
>>> bugzilla
>>> 209648 that was fixed in M3 build.
>>> Is it true that you have tried to regenerate the diagrams from gmf
>> artifacts,
>>
>>> not just using the sources from repository? Also please make sure
>>> that you are using M4 jars for depending projects, in particular GMF
>>> runtimes and GEF.
>>>
>>> Regards, Michael
>>>
>>>> Hello Michael!!!
>>>>
>>>> Well, when I try to run an example, it works fine, since I donÅœt
>>>> move any object from its original position. If I change any object
>>>> from his original position, I got the same error.
>>>>
>>>> I uploaded a print screen with the error at:
>>>> http://www.dc.ufscar.br/~raphael_oliveira/bug.JPG
>>>> I didnÅœt get any error message when this error happens. The object
>>>> just go to the left/top of the window.
>>>>
>>>> Thanks for your attencion,
>>>> Raphael
>>>> Michael Golubev wrote:
>>>>> Hello Raphael,
>>>>>
>>>>> Odd, I can not observe this in my development environment :).
>>>>>
>>>>> Could you please try to open one of the sample diagrams (from
>>>>>
>>>> [oeu2d.examples.class
>>>>
>>>>> plugin]) and check that the contents is somehow layouted. It would
>>>>> allow to find whether it is the problem related to element creation
>>>>> or to more general issue.
>>>>>
>>>>> Also I would appreciate to see the error log on creating an wrong
>>>>> positioned element.
>>>>>
>>>>> Regards, Michael
>>>>>
>>>>>> Hello friends...
>>>>>>
>>>>>> I downloaded the last UML2Tools version (0.8.0M4) and its
>>>>>> dependencies.
>>>>>>
>>>>>> After compile any project, when I try to draw any kind of object
>>>>>> in the screen, the object goes to the left/top of the screen. It
>>>>>> never goes in the position where I try to draw it. =(
>>>>>>
>>>>>> Has anybody got this error too?!?
>>>>>>
>>>>>> Thanks,
>>>>>> Raphael
Hello Tatiana
Re: Error in Drawing Position [message #616734 is a reply to message #472267] Wed, 16 January 2008 15:53 Go to previous message
Tatiana Fesenko is currently offline Tatiana Fesenko
Messages: 530
Registered: July 2009
Senior Member
Hi Raphael,

I puzzle over your problem... No ideas =(
You know both Michael and I checked it, but we have everything working correctly.

The only advice I can give is cruel - re-install everything(eclipse, uml2tools
and its dependencies) from zips clean.

Good luck,
Tatiana.

> Hello Tatiana!
>
> Unfortunately, in my error log there is nothing =( Well, letŽs just
> check. IŽm using the following resources:
>
> Eclipse S-3.4M4-200712131700 (Windows XP)
> EMF 2.4.0M4 S200712160044
> Query 1.2.0M4 S200712171224
> Transaction 1.2.0M4 S200712171243
> Validation 1.2.0M4 S200712171225
> OCL 1.2.0M4 S200712171124
> UML2 2.2.0M4 S200712170918
> GEF S-3.4M4-200712181544
> GMF S-2.1M4-200801071111
> UML2TOOLS 0.8.0M4
> Is that all right?!
>
> Thanks for your attention!
> Raphael
> Tatiana Fesenko wrote:
>
>> Hello Raphael,
>>
>> I installed Eclipse and UML2Tools dependencies of M4 version.
>> Everything works properly.
>>
>> Situation you described looks strange. Is there anything in your
>> error log? If so, could you, please, send us its content?
>>
>> Best wishes,
>> Tatiana.
>>> Hello Michael...
>>>
>>> IÅœm just using the sources from CVS, and still not working.
>>>
>>> I tested another thing. If I select the class object and click just
>>> once to draw it, it will be drawed where I clicked. But, if I try to
>>> move this object, it always goes to the screen lef/top.
>>>
>>> Another test that done: when I select the class object and try to
>>> draw it holding on the mouse button (to create a custom size), the
>>> object goes always to the screen lef/top.
>>>
>>> Also, IÅœm using all M4 jars and its dependencies, and the error
>>> still happening.
>>>
>>> Regards,
>>> Raphael
>>> Michael Golubev wrote:
>>>> Hello Raphael,
>>>>
>>>> There are some strange things on your screenshot.
>>>> Say, the class name is truncated to "..." -- the issue covered by
>>>> bugzilla
>>>> 209648 that was fixed in M3 build.
>>>> Is it true that you have tried to regenerate the diagrams from gmf
>>> artifacts,
>>>
>>>> not just using the sources from repository? Also please make sure
>>>> that you are using M4 jars for depending projects, in particular
>>>> GMF runtimes and GEF.
>>>>
>>>> Regards, Michael
>>>>
>>>>> Hello Michael!!!
>>>>>
>>>>> Well, when I try to run an example, it works fine, since I donÃ
>>>>> œt move any object from its original position. If I change any
>>>>> object from his original position, I got the same error.
>>>>>
>>>>> I uploaded a print screen with the error at:
>>>>> http://www.dc.ufscar.br/~raphael_oliveira/bug.JPG
>>>>> I didnÅœt get any error message when this error happens. The
>>>>> object
>>>>> just go to the left/top of the window.
>>>>> Thanks for your attencion,
>>>>> Raphael
>>>>> Michael Golubev wrote:
>>>>>> Hello Raphael,
>>>>>>
>>>>>> Odd, I can not observe this in my development environment :).
>>>>>>
>>>>>> Could you please try to open one of the sample diagrams (from
>>>>>>
>>>>> [oeu2d.examples.class
>>>>>
>>>>>> plugin]) and check that the contents is somehow layouted. It
>>>>>> would allow to find whether it is the problem related to element
>>>>>> creation or to more general issue.
>>>>>>
>>>>>> Also I would appreciate to see the error log on creating an wrong
>>>>>> positioned element.
>>>>>>
>>>>>> Regards, Michael
>>>>>>
>>>>>>> Hello friends...
>>>>>>>
>>>>>>> I downloaded the last UML2Tools version (0.8.0M4) and its
>>>>>>> dependencies.
>>>>>>>
>>>>>>> After compile any project, when I try to draw any kind of object
>>>>>>> in the screen, the object goes to the left/top of the screen. It
>>>>>>> never goes in the position where I try to draw it. =(
>>>>>>>
>>>>>>> Has anybody got this error too?!?
>>>>>>>
>>>>>>> Thanks,
>>>>>>> Raphael
> Hello Tatiana
>
Previous Topic:Use Case Diagrams in M4?
Next Topic:FeatureNotFoundException: requiresall
Goto Forum:
  


Current Time: Thu Apr 24 11:21:49 EDT 2014

Powered by FUDForum. Page generated in 0.09209 seconds