Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 Tools » Installing UML2 Tools
Installing UML2 Tools [message #472136] Tue, 18 December 2007 15:38 Go to next message
Raphael is currently offline Raphael
Messages: 47
Registered: July 2009
Member
Hello my friends...

IŽm new in the project UML2 Tools, and IŽm trying to install it over my
windows.

IŽve seen the build dependecies list and there is a "Eclipse 3.4 for
linux" on it.

Is there a way to install UML2 Tools over windows?!

Sorry for the question, thatŽs because I tried to install UML2 Tools in my
windows with Eclipse 3.4 and didnŽt work.

Thanks everybody,
Raphael
Re: Installing UML2 Tools [message #472139 is a reply to message #472136] Tue, 18 December 2007 16:46 Go to previous messageGo to next message
Dave Carlson is currently offline Dave Carlson
Messages: 399
Registered: July 2009
Senior Member
That build dependency for linux just reflects what was used in the automated
build environment. It should install and run fine under windows (with the
other platform independent features, e.g. EMF, UML2, etc).

See my previous post to Gary about using the update manager.

Dave

>
> I
Re: Installing UML2 Tools [message #472143 is a reply to message #472139] Wed, 19 December 2007 08:05 Go to previous messageGo to next message
Raphael is currently offline Raphael
Messages: 47
Registered: July 2009
Member
Thanks Dave!

I installed UML2 Tools 0.7.1 with it build dependencies list and it works
fine!

Now itŽs time to understand UML2 tools... =D

Thanks a lot,
Raphael
Re: Installing UML2 Tools [message #472174 is a reply to message #472143] Mon, 31 December 2007 18:41 Go to previous messageGo to next message
Eclipse User
Originally posted by: ayman_java.yahoo.com

Iam trying to install UMLTools over windows with eclipse Version: 3.3.1.1.
I tried first to download all dependencies it doesn't work, I tried
install manager, it also didn't work. I can see the org.eclipse.uml2tools
in the feature details, seems nothing wrong. but I can't see New/Other/UML
2.1 Diagrams in the new project, any help?!!
Re: Installing UML2 Tools [message #472176 is a reply to message #472174] Wed, 02 January 2008 07:37 Go to previous messageGo to next message
Tatiana Fesenko is currently offline Tatiana Fesenko
Messages: 530
Registered: July 2009
Senior Member
Hello ayman,

Do you mean you succesfully installed all the required plugins and after
that you cannot find 'New/Other/UML 2.1 Diagrams' menu item?
Do you have anything in your Error Log? If yes, please send us its content.
Probably it will help us to solve the problem.

Best regards,
Tatiana.

> Iam trying to install UMLTools over windows with eclipse Version:
> 3.3.1.1. I tried first to download all dependencies it doesn't work,
> I tried install manager, it also didn't work. I can see the
> org.eclipse.uml2tools in the feature details, seems nothing wrong. but
> I can't see New/Other/UML 2.1 Diagrams in the new project, any help?!!
>
Re: Installing UML2 Tools [message #472711 is a reply to message #472176] Fri, 25 January 2008 08:18 Go to previous messageGo to next message
Eclipse User
Originally posted by: regnstrom.flowtech.se

Tatiana Fesenko wrote:

> Hello ayman,

> Do you mean you succesfully installed all the required plugins and after
> that you cannot find 'New/Other/UML 2.1 Diagrams' menu item?
> Do you have anything in your Error Log? If yes, please send us its content.
> Probably it will help us to solve the problem.

Hello Tatiana,

The above exactly describes my problem. The file .metadata/.log shows
nothing, are there any other log files? Does uml2tools require Java5?

Best regards,
Bjorn
Re: Installing UML2 Tools [message #472714 is a reply to message #472711] Fri, 25 January 2008 09:56 Go to previous messageGo to next message
Ed Merks is currently offline Ed Merks
Messages: 25746
Registered: July 2009
Senior Member
Bjorn,

Yes because EMF requires Java 5.0. It's quite useful to clear the error
log (either the view or remove <workspace>/.metadata/.log) run Eclipse
with -clean -debug, and look closely at the logged messages. If plugins
are disabled, it will explain what dependencies are missing, or if Java
5.0 is needed but isn't available, it will give messages about that.


Bjorn Regnstrom wrote:
> Tatiana Fesenko wrote:
>
>> Hello ayman,
>
>> Do you mean you succesfully installed all the required plugins and
>> after that you cannot find 'New/Other/UML 2.1 Diagrams' menu item? Do
>> you have anything in your Error Log? If yes, please send us its
>> content. Probably it will help us to solve the problem.
>
> Hello Tatiana,
>
> The above exactly describes my problem. The file .metadata/.log shows
> nothing, are there any other log files? Does uml2tools require Java5?
>
> Best regards,
> Bjorn
>
Re: Installing UML2 Tools [message #472717 is a reply to message #472711] Fri, 25 January 2008 09:57 Go to previous message
Tatiana Fesenko is currently offline Tatiana Fesenko
Messages: 530
Registered: July 2009
Senior Member
Hi Bjorn,

Yes, it is. Look at http://www.eclipse.org/modeling/mdt/downloads/?project=uml2t ools:
Build Dependencies:
sun-java2-5.0

Best wishes,
Tatiana.

> Tatiana Fesenko wrote:
>
>> Hello ayman,
>>
>> Do you mean you succesfully installed all the required plugins and
>> after that you cannot find 'New/Other/UML 2.1 Diagrams' menu item? Do
>> you have anything in your Error Log? If yes, please send us its
>> content. Probably it will help us to solve the problem.
>>
> Hello Tatiana,
>
> The above exactly describes my problem. The file .metadata/.log shows
> nothing, are there any other log files? Does uml2tools require Java5?
>
> Best regards,
> Bjorn
Re: Installing UML2 Tools [message #611650 is a reply to message #472136] Tue, 18 December 2007 16:46 Go to previous message
Dave Carlson is currently offline Dave Carlson
Messages: 399
Registered: July 2009
Senior Member
That build dependency for linux just reflects what was used in the automated
build environment. It should install and run fine under windows (with the
other platform independent features, e.g. EMF, UML2, etc).

See my previous post to Gary about using the update manager.

Dave

>
> I
Re: Installing UML2 Tools [message #611656 is a reply to message #472139] Wed, 19 December 2007 08:05 Go to previous message
Raphael is currently offline Raphael
Messages: 47
Registered: July 2009
Member
Thanks Dave!

I installed UML2 Tools 0.7.1 with it build dependencies list and it works
fine!

Now itŽs time to understand UML2 tools... =D

Thanks a lot,
Raphael
Re: Installing UML2 Tools [message #614539 is a reply to message #472143] Mon, 31 December 2007 18:41 Go to previous message
Eclipse User
Originally posted by: ayman_java.yahoo.com

Iam trying to install UMLTools over windows with eclipse Version: 3.3.1.1.
I tried first to download all dependencies it doesn't work, I tried
install manager, it also didn't work. I can see the org.eclipse.uml2tools
in the feature details, seems nothing wrong. but I can't see New/Other/UML
2.1 Diagrams in the new project, any help?!!
Re: Installing UML2 Tools [message #614541 is a reply to message #472174] Wed, 02 January 2008 07:37 Go to previous message
Tatiana Fesenko is currently offline Tatiana Fesenko
Messages: 530
Registered: July 2009
Senior Member
Hello ayman,

Do you mean you succesfully installed all the required plugins and after
that you cannot find 'New/Other/UML 2.1 Diagrams' menu item?
Do you have anything in your Error Log? If yes, please send us its content.
Probably it will help us to solve the problem.

Best regards,
Tatiana.

> Iam trying to install UMLTools over windows with eclipse Version:
> 3.3.1.1. I tried first to download all dependencies it doesn't work,
> I tried install manager, it also didn't work. I can see the
> org.eclipse.uml2tools in the feature details, seems nothing wrong. but
> I can't see New/Other/UML 2.1 Diagrams in the new project, any help?!!
>
Re: Installing UML2 Tools [message #617567 is a reply to message #472176] Fri, 25 January 2008 08:18 Go to previous message
Eclipse User
Originally posted by: regnstrom.flowtech.se

Tatiana Fesenko wrote:

> Hello ayman,

> Do you mean you succesfully installed all the required plugins and after
> that you cannot find 'New/Other/UML 2.1 Diagrams' menu item?
> Do you have anything in your Error Log? If yes, please send us its content.
> Probably it will help us to solve the problem.

Hello Tatiana,

The above exactly describes my problem. The file .metadata/.log shows
nothing, are there any other log files? Does uml2tools require Java5?

Best regards,
Bjorn
Re: Installing UML2 Tools [message #617571 is a reply to message #472711] Fri, 25 January 2008 09:56 Go to previous message
Ed Merks is currently offline Ed Merks
Messages: 25746
Registered: July 2009
Senior Member
Bjorn,

Yes because EMF requires Java 5.0. It's quite useful to clear the error
log (either the view or remove <workspace>/.metadata/.log) run Eclipse
with -clean -debug, and look closely at the logged messages. If plugins
are disabled, it will explain what dependencies are missing, or if Java
5.0 is needed but isn't available, it will give messages about that.


Bjorn Regnstrom wrote:
> Tatiana Fesenko wrote:
>
>> Hello ayman,
>
>> Do you mean you succesfully installed all the required plugins and
>> after that you cannot find 'New/Other/UML 2.1 Diagrams' menu item? Do
>> you have anything in your Error Log? If yes, please send us its
>> content. Probably it will help us to solve the problem.
>
> Hello Tatiana,
>
> The above exactly describes my problem. The file .metadata/.log shows
> nothing, are there any other log files? Does uml2tools require Java5?
>
> Best regards,
> Bjorn
>
Re: Installing UML2 Tools [message #617573 is a reply to message #472711] Fri, 25 January 2008 09:57 Go to previous message
Tatiana Fesenko is currently offline Tatiana Fesenko
Messages: 530
Registered: July 2009
Senior Member
Hi Bjorn,

Yes, it is. Look at http://www.eclipse.org/modeling/mdt/downloads/?project=uml2t ools:
Build Dependencies:
sun-java2-5.0

Best wishes,
Tatiana.

> Tatiana Fesenko wrote:
>
>> Hello ayman,
>>
>> Do you mean you succesfully installed all the required plugins and
>> after that you cannot find 'New/Other/UML 2.1 Diagrams' menu item? Do
>> you have anything in your Error Log? If yes, please send us its
>> content. Probably it will help us to solve the problem.
>>
> Hello Tatiana,
>
> The above exactly describes my problem. The file .metadata/.log shows
> nothing, are there any other log files? Does uml2tools require Java5?
>
> Best regards,
> Bjorn
Previous Topic:Loop Nodes and Conditional Nodes in Activity Diagrams
Next Topic:Which UML2 "Diagram Element" should be selected for GMF
Goto Forum:
  


Current Time: Sat Apr 19 05:56:30 EDT 2014

Powered by FUDForum. Page generated in 0.03813 seconds