Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 Tools » org.eclipse.emf.query (1.0.1) - where is it?
org.eclipse.emf.query (1.0.1) - where is it? [message #472134] Tue, 18 December 2007 19:51 Go to next message
Gary is currently offline Gary
Messages: 10
Registered: July 2009
Junior Member
All:

I have been trying to install the UML2 Tools Component. I have been
painfully searching for and downloading the necessary plugins, with their
necessary prerequisites, according to the installation instructions found
at: http://wiki.eclipse.org/MDT-UML2Tools, (topic: "How can I start with
UML2Tools?"). I have been using the Eclipse download manager to complete
these tasks.

I have gotten to the point where each time I use the update manager and
select the "MDT UMLTOOLS SDK (Incubation) 0.7.1", I keep getting this
error message when I select certain features to install:

" UML2 Diagramming (Incubation) (0.7.1.v200710010534) requires feature
"org.eclipse.emf.query (1.0.1)", or compatible."

I'm thinking that because I have yet to include this plugin in my eclipse
environment I do not see the " 'org.eclipse.uml2tools' " in my Feature
Details when I click on Help/About Eclipse SDK, again as per the
instructions found on the same web page.

Now, I don't know if this makes any difference or not, but I do see a
org.eclipse.emf.query_1.1.0.v200706071712.jar in my \eclipse\plugins
directory.

Anyway, can anybody assist? Does anybody know where on the Eclipse site I
can find this exact feature and version that the update manager keeps
telling me I need in order to successfully install and use the UML2 Tools
Component?

Thx to all for your response and happy holidays.
Gary
Re: org.eclipse.emf.query (1.0.1) - where is it? [message #472137 is a reply to message #472134] Tue, 18 December 2007 21:43 Go to previous message
Dave Carlson is currently offline Dave Carlson
Messages: 399
Registered: July 2009
Senior Member
Gary,
The easiest (and much less painful) way to use update manager is to just
click the Select Required button. However, for that to work, you must
expand the top-level category containing the dependencies. So, if
installing in a 3.3 workbench, select UML2Tools, expand Europa category,
then click Select Required. Should get everything you need that is not
already in your config.

For the update manager to work, the *features* are needed in your workbench
config, not only the plugins. So even if you have the query plugin (as you
indicated), also check that you have the query feature present. But "Select
Required" should get it if not already installed.

Hope this helps,
Dave Carlson

> Now, I don't know if this makes any difference or not, but I do see a
> org.eclipse.emf.query_1.1.0.v200706071712.jar in my \eclipse\plugins
> directory.
>
> Anyway, can anybody assist? Does anybody know where on the Eclipse site I
> can find this exact feature and version that the update manager keeps
> telling me I need in order to successfully install and use the UML2 Tools
> Component?
>
> Thx to all for your response and happy holidays.
> Gary
>
Re: org.eclipse.emf.query (1.0.1) - where is it? [message #611649 is a reply to message #472134] Tue, 18 December 2007 21:43 Go to previous message
Dave Carlson is currently offline Dave Carlson
Messages: 399
Registered: July 2009
Senior Member
Gary,
The easiest (and much less painful) way to use update manager is to just
click the Select Required button. However, for that to work, you must
expand the top-level category containing the dependencies. So, if
installing in a 3.3 workbench, select UML2Tools, expand Europa category,
then click Select Required. Should get everything you need that is not
already in your config.

For the update manager to work, the *features* are needed in your workbench
config, not only the plugins. So even if you have the query plugin (as you
indicated), also check that you have the query feature present. But "Select
Required" should get it if not already installed.

Hope this helps,
Dave Carlson

> Now, I don't know if this makes any difference or not, but I do see a
> org.eclipse.emf.query_1.1.0.v200706071712.jar in my \eclipse\plugins
> directory.
>
> Anyway, can anybody assist? Does anybody know where on the Eclipse site I
> can find this exact feature and version that the update manager keeps
> telling me I need in order to successfully install and use the UML2 Tools
> Component?
>
> Thx to all for your response and happy holidays.
> Gary
>
Previous Topic:Installing UML2 Tools
Next Topic:Re: Problem with classDiagram.gmfmap
Goto Forum:
  


Current Time: Wed Oct 22 06:33:23 GMT 2014

Powered by FUDForum. Page generated in 0.08716 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software