Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Platform - User Assistance (UA) » Infocenter WAR file does not deploy on JBoss 4.2.1.GA - LogConfigurationException: No suitable Log c
Infocenter WAR file does not deploy on JBoss 4.2.1.GA - LogConfigurationException: No suitable Log c [message #471452] Wed, 16 January 2008 22:06 Go to next message
Peter Desjardins is currently offline Peter DesjardinsFriend
Messages: 21
Registered: July 2009
Junior Member
I've gotten my Infocenter WAR file to run on JBoss 4.0.1 just fine. I
need to support JBoss 4.2.1. On 4.2.1, the Infocenter WAR fails to
deploy and I see this error in the server log.

008-01-16 13:34:10,655 ERROR
[org.apache.catalina.core.ContainerBase.[jboss.web].[localho st].[/nexus-5-0-admin].[equinoxbridgeservlet]]

Servlet.service() for servlet equinoxbridgeservlet threw exception
org.apache.commons.logging.LogConfigurationException:
org.apache.commons.logging.LogConfigurationException: No suitable Log
constructor [Ljava.lang.Class;@1a88328 for
org.apache.commons.logging.impl.Log4JLogger (Caused by
java.lang.NoClassDefFoundError: org/apache/log4j/Category) (Caused by
org.apache.commons.logging.LogConfigurationException: No suitable Log
constructor [Ljava.lang.Class;@1a88328 for
org.apache.commons.logging.impl.Log4JLogger (Caused by
java.lang.NoClassDefFoundError: org/apache/log4j/Category))

The JBoss 4.2.1 release notes indicate that: "log4j and commons-logging
have both been upgraded. commons-logging is patched in addition,
JBAS-2823."

The WAR file template for the Infocenter contains
org.apache.commons.logging_1.0.4.v200706111724.jar. Would upgrading
that JAR to version 1.1.1 be a likely solution?

I tried including the log4j.jar file from JBoss 4.0.1 in the plugins
directory of my WAR file and also the WEB-INF/lib/ directories. In the
plugins directory, there was no effect at all. In the lib directory, I
saw log4j errors like this one:

16:53:38,011 ERROR [STDERR] log4j:ERROR A
"org.jboss.logging.appender.FileAppender" object is not assignable to a
"org.apache.log4j.Appender" variable.

Any suggestions would be much appreciated.

Thanks.

Peter
Re: Infocenter WAR file does not deploy on JBoss 4.2.1.GA - LogConfigurationExce [message #474553 is a reply to message #471452] Thu, 25 September 2008 15:06 Go to previous message
Matt Holcomb is currently offline Matt HolcombFriend
Messages: 2
Registered: July 2009
Junior Member
Peter, have you ever found the cause to this issue? I am having the same
problems and have not had luck in resolving it so far.
Re: Infocenter WAR file does not deploy on JBoss 4.2.1.GA - LogConfigurationExce [message #619899 is a reply to message #471452] Thu, 25 September 2008 15:06 Go to previous message
Matt Holcomb is currently offline Matt HolcombFriend
Messages: 2
Registered: July 2009
Junior Member
Peter, have you ever found the cause to this issue? I am having the same
problems and have not had luck in resolving it so far.
Previous Topic:Dropins folder not being rescanned
Next Topic:Where to include cheatsheets?
Goto Forum:
  


Current Time: Wed Nov 26 03:25:33 GMT 2014

Powered by FUDForum. Page generated in 0.01619 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software