Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » Subversive is 'mutating' .svn files to higher revision, breaking other clients
Subversive is 'mutating' .svn files to higher revision, breaking other clients [message #47867] Thu, 25 June 2009 19:27 Go to next message
Mike Norman is currently offline Mike NormanFriend
Messages: 35
Registered: July 2009
Member
I am trying to setup a brand new Galileo environment. I am using
eclipse-jee-galileo-win32.zip and added:
- Subversive SVN Team Provider (Incubation) 0.7.8.I20090506-1500
- Subversive SVN Connectors 2.2.0.I20090505-1500
- JavaHL 1.5.4 Win32 Binaries 2.2.0.I20090505-1500
With this combination, I can connect to the SVN server at the Eclipse
Foundation.

However, the Foundation is running a v 1.4 server (r21228; see 'Powered by'
at the bottom of
http://dev.eclipse.org/svnroot/rt/org.eclipse.persistence/tr unk)
We are experiencing problems tunnelling svn+ssh thru our corporate
HTTP proxy/firewall - svn clients v1.5 and v1.6 experience hangs and
generally poor performance.

So, my 'outside-of-eclipse' SVN client is v1.4 based - however, updates
done 'inside-of-eclipse' result in:

Error: This client is too old to work with working copy
'C:\_eclipselink\trunk\dbws\org.eclipse.persistence.dbws\MET A-INF'; please
get a newer Subversion client

Is there any configuration to tell the provider/connector or native win32
binaries to leave the working copy at the 1.4-format?
Re: Subversive is 'mutating' .svn files to higher revision, breaking other clients [message #47897 is a reply to message #47867] Fri, 26 June 2009 07:45 Go to previous message
Jörg Thönnes is currently offline Jörg ThönnesFriend
Messages: 229
Registered: July 2009
Senior Member
Hi Mike,

it is not good idea to mix SVN formats inside and outside Eclipse. I do not use JavaHL, but SVNKit
since it is pure java and independent from native libraries. And starting with Subversive 0.7.8,
only SVNKit 1.2.* is supported, which in turn supports SVN 1.5 and 1.6. Therefore, we have started
to upgrade our out-side-of-eclipse clients to SVN 1.5 to match this. Otherwise, we would have to
stay at an older version of Subversive (0.7.7) and corresponding SVNKit.

So either you downgrade to Subversive 0.7.7 and use related Polarion connectors or (what I would
suggest) you upgrade your local SVN client from 1.4. to 1.5. It would still work with a 1.4 server
as we do so. Then you could upgrade your complete working copy by doing "svn cleanup" in the head of
the working copy. The "format" file in the .svn sub-folders would then go from "8" (1.4) to "9" (1.5.).

Feel free to ask for further details if you need so. We still use Eclipse 3.3.2, so I cannot answer
3.4 or 3.5 related questions yet.

Cheers, Jörg

On 06/25/09 21:27, Mike Norman wrote:
> I am trying to setup a brand new Galileo environment. I am using
> eclipse-jee-galileo-win32.zip and added:
> - Subversive SVN Team Provider (Incubation) 0.7.8.I20090506-1500
> - Subversive SVN Connectors 2.2.0.I20090505-1500
> - JavaHL 1.5.4 Win32 Binaries 2.2.0.I20090505-1500
> With this combination, I can connect to the SVN server at the Eclipse
> Foundation.
>
> However, the Foundation is running a v 1.4 server (r21228; see 'Powered by'
> at the bottom of
> http://dev.eclipse.org/svnroot/rt/org.eclipse.persistence/tr unk)
> We are experiencing problems tunnelling svn+ssh thru our corporate
> HTTP proxy/firewall - svn clients v1.5 and v1.6 experience hangs and
> generally poor performance.
>
> So, my 'outside-of-eclipse' SVN client is v1.4 based - however, updates
> done 'inside-of-eclipse' result in:
>
> Error: This client is too old to work with working copy
> 'C:\_eclipselink\trunk\dbws\org.eclipse.persistence.dbws\MET A-INF';
> please get a newer Subversion client
> Is there any configuration to tell the provider/connector or native
> win32 binaries to leave the working copy at the 1.4-format?
>
Previous Topic:Error: unable connect...
Next Topic:New Merge dialog?
Goto Forum:
  


Current Time: Mon Nov 24 07:07:46 GMT 2014

Powered by FUDForum. Page generated in 0.02437 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software