Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » M2M (model-to-model transformation) » [ATL] Developing a plugin which executes ATL transformations
[ATL] Developing a plugin which executes ATL transformations [message #47861] Thu, 21 June 2007 09:12 Go to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
Hello,
I am new in developing Eclipse plugins. I have defined several ATL
transformations and I would like to create a Eclipse plugin which executes
the sequence of transformations automatically. I think that I need ATL
classes to call those defined transformations.
Does anybody know what classes I need? Has anybody tried to develop such
kind of plugin?
Thanks in advance.
Bea
Re: [ATL] Developing a plugin which executes ATL transformations [message #47951 is a reply to message #47861] Thu, 21 June 2007 11:48 Go to previous messageGo to next message
Frédéric Jouault is currently offline Frédéric JouaultFriend
Messages: 572
Registered: July 2009
Senior Member
Hello,


> I am new in developing Eclipse plugins. I have defined several ATL
> transformations and I would like to create a Eclipse plugin which
executes
> the sequence of transformations automatically. I think that I need ATL
> classes to call those defined transformations.
> Does anybody know what classes I need? Has anybody tried to develop such
> kind of plugin?
> Thanks in advance.

The KM3 plugin does execute ATL transformations:
http://dev.eclipse.org/viewcvs/index.cgi/org.eclipse.gmt/AM3 /org.eclipse.gmt.am3.dsls.km3/?root=Technology_Project

and more especially the KM3Projector class:
http://dev.eclipse.org/viewcvs/index.cgi/org.eclipse.gmt/AM3 /org.eclipse.gmt.am3.dsls.km3/src/org/eclipse/gmt/am3/dsls/k m3/KM3Projector.java?revision=1.4&root=Technology_Projec t&view=markup


Regards,

Frédéric Jouault
Re: [ATL] Developing a plugin which executes ATL transformations [message #48042 is a reply to message #47951] Thu, 21 June 2007 13:50 Go to previous messageGo to next message
Dennis Wagelaar is currently offline Dennis WagelaarFriend
Messages: 147
Registered: July 2009
Senior Member
Frédéric Jouault schreef:
> Hello,
>

Hi,

>
> > I am new in developing Eclipse plugins. I have defined several ATL
> > transformations and I would like to create a Eclipse plugin which
> executes
> > the sequence of transformations automatically. I think that I need ATL
> > classes to call those defined transformations.
> > Does anybody know what classes I need? Has anybody tried to develop such
> > kind of plugin?
> > Thanks in advance.
>
> The KM3 plugin does execute ATL transformations:
> http://dev.eclipse.org/viewcvs/index.cgi/org.eclipse.gmt/AM3 /org.eclipse.gmt.am3.dsls.km3/?root=Technology_Project
>
>
> and more especially the KM3Projector class:
> http://dev.eclipse.org/viewcvs/index.cgi/org.eclipse.gmt/AM3 /org.eclipse.gmt.am3.dsls.km3/src/org/eclipse/gmt/am3/dsls/k m3/KM3Projector.java?revision=1.4&root=Technology_Projec t&view=markup
>
>
>
> Regards,
>
> Frédéric Jouault

The instant messenger configuration editor also invokes ATL
transformations to generate a build.xml file from a configuration model:

http://ssel.vub.ac.be/viewcvs/viewcvs.py/UML2CaseStudies/uml 2cs-instantmessenger-config-editor/

http://ssel.vub.ac.be/viewcvs/viewcvs.py/UML2CaseStudies/uml 2cs-instantmessenger-config-editor/src/be/ac/vub/uml2cs/inst antmessenger/popup/actions/GenerateBuildFileAction.java?view =markup

Regards,
Dennis

P.S. The instant messenger is part of
http://ssel.vub.ac.be/ssel/research:mdd:casestudies
Re: [ATL] Developing a plugin which executes ATL transformations [message #48132 is a reply to message #47861] Thu, 21 June 2007 15:35 Go to previous messageGo to next message
urs zeidler is currently offline urs zeidlerFriend
Messages: 91
Registered: July 2009
Member
Bea schrieb:
> Hello,
> I am new in developing Eclipse plugins. I have defined several ATL
> transformations and I would like to create a Eclipse plugin which executes
> the sequence of transformations automatically. I think that I need ATL
> classes to call those defined transformations.
> Does anybody know what classes I need? Has anybody tried to develop such
> kind of plugin?
> Thanks in advance.
> Bea
>
>
I have developed a graphical execution board for ATL.
There you can link transformations together to a flow.



http://opensource.urszeidler.de/ATLflow/updatesite/

a small briefing can be found here :
http://opensource.urszeidler.de/ATLflow/html/

It's based on the Topcased Diagram Modeler.

greetings urs.
Re: [ATL] Developing a plugin which executes ATL transformations [message #48178 is a reply to message #48042] Thu, 21 June 2007 16:20 Go to previous messageGo to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
The "problem" is that I use other plugins and I would like to run the
transformations defined in ATL together with other transformations defined
using other plugins.

I would like to define an ANT script (or use ATL classes but I don't know
what classes) with the sequence of transformations in ATL and later invoke
this script from my plugin. The problem is that I don't find how to invoke
this files or what ATL classes I can use.
Does anybody can help me?
Thank you




"Dennis Wagelaar" <dennis.wagelaar@vub.ac.be> escribi
Re: [ATL] Developing a plugin which executes ATL transformations [message #48205 is a reply to message #48178] Thu, 21 June 2007 16:37 Go to previous messageGo to next message
urs zeidler is currently offline urs zeidlerFriend
Messages: 91
Registered: July 2009
Member
Bea schrieb:
> The "problem" is that I use other plugins and I would like to run the
> transformations defined in ATL together with other transformations defined
> using other plugins.
>
> I would like to define an ANT script (or use ATL classes but I don't know
> what classes) with the sequence of transformations in ATL and later invoke
> this script from my plugin. The problem is that I don't find how to invoke
> this files or what ATL classes I can use.
> Does anybody can help me?
> Thank you
>
>

As Frédéric mentioned AM3 comes with antTasks see
http://wiki.eclipse.org/AM3_Ant_Tasks .

To start ATL programmatically see
http://wiki.eclipse.org/index.php/ATL_Howtos#Solution
or search this newsgroup.

I'm just curios, what other transformations do you want to execute ?

greetings, urs.
Re: [ATL] Developing a plugin which executes ATL transformations [message #48235 is a reply to message #48205] Thu, 21 June 2007 16:41 Go to previous messageGo to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
I use MOFScript for model to text transformations and ATL for model to model
transformations. So I would like to create a plugin which execute the
defined transformations in the order I want.
Do you know how I can invoke an ANT script?
Thanks


"urs zeidler" <ich@urszeidler.de> escribi
Re: [ATL] Developing a plugin which executes ATL transformations [message #48265 is a reply to message #48235] Thu, 21 June 2007 17:04 Go to previous messageGo to next message
urs zeidler is currently offline urs zeidlerFriend
Messages: 91
Registered: July 2009
Member
Bea schrieb:
> I use MOFScript for model to text transformations and ATL for model to model
> transformations. So I would like to create a plugin which execute the
> defined transformations in the order I want.
> Do you know how I can invoke an ANT script?
> Thanks
>
You can start ANT like an other process :

Process process = Runtime.getRuntime().exec(cmd);


or with the launcher :
org.apache.tools.ant.launch.Launcher

see ANT manual
http://ant.apache.org/manual/index.html

greetings, urs.
Re: [ATL] Developing a plugin which executes ATL transformations [message #48385 is a reply to message #48265] Fri, 22 June 2007 10:43 Go to previous messageGo to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
Hello again
I have problems with am3.loadmodel sentence. I get the error "Ant could not
find the task or a class this task relies upon.".
In my build.xml file I have:

<am3.loadModel modelHandler="EMF" name="UML2" metamodel="MOF"
path="uri:http://www.eclipse.org/uml2/1.0.0/UML"/>

I have the plugin org.eclipse.gmt.am3.tools.ant installed but I thinnk that
it doesn't work Any idea?
Thank you.



"urs zeidler" <ich@urszeidler.de> escribi
Re: [ATL] Developing a plugin which executes ATL transformations [message #48415 is a reply to message #48385] Fri, 22 June 2007 11:59 Go to previous messageGo to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
I think that the problem is that eclipse doesn't find the
org.eclipse.gmt.am3.tools.ant_1.0.0.20070619.jar. I have tried with right
click on the build.xml and selecting the second Ant run. In the classpath
section I have added that .jar but it doesn't work.



"Bea" <beaperez@unizar.es> escribi
Re: [ATL] Developing a plugin which executes ATL transformations [message #48523 is a reply to message #48415] Mon, 25 June 2007 07:43 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: quentin.glineur.obeo.fr

Hi,

I think your problem comes from the way you launch the ant build :

Try to configure the launch as follow :
-right click the ant file: run as...
-under the refresh tab select refresh the entire workspace
-under the jre tab select "run in the same jre as the workspace"

Regards,

Quentin


Bea a écrit :
> I think that the problem is that eclipse doesn't find the
> org.eclipse.gmt.am3.tools.ant_1.0.0.20070619.jar. I have tried with right
> click on the build.xml and selecting the second Ant run. In the classpath
> section I have added that .jar but it doesn't work.
>
>
>
> "Bea" <beaperez@unizar.es> escribió en el mensaje
> news:f5g94g$qv7$1@build.eclipse.org...
>> Hello again
>> I have problems with am3.loadmodel sentence. I get the error "Ant could
>> not find the task or a class this task relies upon.".
>> In my build.xml file I have:
>>
>> <am3.loadModel modelHandler="EMF" name="UML2" metamodel="MOF"
>> path="uri:http://www.eclipse.org/uml2/1.0.0/UML"/>
>>
>> I have the plugin org.eclipse.gmt.am3.tools.ant installed but I thinnk
>> that it doesn't work Any idea?
>> Thank you.
>>
>>
>>
>> "urs zeidler" <ich@urszeidler.de> escribió en el mensaje
>> news:f5eb34$3jo$1@build.eclipse.org...
>>> Bea schrieb:
>>>> I use MOFScript for model to text transformations and ATL for model to
>>>> model transformations. So I would like to create a plugin which execute
>>>> the defined transformations in the order I want.
>>>> Do you know how I can invoke an ANT script?
>>>> Thanks
>>>>
>>> You can start ANT like an other process :
>>>
>>> Process process = Runtime.getRuntime().exec(cmd);
>>>
>>>
>>> or with the launcher :
>>> org.apache.tools.ant.launch.Launcher
>>>
>>> see ANT manual
>>> http://ant.apache.org/manual/index.html
>>>
>>> greetings, urs.
>>
>
>
Re: [ATL] Developing a plugin which executes ATL transformations [message #48551 is a reply to message #48523] Mon, 25 June 2007 08:03 Go to previous messageGo to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
Hi,
thank you for your help, but I have already tried it, but it doesn't work. I
don't know what to do then, any idea?


"Quentin Glineur" <quentin.glineur@obeo.fr> escribi
Re: [ATL] Developing a plugin which executes ATL transformations [message #48611 is a reply to message #48551] Mon, 25 June 2007 08:26 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: quentin.glineur.obeo.fr

Then, I am not sure but you may try to use this form for the am3.loadModel :

<am3.loadModel name="UML2" metamodel="MOF"
nsUri="http://www.eclipse.org/uml2/1.0.0/UML" />

This is the way I load model registered by an uri.

Bea a écrit :
> Hi,
> thank you for your help, but I have already tried it, but it doesn't work. I
> don't know what to do then, any idea?
>
>
> "Quentin Glineur" <quentin.glineur@obeo.fr> escribió en el mensaje
> news:f5nrmf$gp2$1@build.eclipse.org...
>> Hi,
>>
>> I think your problem comes from the way you launch the ant build :
>>
>> Try to configure the launch as follow :
>> -right click the ant file: run as...
>> -under the refresh tab select refresh the entire workspace
>> -under the jre tab select "run in the same jre as the workspace"
>>
>> Regards,
>>
>> Quentin
>>
>>
>> Bea a écrit :
>>> I think that the problem is that eclipse doesn't find the
>>> org.eclipse.gmt.am3.tools.ant_1.0.0.20070619.jar. I have tried with
>>> right click on the build.xml and selecting the second Ant run. In the
>>> classpath section I have added that .jar but it doesn't work.
>>>
>>>
>>>
>>> "Bea" <beaperez@unizar.es> escribió en el mensaje
>>> news:f5g94g$qv7$1@build.eclipse.org...
>>>> Hello again
>>>> I have problems with am3.loadmodel sentence. I get the error "Ant could
>>>> not find the task or a class this task relies upon.".
>>>> In my build.xml file I have:
>>>>
>>>> <am3.loadModel modelHandler="EMF" name="UML2" metamodel="MOF"
>>>> path="uri:http://www.eclipse.org/uml2/1.0.0/UML"/>
>>>>
>>>> I have the plugin org.eclipse.gmt.am3.tools.ant installed but I thinnk
>>>> that it doesn't work Any idea?
>>>> Thank you.
>>>>
>>>>
>>>>
>>>> "urs zeidler" <ich@urszeidler.de> escribió en el mensaje
>>>> news:f5eb34$3jo$1@build.eclipse.org...
>>>>> Bea schrieb:
>>>>>> I use MOFScript for model to text transformations and ATL for model to
>>>>>> model transformations. So I would like to create a plugin which
>>>>>> execute the defined transformations in the order I want.
>>>>>> Do you know how I can invoke an ANT script?
>>>>>> Thanks
>>>>>>
>>>>> You can start ANT like an other process :
>>>>>
>>>>> Process process = Runtime.getRuntime().exec(cmd);
>>>>>
>>>>>
>>>>> or with the launcher :
>>>>> org.apache.tools.ant.launch.Launcher
>>>>>
>>>>> see ANT manual
>>>>> http://ant.apache.org/manual/index.html
>>>>>
>>>>> greetings, urs.
>
Re: [ATL] Developing a plugin which executes ATL transformations [message #48701 is a reply to message #48611] Mon, 25 June 2007 08:54 Go to previous messageGo to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
Hi,
thank you again but it doesn't work yet. I think that the problem is the
plugin. I have tried with the pack
http://www.sciences.univ-nantes.fr/lina/atl/www/atldemo/ATLB undle_20070217.zip
and with this version, the metamodel is loaded (then, the am3.loadmodel
works) but I can't use it because all my models are created using UML2 1.0.0
and this pack is for Eclipse 3.2 and UML2 2.0.0. Could you tell me what
version of ATL and AM3 do you use, and where can I find it?

Thank you again in advance
Bea


"Quentin Glineur" <quentin.glineur@obeo.fr> escribi
Re: [ATL] Developing a plugin which executes ATL transformations [message #48731 is a reply to message #48701] Mon, 25 June 2007 09:15 Go to previous messageGo to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
I have seen in the web that some people use ATLBundle-20060501 but I can't
find it. Doues anybody know where I can find it?





"Bea" <beaperez@unizar.es> escribi
Re: [ATL] Developing a plugin which executes ATL transformations [message #48758 is a reply to message #48731] Mon, 25 June 2007 10:31 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: quentin.glineur.obeo.fr

Currently, I am using:
- Eclipse Version: 3.2.2,
- ATL 1.0.7
- AM3 1.0.0
- and UML2 2.0.3
from http://www.eclipse.org/m2m/atl/download/.
But considering your problem, I don't think this will help you as the
version I use is pretty similar to the bundle.

You can find the ATLBundle-20060501 at
http://www.sciences.univ-nantes.fr/lina/atl/www/atldemo/ATLB undle-20060501.zip

Quentin


Bea a écrit :
> I have seen in the web that some people use ATLBundle-20060501 but I can't
> find it. Doues anybody know where I can find it?
>
>
>
>
>
> "Bea" <beaperez@unizar.es> escribió en el mensaje
> news:f5nvt1$qs2$1@build.eclipse.org...
>> Hi,
>> thank you again but it doesn't work yet. I think that the problem is the
>> plugin. I have tried with the pack
>> http://www.sciences.univ-nantes.fr/lina/atl/www/atldemo/ATLB undle_20070217.zip
>> and with this version, the metamodel is loaded (then, the am3.loadmodel
>> works) but I can't use it because all my models are created using UML2
>> 1.0.0 and this pack is for Eclipse 3.2 and UML2 2.0.0. Could you tell me
>> what version of ATL and AM3 do you use, and where can I find it?
>>
>> Thank you again in advance
>> Bea
>>
>>
>> "Quentin Glineur" <quentin.glineur@obeo.fr> escribió en el mensaje
>> news:f5nu74$n1i$1@build.eclipse.org...
>>> Then, I am not sure but you may try to use this form for the
>>> am3.loadModel :
>>>
>>> <am3.loadModel name="UML2" metamodel="MOF"
>>> nsUri="http://www.eclipse.org/uml2/1.0.0/UML" />
>>>
>>> This is the way I load model registered by an uri.
>>>
>>> Bea a écrit :
>>>> Hi,
>>>> thank you for your help, but I have already tried it, but it doesn't
>>>> work. I don't know what to do then, any idea?
>>>>
>>>>
>>>> "Quentin Glineur" <quentin.glineur@obeo.fr> escribió en el mensaje
>>>> news:f5nrmf$gp2$1@build.eclipse.org...
>>>>> Hi,
>>>>>
>>>>> I think your problem comes from the way you launch the ant build :
>>>>>
>>>>> Try to configure the launch as follow :
>>>>> -right click the ant file: run as...
>>>>> -under the refresh tab select refresh the entire workspace
>>>>> -under the jre tab select "run in the same jre as the workspace"
>>>>>
>>>>> Regards,
>>>>>
>>>>> Quentin
>>>>>
>>>>>
>>>>> Bea a écrit :
>>>>>> I think that the problem is that eclipse doesn't find the
>>>>>> org.eclipse.gmt.am3.tools.ant_1.0.0.20070619.jar. I have tried with
>>>>>> right click on the build.xml and selecting the second Ant run. In the
>>>>>> classpath section I have added that .jar but it doesn't work.
>>>>>>
>>>>>>
>>>>>>
>>>>>> "Bea" <beaperez@unizar.es> escribió en el mensaje
>>>>>> news:f5g94g$qv7$1@build.eclipse.org...
>>>>>>> Hello again
>>>>>>> I have problems with am3.loadmodel sentence. I get the error "Ant
>>>>>>> could not find the task or a class this task relies upon.".
>>>>>>> In my build.xml file I have:
>>>>>>>
>>>>>>> <am3.loadModel modelHandler="EMF" name="UML2" metamodel="MOF"
>>>>>>> path="uri:http://www.eclipse.org/uml2/1.0.0/UML"/>
>>>>>>>
>>>>>>> I have the plugin org.eclipse.gmt.am3.tools.ant installed but I
>>>>>>> thinnk that it doesn't work Any idea?
>>>>>>> Thank you.
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> "urs zeidler" <ich@urszeidler.de> escribió en el mensaje
>>>>>>> news:f5eb34$3jo$1@build.eclipse.org...
>>>>>>>> Bea schrieb:
>>>>>>>>> I use MOFScript for model to text transformations and ATL for model
>>>>>>>>> to model transformations. So I would like to create a plugin which
>>>>>>>>> execute the defined transformations in the order I want.
>>>>>>>>> Do you know how I can invoke an ANT script?
>>>>>>>>> Thanks
>>>>>>>>>
>>>>>>>> You can start ANT like an other process :
>>>>>>>>
>>>>>>>> Process process = Runtime.getRuntime().exec(cmd);
>>>>>>>>
>>>>>>>>
>>>>>>>> or with the launcher :
>>>>>>>> org.apache.tools.ant.launch.Launcher
>>>>>>>>
>>>>>>>> see ANT manual
>>>>>>>> http://ant.apache.org/manual/index.html
>>>>>>>>
>>>>>>>> greetings, urs.
>>
>
>
Re: [ATL] Developing a plugin which executes ATL transformations [message #48786 is a reply to message #48758] Mon, 25 June 2007 10:38 Go to previous messageGo to next message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
Hi,
Thank you, that works!!! Although I have other problems, it works. All
models are loaded but when the transformation is running I get the error:

[am3.atl] Executing ATL transformation
/Plugin/ATLFiles/First/transformation.asm

[am3.atl] ****** BEGIN Stack Trace

[am3.atl] message: ERROR: OclUndefined has no property




"Quentin Glineur" <quentin.glineur@obeo.fr> escribi
Re: [ATL] Developing a plugin which executes ATL transformations [message #48815 is a reply to message #48786] Mon, 25 June 2007 10:57 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: quentin.glineur.obeo.fr

Bea a écrit :
> Hi,
> Thank you, that works!!!

Great !

Although I have other problems, it works.

Can you please tell what you have changed to make it work ?

Regards,
Quentin

All
> models are loaded but when the transformation is running I get the error:
>
> [am3.atl] Executing ATL transformation
> /Plugin/ATLFiles/First/transformation.asm
>
> [am3.atl] ****** BEGIN Stack Trace
>
> [am3.atl] message: ERROR: OclUndefined has no property
>
>
>
>
> "Quentin Glineur" <quentin.glineur@obeo.fr> escribió en el mensaje
> news:f5o5h7$i4b$1@build.eclipse.org...
>> Currently, I am using:
>> - Eclipse Version: 3.2.2,
>> - ATL 1.0.7
>> - AM3 1.0.0
>> - and UML2 2.0.3
>> from http://www.eclipse.org/m2m/atl/download/.
>> But considering your problem, I don't think this will help you as the
>> version I use is pretty similar to the bundle.
>>
>> You can find the ATLBundle-20060501 at
>> http://www.sciences.univ-nantes.fr/lina/atl/www/atldemo/ATLB undle-20060501.zip
>>
>> Quentin
>>
>>
>> Bea a écrit :
>>> I have seen in the web that some people use ATLBundle-20060501 but I
>>> can't find it. Doues anybody know where I can find it?
>>>
>>>
>>>
>>>
>>>
>>> "Bea" <beaperez@unizar.es> escribió en el mensaje
>>> news:f5nvt1$qs2$1@build.eclipse.org...
>>>> Hi,
>>>> thank you again but it doesn't work yet. I think that the problem is the
>>>> plugin. I have tried with the pack
>>>> http://www.sciences.univ-nantes.fr/lina/atl/www/atldemo/ATLB undle_20070217.zip
>>>> and with this version, the metamodel is loaded (then, the am3.loadmodel
>>>> works) but I can't use it because all my models are created using UML2
>>>> 1.0.0 and this pack is for Eclipse 3.2 and UML2 2.0.0. Could you tell me
>>>> what version of ATL and AM3 do you use, and where can I find it?
>>>>
>>>> Thank you again in advance
>>>> Bea
>>>>
>>>>
>>>> "Quentin Glineur" <quentin.glineur@obeo.fr> escribió en el mensaje
>>>> news:f5nu74$n1i$1@build.eclipse.org...
>>>>> Then, I am not sure but you may try to use this form for the
>>>>> am3.loadModel :
>>>>>
>>>>> <am3.loadModel name="UML2" metamodel="MOF"
>>>>> nsUri="http://www.eclipse.org/uml2/1.0.0/UML" />
>>>>>
>>>>> This is the way I load model registered by an uri.
>>>>>
>>>>> Bea a écrit :
>>>>>> Hi,
>>>>>> thank you for your help, but I have already tried it, but it doesn't
>>>>>> work. I don't know what to do then, any idea?
>>>>>>
>>>>>>
>>>>>> "Quentin Glineur" <quentin.glineur@obeo.fr> escribió en el mensaje
>>>>>> news:f5nrmf$gp2$1@build.eclipse.org...
>>>>>>> Hi,
>>>>>>>
>>>>>>> I think your problem comes from the way you launch the ant build :
>>>>>>>
>>>>>>> Try to configure the launch as follow :
>>>>>>> -right click the ant file: run as...
>>>>>>> -under the refresh tab select refresh the entire workspace
>>>>>>> -under the jre tab select "run in the same jre as the workspace"
>>>>>>>
>>>>>>> Regards,
>>>>>>>
>>>>>>> Quentin
>>>>>>>
>>>>>>>
>>>>>>> Bea a écrit :
>>>>>>>> I think that the problem is that eclipse doesn't find the
>>>>>>>> org.eclipse.gmt.am3.tools.ant_1.0.0.20070619.jar. I have tried with
>>>>>>>> right click on the build.xml and selecting the second Ant run. In
>>>>>>>> the classpath section I have added that .jar but it doesn't work.
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> "Bea" <beaperez@unizar.es> escribió en el mensaje
>>>>>>>> news:f5g94g$qv7$1@build.eclipse.org...
>>>>>>>>> Hello again
>>>>>>>>> I have problems with am3.loadmodel sentence. I get the error "Ant
>>>>>>>>> could not find the task or a class this task relies upon.".
>>>>>>>>> In my build.xml file I have:
>>>>>>>>>
>>>>>>>>> <am3.loadModel modelHandler="EMF" name="UML2" metamodel="MOF"
>>>>>>>>> path="uri:http://www.eclipse.org/uml2/1.0.0/UML"/>
>>>>>>>>>
>>>>>>>>> I have the plugin org.eclipse.gmt.am3.tools.ant installed but I
>>>>>>>>> thinnk that it doesn't work Any idea?
>>>>>>>>> Thank you.
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> "urs zeidler" <ich@urszeidler.de> escribió en el mensaje
>>>>>>>>> news:f5eb34$3jo$1@build.eclipse.org...
>>>>>>>>>> Bea schrieb:
>>>>>>>>>>> I use MOFScript for model to text transformations and ATL for
>>>>>>>>>>> model to model transformations. So I would like to create a
>>>>>>>>>>> plugin which execute the defined transformations in the order I
>>>>>>>>>>> want.
>>>>>>>>>>> Do you know how I can invoke an ANT script?
>>>>>>>>>>> Thanks
>>>>>>>>>>>
>>>>>>>>>> You can start ANT like an other process :
>>>>>>>>>>
>>>>>>>>>> Process process = Runtime.getRuntime().exec(cmd);
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> or with the launcher :
>>>>>>>>>> org.apache.tools.ant.launch.Launcher
>>>>>>>>>>
>>>>>>>>>> see ANT manual
>>>>>>>>>> http://ant.apache.org/manual/index.html
>>>>>>>>>>
>>>>>>>>>> greetings, urs.
>
Re: [ATL] Developing a plugin which executes ATL transformations [message #48845 is a reply to message #48815] Mon, 25 June 2007 10:59 Go to previous message
beaperez Mising name is currently offline beaperez Mising nameFriend
Messages: 81
Registered: July 2009
Member
I have only installed the ATLBundle-20060501 + the UML2 1.0.0 plugin.

"Quentin Glineur" <quentin.glineur@obeo.fr> escribi
Previous Topic:[ATL]should the passed in name be same with the package name in KM3?
Next Topic:Re-Posting my question... Can I use ATL to apply a profile to a UML model?
Goto Forum:
  


Current Time: Fri Dec 19 14:37:13 GMT 2014

Powered by FUDForum. Page generated in 0.09276 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software