Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EPF » WAR - Search - Weblogic 10
WAR - Search - Weblogic 10 [message #47710] Mon, 04 February 2008 07:21 Go to next message
danny foncke is currently offline danny fonckeFriend
Messages: 92
Registered: July 2009
Member
hi,

Search fails on Weblogic 10.
When you click the search button, nothing happens
No messages, no logs, nothing

all help appreciated

Danny
Re: WAR - Search - Weblogic 10 [message #47743 is a reply to message #47710] Mon, 04 February 2008 09:56 Go to previous messageGo to next message
danny foncke is currently offline danny fonckeFriend
Messages: 92
Registered: July 2009
Member
Same error as in previous posting
-> indexpath = null

questions : why ?

trace:
LD> searchString: doormat
convert doormat -> doormat
LD> _indexPath: null
LD> _currentSearchString: doormat
LD> unicodes: doormat
LD> analyzerName: null
LD> _hits: null
java.lang.NullPointerException
at
org.eclipse.epf.web.servlet.SearchServlet.runQuery(SearchSer vlet.java
:206)

danny wrote:
> hi,
>
> Search fails on Weblogic 10.
> When you click the search button, nothing happens
> No messages, no logs, nothing
>
> all help appreciated
>
> Danny
Re: WAR - Search - Weblogic 10 [message #48031 is a reply to message #47710] Wed, 13 February 2008 14:10 Go to previous messageGo to next message
danny foncke is currently offline danny fonckeFriend
Messages: 92
Registered: July 2009
Member
problem solved

getrealpath(..) is the cause


danny wrote:
> hi,
>
> Search fails on Weblogic 10.
> When you click the search button, nothing happens
> No messages, no logs, nothing
>
> all help appreciated
>
> Danny
Re: WAR - Search - Weblogic 10 [message #48061 is a reply to message #48031] Wed, 13 February 2008 21:00 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: storaskar.xx.xxx.xxx

more details please :)

If you did change EPF code, we would appreciate you creating bugzilla and
then attaching a patch so that we can send it across in next release to
rest of EPF community.

Thanks in advance.

Regards,
Shilpa
Re: WAR - Search - Weblogic 10 [message #48089 is a reply to message #48061] Thu, 14 February 2008 06:54 Go to previous message
danny foncke is currently offline danny fonckeFriend
Messages: 92
Registered: July 2009
Member
no changes to EPF code

some investigation lead to the following line (in searchServlet) being
the cause :
_indexPath =
config.getServletContext().getRealPath(config.getInitParamet er( "searchIndex"));

some further investigation learned that getRealPath(...) doesn't work
well when the war is deployed as an archive (not exploded)

-> in WebLogic 10 there is a flag :
"Archived Real Path enabled" which you need to set to get
'getRealPath()' working correctly

-> problem solved :)

(I have no clue why that flag isn't set by default - which is a bit
worrying now)


Shilpa Toraskar wrote:
> more details please :)
>
> If you did change EPF code, we would appreciate you creating bugzilla
> and then attaching a patch so that we can send it across in next release
> to rest of EPF community.
>
> Thanks in advance.
>
> Regards,
> Shilpa
>
Re: WAR - Search - Weblogic 10 [message #588352 is a reply to message #47710] Mon, 04 February 2008 09:56 Go to previous message
danny foncke is currently offline danny fonckeFriend
Messages: 92
Registered: July 2009
Member
Same error as in previous posting
-> indexpath = null

questions : why ?

trace:
LD> searchString: doormat
convert doormat -> doormat
LD> _indexPath: null
LD> _currentSearchString: doormat
LD> unicodes: doormat
LD> analyzerName: null
LD> _hits: null
java.lang.NullPointerException
at
org.eclipse.epf.web.servlet.SearchServlet.runQuery(SearchSer vlet.java
:206)

danny wrote:
> hi,
>
> Search fails on Weblogic 10.
> When you click the search button, nothing happens
> No messages, no logs, nothing
>
> all help appreciated
>
> Danny
Re: WAR - Search - Weblogic 10 [message #588440 is a reply to message #47710] Wed, 13 February 2008 14:10 Go to previous message
danny foncke is currently offline danny fonckeFriend
Messages: 92
Registered: July 2009
Member
problem solved

getrealpath(..) is the cause


danny wrote:
> hi,
>
> Search fails on Weblogic 10.
> When you click the search button, nothing happens
> No messages, no logs, nothing
>
> all help appreciated
>
> Danny
Re: WAR - Search - Weblogic 10 [message #588449 is a reply to message #48031] Wed, 13 February 2008 21:00 Go to previous message
Shilpa Toraskar is currently offline Shilpa ToraskarFriend
Messages: 102
Registered: July 2009
Senior Member
more details please :)

If you did change EPF code, we would appreciate you creating bugzilla and
then attaching a patch so that we can send it across in next release to
rest of EPF community.

Thanks in advance.

Regards,
Shilpa
Re: WAR - Search - Weblogic 10 [message #588450 is a reply to message #48061] Thu, 14 February 2008 06:54 Go to previous message
danny foncke is currently offline danny fonckeFriend
Messages: 92
Registered: July 2009
Member
no changes to EPF code

some investigation lead to the following line (in searchServlet) being
the cause :
_indexPath =
config.getServletContext().getRealPath(config.getInitParamet er( "searchIndex"));

some further investigation learned that getRealPath(...) doesn't work
well when the war is deployed as an archive (not exploded)

-> in WebLogic 10 there is a flag :
"Archived Real Path enabled" which you need to set to get
'getRealPath()' working correctly

-> problem solved :)

(I have no clue why that flag isn't set by default - which is a bit
worrying now)


Shilpa Toraskar wrote:
> more details please :)
>
> If you did change EPF code, we would appreciate you creating bugzilla
> and then attaching a patch so that we can send it across in next release
> to rest of EPF community.
>
> Thanks in advance.
>
> Regards,
> Shilpa
>
Previous Topic:searchservlet source code
Next Topic:H2 Automatically Generate Feedback with contextual mailto ?
Goto Forum:
  


Current Time: Mon Dec 22 08:39:44 GMT 2014

Powered by FUDForum. Page generated in 0.06752 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software