Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » DSDP - Device Debugging » Problem in debugging with DSF.
Problem in debugging with DSF. [message #470108] Tue, 06 January 2009 08:12 Go to next message
Dmitri Pikus is currently offline Dmitri PikusFriend
Messages: 4
Registered: July 2009
Junior Member
Hi,

I have several problems when using DSF.

Environment:
OS: Windows XP Professional, SP2.
Eclipse: 3.4.1
CDT: 5.0.1
DSF: 1.1.0 - latest plugins taken from CVS (dev.eclipse.org, /cvsroot/dsdp)
Debugged application: simple C application with single method( main() )
that contains several printouts.

SCENARIO1:
1. Line breakpoint without actions is set.
2. Application is debugged with DSF.

Problem1: Threads change to 'Suspended' state, but call stack isn't shown.
Problem2: Line with reached breakpoint isn't colored.
Problem3: The following mesages are displayed in console:
mi_cmd_stack_info_depth: Usage: [MAX_DEPTH]
mi_cmd_stack_list_frames: Usage: [FRAME_LOW FRAME_HIGH]
mi_cmd_stack_info_depth: Usage: [MAX_DEPTH]

==============================================

SCENARIO2:
1. Line breakpoint without Resume action is set.
2. Application is debugged with DSF.
Problem: ClassCastException happens:
org.eclipse.dd.gdb.internal.provisional.service.command.GDBC ontrolDMContext
incompatible with
org.eclipse.dd.dsf.debug.service.IRunControl$IExecutionDMCon text

Changing GDBControlDMContext class to implement IExecutionDMContext
doesn't help much:
I see problems 1 and 2 as in scenario 1, and message
'mi_cmd_stack_info_depth: Usage: [MAX_DEPTH]' is displayed.


Sincerely,
Dmitri Pikus
Re: Problem in debugging with DSF. [message #470109 is a reply to message #470108] Tue, 06 January 2009 08:36 Go to previous message
Dmitri Pikus is currently offline Dmitri PikusFriend
Messages: 4
Registered: July 2009
Junior Member
1. There is a misprint in my original post:
In SCENARIO2, Line breakpoint WITH Resume action is set.

2. There is also the problem with the Update Policy selection not showing
in the variables view menu.

Thanks!

Sincerely,
Dmitri Pikus.
Re: Problem in debugging with DSF. [message #590455 is a reply to message #470108] Tue, 06 January 2009 08:36 Go to previous message
Dmitri Pikus is currently offline Dmitri PikusFriend
Messages: 4
Registered: July 2009
Junior Member
1. There is a misprint in my original post:
In SCENARIO2, Line breakpoint WITH Resume action is set.

2. There is also the problem with the Update Policy selection not showing
in the variables view menu.

Thanks!

Sincerely,
Dmitri Pikus.
Previous Topic:Problem in debugging with DSF.
Next Topic:Projects on DSDP-DD
Goto Forum:
  


Current Time: Mon Dec 22 05:14:29 GMT 2014

Powered by FUDForum. Page generated in 0.09774 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software