Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » AMW » cannot compile sources
cannot compile sources [message #469854] Tue, 24 February 2009 04:05 Go to next message
Aram Hovsepyan is currently offline Aram Hovsepyan
Messages: 34
Registered: July 2009
Member
Hi Marcos,
I've been struggling for a week already trying to install AMW from the
commited sources but it just won't work. I keep on getting error messages.
I still get errors that KM3_ANTLR3Parser.java depends on TCS.

Could you please help me fix it.
Thanks
Re: cannot compile sources [message #469855 is a reply to message #469854] Tue, 24 February 2009 04:44 Go to previous messageGo to next message
Juan Pedro Silva is currently offline Juan Pedro Silva
Messages: 258
Registered: July 2009
Senior Member
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-15"
http-equiv="Content-Type">
<title></title>
</head>
<body bgcolor="#ffffff" text="#000000">
Hi Aram, check <a
href="news://news.eclipse.org:119/gidr0q$jo4$1@build.eclipse.org">this
post</a> from Marcos.<br>
Regards,<br>
             Juan Pedro<br>
<br>
Aram Hovsepyan escribió:
<blockquote
cite="mid:01fc8fb08887413e7a22862cf7727924$1@www.eclipse.org"
type="cite">Hi Marcos,
<br>
I've been struggling for a week already trying to install AMW from the
commited sources but it just won't work. I keep on getting error
messages.
<br>
I still get errors that KM3_ANTLR3Parser.java depends on TCS.
<br>
<br>
Could you please help me fix it.
<br>
Thanks
<br>
<br>
<br>
<br>
</blockquote>
</body>
</html>
Re: cannot compile sources [message #469856 is a reply to message #469854] Tue, 24 February 2009 09:38 Go to previous messageGo to next message
user is currently offline user
Messages: 296
Registered: July 2009
Senior Member
Thnx Juan. I've managed to install it, however, I still get errors when
I try to create a new model weaving specification. On the first screen
where I select the km3 model it seems ok but when I click next I get the
following error:

Unresolved compilation problems:
the type org.eclipse.m2m.atl.engine.AtlModelHandler cannot be resolved.
the import org.eclipse.m2m.atl.engine.AtlEMFModelHandler cnanot be resolved

I have ATL and ATL SDK installed from the eclipse update sites.

thnx

Aram Hovsepyan wrote:
> Hi Marcos,
> I've been struggling for a week already trying to install AMW from the
> commited sources but it just won't work. I keep on getting error messages.
> I still get errors that KM3_ANTLR3Parser.java depends on TCS.
>
> Could you please help me fix it.
> Thanks
>
>
>
Re: cannot compile sources [message #469857 is a reply to message #469856] Wed, 25 February 2009 08:04 Go to previous messageGo to next message
Marcos Didonet Del Fabro is currently offline Marcos Didonet Del Fabro
Messages: 84
Registered: July 2009
Member
Hello,

the AMW sources have been tested only with ATL branch "R2_1_0dev", and
"old" AM3. Not sure it will work with the update site.

Marcos.
cannot install amw [message #469858 is a reply to message #469856] Wed, 11 March 2009 06:31 Go to previous messageGo to next message
Aram Hovsepyan is currently offline Aram Hovsepyan
Messages: 34
Registered: July 2009
Member
Hi guys,

Its been almost a month since I'm trying to install all possible
variations of AMW on my Mac. Could it be that AMW never works on MAC?

The same version works perfectly on linux and windows but not on the
Mac. The error I've seen the most is bad version of .class file.

thnx.
Re: cannot install amw [message #469859 is a reply to message #469858] Thu, 12 March 2009 08:32 Go to previous message
Marcos Didonet Del Fabro is currently offline Marcos Didonet Del Fabro
Messages: 84
Registered: July 2009
Member
Hello,

One possible cause to this error is an incompatible version of JRE that
you are using. You should use JRE 1.6.x, because some jars used by AMW
(e.g., KM3-parser.jar) were generated using 1.6.x.

Regards,

Marcos.
Previous Topic:An internal error occurred during: "Launching...
Next Topic:Can not install AMW on Eclipse 3.4.2
Goto Forum:
  


Current Time: Fri Apr 18 10:12:24 EDT 2014

Powered by FUDForum. Page generated in 0.01790 seconds